Problems about battery, WiFi, callsGeneral


  1. shvraka

    shvraka New Member

    Hello guys,

    I have an LG Optimus 2x, bought from my telecom operator about month ago, running stock android 2.2 .2 and I am starting to have some strange problems.

    - Sometimes I can not turn on WiFi. It starts, and it says "turning on WiFi" but then is says "error" and nothing happens. Then I have to restart the phone, and everything works fine. I do not want to restart my phone, if I want to check my email or smth quickly.

    - Yesterday I had this problem with battery. It was 30% in the morning, and after about an hour the phone turned off by itself. I turned it back on, and it was 5%, I do not know how. It stayed all day on 5, and when I came back home I plug it in, and after couple of hours it said 9%, and not moving forward. I turned it off, plugged the battery out and put it back, turned on, and it was showing 91%, and everything worked normally.

    - My girlfriend is sometimes angry with me because I did not answer her call. the problem is the phone did not register any call. I looked at calls history, and nothing, but on her phone I can see that she really called me.

    - Also some problems with running aps. I can not turn off some aps, others are starting by themself, and the app "advanced task killer" can not close some of them.

    Please, does anyone knows any solution to this problem. Because it is becoming really annoying, and I am frustrated that this is happening on the phone of this class.

    Thank you,
    best regards ;))

    Advertisement
    :
  2. Rusty

    Rusty Well-Known Member

    If you haven't yet, update the software, earlier builds were terrible.
  3. shvraka

    shvraka New Member

    Thank you for the info,

    but I am new to all this, and is there any manual, or tutorial, or any advice how to update the software???

    I have tried directly from the phone and nothing happens ;(
  4. Rusty

    Rusty Well-Known Member

    The LG update tool would be a good bet.
  5. zemigsan

    zemigsan New Member

    I have got exactly the same problems..

    And this is already the second LG P990 (i changed my first one because of this)..

    I tried the update but it seems that is already in the last version (v10c)

    any solution? :(
Loading...

Share This Page