Problems after Android 4.4.2 KitKat update Galaxy S4Support


Last Updated: 2014-05-27 00:49:24
  1. s1mon87

    s1mon87 Active Member

    My phone constantly displays 'no service' even when it has got full signal. I can't access voicemail because when I press and hold number 1 it comes up saying 'voicemail number missing' but it won't let me manually add the number because it's all greyed out. I can no longer move things to my memory card because every time I try it comes up 'failed'. I've tried factory resets and all the other pointless stuff the mobile network advises you to do such as selecting networks automatically etc. All to no avail. Everything worked perfect before the update and I'd even go as far as saying that I no longer like the phone as ac result of it and I'm really wishing I'd have stayed with HTC.

    If anyone out there has had these issues could you please advise me on what you did to sort it?

    My phone is not rooted nor is it network locked. It's the European version GT-I9505. The update was the official Samsung update that was pushed to my phone in March.

    Thank you.

    Advertisement
  2. anoniemouse

    anoniemouse Well-Known Member

  3. nickdalzell

    nickdalzell Well-Known Member Contributor

    and folks wonder why i refuse outright to update my fully-functioning phone to KitKat. this and tons of other threads here explain why.
  4. anoniemouse

    anoniemouse Well-Known Member

    Thats my sentiments exactly, mine is staying where it is on 4.3 fully functional too
  5. dragula2012

    dragula2012 Well-Known Member

    hello , s1mon87. download the firmware from sammobile and flash it back.
    I'm running kitkat on a s4 international versi
  6. nickdalzell

    nickdalzell Well-Known Member Contributor

    the 4.3 update killed 4G on my S3 at home, and i use my phone as a hotspot for internet at home, as i have no other options (live in a remote area without phone or cable lines). losing 4G meant dial-up speeds with slow 3G or worse, unusable speeds at 1xRTT. the only reason i actually updated my S3 was because it was required for the Galaxy Gear to work with it (i didn't have the cash for the S4 or Note 3)

    it essentially slowed the device down much like iOS 7 slows down earlier iPhone 4's. it's just better to keep the Android version that shipped with your device if you want the same speeds and network stability. my 4G LTE comes in pretty strong on my new S4, and i would not feel good chancing it with the update and hoping i don't go back to dialup again.

    Basically could never understand the fanatical addiction with having the most latest version of everything, including Android or apps in general. most updates change the entire UI to an unfamiliar state where you have to relearn everything (new photobucket app comes to mind, plus it uses like 50 MB vs. the 1-2 the old one did) or removes features. why would anyone want reduced function anyway?
  7. speedlever

    speedlever Well-Known Member

    Which also made me wary as well.

    However, now that my GS4 auto-updated without my permission, I've not found any issues as a result of the update. But it's still early yet. I'll post if I run into problems.
  8. Shocky

    Shocky On Probation

    You get this sometimes when flashing new roms without the correct modem, never seen it happen from an OTA update though.

    Your best bet would be to flash an official stock Samsung rom using odin and hope it corrects the issue.

    I believe I'm still correct in saying flash counter and knox is not triggered by official roms, so long as you don't try flashing any jellybean roms.
  9. sreum

    sreum Well-Known Member

    Yeah I have the same issues and there only getting worse. My solution is I contacted my carrier to send me a new phone free of charge in hopes that it will have 4.3 on it. And not do the update. Just wish they would go back to 4.2!!!!!
  10. tattoogunman

    tattoogunman Member

    I updated to 4.4.2 this morning without knowing of any of the problems it was having. I only did the update because over the last week or so, my phone (AT&T Samsung Galaxy S4) has started having issues after being completely problem free for about a year. It started draining the battery excessively (even though I normally get about 3-4 days out of a charge since I am NOT a heavy phone user), it was not connecting to the network so I wasn't getting signal (no phone, no texts, etc.), it wouldn't connect to the internet, etc. I figured that maybe they had done an update to fix these issues, so that's why I updated.

    Anyway, after doing the update, my wi-fi would not connect or even turn on. I did some searching around the 'net and found that if I took the battery out and put it back in, it fixed the problem. Since this seems to be a common problem, I figured this might help out others. After doing the battery in/out, it's working fine.
  11. sreum

    sreum Well-Known Member

    Hopefully you don't start having connectivity issues.

Share This Page