Problems installing/running custom recovery


  1. labeledbass

    labeledbass Well-Known Member

    Hello there, been a while but I noticed this phones bootloader has been freed so I've decided to try to get a custom ROM or two on here.

    I've followed directions to a T, I'm just not able to enter any custom recovery. I tried TWRP first and couldn't get into it (entering fastboot>recovery ended up with the android !) and then CWR (entering fastboot boot recovery cwm.img returned <bootloader> command restricted failure remote failure). Now I would have thought I haven't unlocked the phone but in fastboot it states "UNLOCKED" "Status code 3", and I receive the warning at the beginning of every boot now. I've checked root and its there, and I have a new clean copy of SU.

    Any clues to what's going on? Help would greatly be appreciated, I've waited long enough with a locked phone coming from so many other "free" devices.

    Thank you so much! any questions please ask -

    Ver. 4.1.2 - (stock rooted)
    Kernel 3.031 -ge491d6d
    Build 9.8.1Q-66
    Unlocked via Motopocalypse.zip

    Advertisement
  2. labeledbass

    labeledbass Well-Known Member

    UPDATE:

    I've updated the drivers on my PC, tried to re-flash both recoverys thinking something didn't take and this is what I get - Hopefully this will help.

    fastboot flash recovery cwm.img
    <bootloader> variable not supported!
    target reported max download size of 31457280 bytes
    sending 'recovery' (7594 KB)...
    OKAY [ 0.608s ]
    writing 'recovery' ...
    OKAY [ 2.309s ]
    finished. total 2.978s

    When I try to boot into recovery via fastboot -

    fastboot boot cwm.img
    downloading 'boot.img '...
    OK [ .535s ]
    booting...
    (bootloader) Command Restricted
    FAILED (remoted failure)
    finished. total time .624s

    Same verbiage for twrp recovery -

    fastboot states -
    Device is UNLOCKED. Status code: 3
    Battery OK

    Tranfer Mode:
    USB Connected

    Flash Reason: Menu Selected
    usb connected

    Now I have noticed when I try to boot from fastboot, simply useing "reboot" it returns this, and not rebooting my device. I have to do a hard reset to do so -

    Device is UNLOCKED. Status code: 3
    Battery OK

    Tranfer Mode:
    USB Connected

    Flash Reason: Flash Failure
    usb connected

    I'm beginning to wonder if fastboot is corrupt, some how on my phones end. So, I'm still trying to figure whats going on with the recovery but I also have another question, is it possible to re-flash "fastboot"?
    I'm going to run the script again to unlock the bootloader and start from fresh unless someone has an idea -

    TIA! ~ E

    :: After reading a bit anyone think the 1.10 M Utility would work? #1 to be specific? only thing I notice is it is to re-flash 4.1.1, I'm currently on 4.1.2 ??
  3. teddyearp

    teddyearp A guide with guides Guide

    Congrats on being another to be able to grab one of these with an unlockable bootloader. The way I read it is that there is a special fastboot.exe for this device (or Motorola), so if you're using a version of fastboot you've had for a bit you'll want to get the one for this device.

    I see you mentioned a "1.10 M utility", I think you should get Matt's 1.20 version as it has the best drivers and everything else you need:

    DROID RAZR M Utility 1.20 --- Windows/Mac/Linux - VZW Droid Razr M Development [XT907] - DroidRzr.com

    The good news is that it appears you have already unlocked your bootloader. WOOT! But I think the rest of your problems lie in either your version of fastboot and/or your commands.

    For me to flash a custom recovery it is thus (using the drivers and fastboot from Matt):

    Code (Text):
    1. adb reboot bootloader
    2. fastboot flash recovery (name)
    3. fastboot reboot
    I am not sure if a 'fastboot reboot recovery' works, but in any event I then power the phone off, and reboot into recovery manually and then go about my business.

    The only other thing I can think of is that you _might_ still have to remove/rename the 'recovery-from-boot.p' file (I might have the exact name wrong, but I am sure you know what I mean).

    good luck
    argedion likes this.
  4. argedion

    argedion The TechnoFrog Moderator

    Are you sure you have the right device images? I did that and borked it up once. fastboot would come up on every reboot. It did it until I finally found the right image for the device.

    cwm 6.0.3.2 you can get that here.

    cmw 6.0.3.7 you can get that here.

    twrp you can get that here.
  5. teddyearp

    teddyearp A guide with guides Guide

    OP hasn't been on here since Nov 21 . . . .
  6. argedion

    argedion The TechnoFrog Moderator

    Yes I am aware but I left the links for anyone that may need them that sees this thread having similar issues. :)
    MasterCylinder and teddyearp like this.
Loading...

Share This Page