Problems re-rooting after latest .621 update!


  1. mahers

    mahers Well-Known Member

    Hi All-Knowing Android Experts!

    I have an issue and it's killing me. I took the latest DX update to .621 and can't re-root my phone. :mad:

    I've tried the Motofail, Droid 4 and Droid 3 methods and I encounter an error on each one. Apparently, if you were rooted before, these methods see remnants of BusyBox and SuperUser and don't know how to get past them to root. I wish I knew about RootKeeper prior, but it's too late now.
    ---------------------------------------------------------------------


    Here's the suggested trouble-shooting that I can't get to work:
    1. 1. Open a Command Prompt in the folder where you extracted the one-click root package (see instructions for rooting). If you are using Windows 7, you can just use Shift+Right-Click on the folder you extracted the package and choose to "Open a command prompt here". For other operating systems or versions of Windows, you may require some DOS experience or need to Google how to change directories.
    2. 2. In the command prompt, type the following command:

      adb shell
    3. 3. If you receive any kind of error, then you may not be in the folder where you extracted ADB.exe or you may need to reboot your computer, your phone, or check the connection. You should receive an ADB prompt ending with either a # or a $.
    4. 4. If the line ends with a $, then run the one-click exploit for Windows XP (even if you have Windows Vista or 7) and only complete step 1.
    5. 5. When you have adb shell ending with a #, type the following commands:

      mount -o remount,rw /dev/block/system /system
      rm /system/bin/su
      rm /system/xbin/su

      Ignore any messages that warn you about the file not being found/missing. We're removing old copies of su/superuser which are causing this one-click root method to fail.
    ---------------------------------------------------------------------

    Either I don't understand Step 4 above in red, or something isn't working properly. I never get the # to show to do Step 5. Oh, and at Step 5, am I supposed to hit enter after each of those commands??




    Any ideas, tips, or suggestions here? I need my root!:eek:

    Advertisement
  2. VoidedSaint

    VoidedSaint Resident Ninja VIP Member

    Why don't you sbf back to .602 and do it correctly? It will probably be the simplest method in all honesty
    mahers likes this.
  3. mahers

    mahers Well-Known Member

    Ha! I knew that was coming. ;) I have never SBF'ed before and was hoping for an easier way. Since I have everything backed up with TU anyway, I guess it won't hurt.

    I tried uninstalling BB and SU, but my phone is smarter than me...it obviously didn't work.
  4. Metfanant

    Metfanant Well-Known Member

    honestly? SBFing is easy...you plug the phone in and click a few buttons...
    mahers likes this.
  5. VoidedSaint

    VoidedSaint Resident Ninja VIP Member

    i think the longest part of SBFing is wiping data and cache in stock recovery... but maybe thats just me
    mahers likes this.
  6. mahers

    mahers Well-Known Member

    What can I say, I'm chicken! ;) And just to be clear, I would SBF back to .602, root using one of the above methods, use RootKeeper to hide root, update to .621, then use RootKeeper to get back root?

    I think when I type out all the steps, it seems more complicated than the "fix" suggested in my OP, but since that isn't working, I guess I gotta do what I gotta do.

    Thanks guys!
  7. chromicant

    chromicant Member

    Be very careful. I did try to SBF back to .602, and am getting the dreaded A5,70,70,00,1F MEM_MAP Blank error. If anyone is still on .621, has/hasn't rooted, and is handy with sbf_flash in Linux, I'd appreciate a PM to see if I can't fix this small problem. (and before you ask, tried the .602 and .340 SBFs. Both break, hard.)
  8. mahers

    mahers Well-Known Member

    chrominant,

    can u please elaborate? did you miss a step, or mess up somehwere? i am thinking i'd just follow the sbf steps in the stickied root thread here, but if there's an issue, please advise!! thx
  9. chromicant

    chromicant Member

    Not much to elaborate on, sadly. Tried using sbf_flash and RSDLite for the 340 and 602 SBFs, nothing can resurrect the DroidX. I've been able to do some tricks to get different bootloader errors, but no booting DroidX.

    So, until a .621 SBF comes out, if ever, or someone figures out a way to fix the problem, I wouldn't recommend SBFing off of .621.
  10. zEnethSTORM

    zEnethSTORM Member

    Can u please link me to the SBF?
  11. ccsoccer03

    ccsoccer03 Well-Known Member

    I wouldn't SBF it this time... I've been flashing for ever, but I recieved the soak, didnt like it, sbf'd... and poof... bootloader error. Haven't been able to recover since. Tried .340 and .602 ... no go... theyve changed something.. Idk if its the bootloader... the keys... or what the crap it is.... but I've got a perma brick on my hands... and all I gots is a LG ally... yeah tell me abt it
  12. VoidedSaint

    VoidedSaint Resident Ninja VIP Member

    i knew moto/verizon would do something with the bootloader, thats why i asked in the other thread if you were able to sbf back.

    sounds like someone needs to get in touch with p3droid and see if he can provide an sbf for it.
  13. GandalfTehGray

    GandalfTehGray Well-Known Member

    Well thats a new low blow.
  14. mahers

    mahers Well-Known Member

    Rat bastards! :mad: So it seems the only way to retain root is to use RootKeeper BEFORE the update to .621! I knew I shouldn't have jumped on this so quickly.
  15. mahers

    mahers Well-Known Member

    How and where might one find this fine fellow?
  16. VoidedSaint

    VoidedSaint Resident Ninja VIP Member

    he is anything but a fine fellow, but that is how i perceive him, i dont care too much for him at all, he loves attention and will use this as a way to get more attention.

    p3droid on twitter
    mydroidworld is his forum

    he will usually respond to twitter feeds, but sometimes will not.

    his contacts inside of motorola should have the .621 update.
    trophynuts and mahers like this.
  17. mahers

    mahers Well-Known Member

    :D

    I personally don't care what he is, as long as he can help with this. :cool: I don't have twitter (useless, IMHO) but I'm hoping someone else does reach out to him. I saw on another forum that someone was going to try...we shall see. At least I didn't try to SBF last night and brick the phone! A working non-rooted phone on .621 is better than nothing.

    Just saw this on p3's site, so it's not looking good for a working solution::(
    Now that he has decided to no longer provide the hacked stock firmware or has lost access to the files,
  18. VoidedSaint

    VoidedSaint Resident Ninja VIP Member

    yeah, just another reason why moto is a failing ship (for the dev community that is) its hard to believe that the OG droid was the first and only truly unlocked device in the US
  19. mahers

    mahers Well-Known Member

    No proof that I can find atm, but it's been said the xoom2/xyboard root may work. Anyone willing to give it a shot and report back? I can't do anything at work (other than surf the net all day) ;)

    Security Research by Dan Rosenberg
  20. brucefan42

    brucefan42 New Member

    If this is the same as the Droid 4 method, I tried it and it didn't work. My phone is still at 621, not rooted, and running like cr*p.:mad:
  21. mahers

    mahers Well-Known Member

    No idea. I tried various ones as well (I think D3, D4, MotoFail), with no luck. I haven't tried this one yet, but may when I get home. If I can find where I saw the comment and any success, I will let you all know.

    Honestly though, I haven't seen any difference in .621, good or bad.
  22. grabb

    grabb New Member

    I was in almost the same boat. I started with 605 rooted, and the OTA update wouldn't apply. So I did:
    - SBF back to 602
    - OTA to 605
    - ran Pete's root tools to get root
    - ran OTA Rootkeeper to save my root
    - OTA to 621

    I attempted to restore root with Rootkeeper, but it failed! Turns out my problem was that I had root previously, and that gums up the process. So I was on 621 with no root - just like you, except I did have a backup of my su program in /system/su-backup created by Rootkeeper. I was able to recover from this using Z4 1.3. I chose to "temporary root", which didn't seem to do anything, but when I "adb shell" into the phone I was able to execute /system/su-backup and it gave me a root (#) prompt. From there I just copied /system/su-backup to /system/xbin/su, and my problem was fixed.
    What I suggest you try:
    1. get a copy of the su binary, and the Superuser.apk
    2. copy them to your sd card
    3. run Z4 and choose temporary root
    4. once z4 runs, do "adb shell"
    5. in the shell ($ prompt) execute "/sdcard/su" to get a root prompt (#)
    6. run the following command in the root prompt:
    - cp /sdcard/su /system/xbin/su
    - install /sdcard/Superuser.apk
    - chmod 4755 /system/xbin/su
    - chmod 755 /system/xbin/busybox
    - /system/xbin/busybox --install -s /system/xbin/
    - ln -s /system/xbin/su /system/bin/su

    Best of luck!
  23. BridgeScore

    BridgeScore New Member

    I am in the same non rooted 621 situation. If I ever get the droid x rooted again, I will shut off ota for good. I can not understand why verizon can not detect by ota if the phone is rooted and just leave it that way.

    Even Microsoft being the stinkers that they are, gives us a choice to install updates or not and to pick which ones we want. Does this phone belong to us or not! What right does Verizon have to shut out the owners of the equipment from having root. The phone does not belong to them!
  24. Thom

    Thom Premium Guide Member Guide

    When you root-ed your Droid X you assumed total responsibility for it.

    They gave you the choice of installing 4.5.621 or not. You chose to install it.

    ... Thom

Share This Page