1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Problems rooting. Missing CID


  1. prjMayhem

    prjMayhem Member

    Android Version: 2.2.2
    Network: Virgin UK
    Taskiller Used?: No
    [Optional]Are You rooted & which Rom: Not rooted
    Issue: Missing CID in rooting process
    hboot 0.93.0001
    bravo pvt1 ship s-off
    radio 5.11.05.27
    baseband: 32.49.00.32U_5.11.05.27
    kernel: 2.6.32.15-gf5a401c htc-kernel@and18-2 #1
    build: 2.29.405.14 CL345208 release-keys
    software: 2.29.405.14
    browser: webkit 3.1

    Hello, I'm new here. I'm struggling to root my Desire. First off I tried the latest version 3.32 of Unrevoked (my mistake should've listened to the FAQ). This gave me 'firmware too new....' So tried 3.21 and it gets further but fails with 'missing CID'. I understand CID is tied to SD card and just curious because the SD card came from my previous phone. Could this influence things?

    Is the next step to try downgrade to 2.1 as per the FAQ, or is there something else to suggest first?

    Advertisement
    :
  2. SUroot

    SUroot Well-Known Member Developer

    You.could try revolutionary to get s-off instead...
    prjMayhem likes this.
  3. scary alien

    scary alien not really so scary Moderator

    Welcome to the AndroidForums, prjMayhem! :)

    I've moved your thread to the all-things-root area so you'll get many more good replies like you got from the esteemed SUroot (great user name, btw :)).

    The folks in here will help you and hook you up with a solution, I'm sure.

    Cheers, and glad you signed-up with us here at AF.
    prjMayhem and SUroot like this.
  4. SUroot

    SUroot Well-Known Member Developer

    Yes, in keeping with your screen name....

    The first rule of root club is, you do not talk about root club.

    The second rule of root club is you DO NOT talk about....wait.... read the faq's


    :eek:

    (i see you already have)
    scary alien likes this.
  5. prjMayhem

    prjMayhem Member

    HaHa thanks for the warm welcome :)

    I'll read up on the revolutionary method.

    "I know this, because Tyler knows this" :cool:
    scary alien likes this.
  6. prjMayhem

    prjMayhem Member

    I'm taking this steady so these may sound like over cautious questions. Step 3 in 'Root Desire Revolutionary' says to read the ADB/Fastboot FAQ and setup. I've done this but the 'adb shell' cmd comes back with 'error: device offline'.

    I think this is because the attempt with Unrevoked wrecked my recovery (red triangle at boot) so I can't get into recovery prior to running 'adb shell'. Does this matter in respect to the task I'm following (rooting phone)?

    Good news is 'fastboot devices' comes back with a string beginning with 'HT' which I guess proves I have a USB phone connection.

    Am I ok to continue the guide?
  7. SUroot

    SUroot Well-Known Member Developer

    You can't use adb commands in recovery until after you have a recovery that supports it. The HTC one you have now does not support adb. This means you can only run adb commands whilst android is running.
    prjMayhem likes this.
  8. prjMayhem

    prjMayhem Member

    Ah ok, Superuser-3.0.7-efgh-signed.zip from Revolutionary site or su-2.3.6.3-efgh-signed.zip from the guide? Or does it matter?
  9. SUroot

    SUroot Well-Known Member Developer

    Depends. If Youre going to flash a custom Rom, you don't even need to flash.this....
  10. prjMayhem

    prjMayhem Member

    Yay phone successfully rooted and recovery installed using Revolutionary method. Not sure why Revoked failed so badly.

    Now off to research Nandroid backup and find some ROMs to test

    Thanks for your help - great forum here. :cool:
    shauny13 likes this.
  11. Hello Gurus,
    I went through the FAQs and it says
    "UnrEVOked only works for 2.2 however. Any 2.3.3 GSM ROM must use revolutionary. Also, any hboot 1.02 or higher needs to use revolutionary too. Please see Mattb81's Guide:"
    But it seems I still have to use revolutionary using Mattb81's guid for Hboot lower tha 1.XX?
    The 2nd thing is my erase size is 40000 which the FAQ recommends Amon Ra for..
    Being a newbie trying to take plunge into rooting getting a bit confused as to which one to use...
    Thanks in advance for help...
  12. Hadron

    Hadron Well-Known Member Contributor

    If you have erase size 40,000 you want Amon Ra 2.0.1 (or 4EXT, which has come out since). This is the recovery which you want the the rooting tool to install, whether you use unrevoked or revolutionary to do it.

    If you have a 0.xx hboot you can use unrevoked. You *can* use revolutionary instead with 0.93 hboot if you prefer.
    Abhishekswarup likes this.
Loading...

Share This Page