Problems with downloading from MarketSupport


  1. AlenaCerna

    AlenaCerna New Member

    Dear All,
    could you please try to help me with my problems with downloading any game, widget etc. from Market on my phone?
    Last wek everything went smoothly, no problem. Now when I have upgrade my mobile to new version of Android 2.3.5. I am not able to download anything. Downloading starts but it falls in a second and nothing happens.
    Do you have any idea what to do??
    Thanks.

    Advertisement
    :
    uadhami likes this.
  2. Rlaakkola

    Rlaakkola Member

    I had the same problem a few days ago... Sadly I found out nothing else helped but a factory reset. After resetting I got to download a newer version of market and after that everything has gone pretty smoothly. :)
  3. clunkercar01

    clunkercar01 Well-Known Member

    I have this problem too after upgrading to 2.3.5.

    Nothing will download from the Android Market.

    Surely I dont have to go through the trouble of a factory reset?

    Isnt there a newly available version of Market to download somewhere to fix this?

    Anyone any ideas please as I dont want to perform yet a factory reset.

    Cheers.
  4. djthebogan

    djthebogan Well-Known Member

    Yes there is market 3.4.4, but I don't think installing it will solve your problem. Your dalvik cache needs to be wiped, factory reset unless u have root
  5. clunkercar01

    clunkercar01 Well-Known Member

    thanks djthebogan, but can you explain please how and why the factory reset fixes it?

    I have tried every suggestion I have found on the net but nothing has worked and I have unfortuantely also read that for some people a factory reset doesnt work either and the market still wont download.

    Cheers.
  6. djthebogan

    djthebogan Well-Known Member

    I believe your dalvik cache was built up before your 2.3.5 update, so your phone is still using caches from the older. With a factory reset it clears out all the caches and rebuilds them based on the 2.3.5 image. If u have root and cwm installed u could just boot into the recovery and wipe your cache and dalvik cache, then when it reboots, during the startup it rebuilds all the cache, that's why the first boot takes longer. But without root there is no access to the dalvik cache to wipe it, so u have to factory reset which will wipe the cache and dalvik, but also all the data gets wiped, which is annoying and another reason u should root
  7. clunkercar01

    clunkercar01 Well-Known Member

    (edit as we cross posted... cheers for the info djthebogan)

    wooooaaah, after hours of trying EVERYTHING - I just fixed it on the Wildfire S.

    Hang on... let me think what I did...

    Okay, download manager cleared, HTC checkin cleared, Market cleared - all data erased blah blah blah, I tried EVERYTHING - I mean everything except a factory reset.

    Right, I think after all the hundreds of things I tried I can pin it down to 1 thing.

    Yeah, I cleared out the download manager - but I 'think' the things that sorted it for me was to uninstall the updates for the download manager. I had read about people uninstalling updates for the market but since there was no option to uninstall market updates I decided that since it was a download problem and I had already cleared the download cache and data that the ONLY option left to try was to uninstall download manager updates as afterall it WAS a download problem.

    So, its working - for now.

    Try it out AlenaCerna and anyone else that has this problem - maybe its a good thing to try before resorting to a factory reset and I cant recall seeing anything on the internet to say uninstall the download manager updates.

    Reply to let us all know how you get on.

    :)
    Jenkev29, cakelover and kpcwatson like this.
  8. djthebogan

    djthebogan Well-Known Member

    I don't have download manager or checkins installed, I removed them from /system/apps/ so I could get more memory. I'm glad u got the problem fixed though.
  9. cakelover

    cakelover New Member

    I'm having the same problem, but all the rooting thing has confused me so I'm ignoring that and will try a factory reset - silly question I know, but will that delete all my address book?
  10. kpcwatson

    kpcwatson New Member

    Being completely new to Android phones (4 days) and not understanding a lot of the threads here (mentioning "root") I tried clunkercar01's suggestion of clearing the download manager and uninstalling the updates and it worked. I can now download apps from the Marketplace again and they actually install, instead of doing nothing. It's saved me going back to the shop with the 'phone - thanks :)
  11. clunkercar01

    clunkercar01 Well-Known Member

    Excellent! I am so pleased my info helped out kpcwatson and thanks for taking the time to sign up and say thanks. :D
  12. cakelover

    cakelover New Member

    wooo yeah clunkercar01 - you rock.... finally worked out how to uninstall updates (am so glad I didn't have to do a factory reset)
  13. Rlaakkola

    Rlaakkola Member

    Glad to see you guys managed through it without a hard reset, I had to do that as I couldn't figure out another way.. Anyway, do you guys have the new (3.4.4) market now or still the old one? :p Just out of curiosity
  14. gow tham

    gow tham Member

    Dear All,
    could you please try to help me with my problems with downloading any game, widget etc. from Market on my phone
    it wont install download complete its gone nothing happens i hav rooted unable to install any apps
Loading...

Share This Page