Problems with ip address on wifiSupport


Last Updated:

  1. sjaak500

    sjaak500 Member

    Hello everybody, i hope you can help me.

    Currently, i am working as a network administrator for a company.
    Our company wants to buy about 500 Samsung Galaxy S2's and Galaxy Ace's.

    We already have some of thede devices for testing purposes.
    Unfortunately, they won't properly connect to our wireless network.

    The phones will associate with the wireless network, but won't receive an IP address from the DHCP server. When i give the phones a static IP address, the connection works perfectly, so security can't be the problem i think.

    I have this problem with almost all Android devices. I have tested it on: Samsung Galaxy S running on Android 2.1, Samsung Galaxy S2 running on Android 2.2, Samsung Galaxy Ace running on Android , HTC Tattoo running on Android 1.6.

    The only Android device which do gets an IP address is an Asus TF101, which i have also tested it on.

    Do you have a solution for this, because i can't think of one anymore.

    Thanks in advance!

    Advertisement
  2. Hawker

    Hawker Well-Known Member

    Mine works without any hitches at all, and I connect each day to my home router and works router seamlessly. I've not ever used the WPS function to connect (I've not even tried this) so initally, I scanned for networks, the GS2 picked up the router, and I connected by entering the WEP (or whatever) key and away it went.
    Are you sure your wireless router itself is configured for DHCP, or are you perhaps making your server do this?

    My thinking is as your only trying this in work, if you took the device home, you would be able to connect without any problem to your home's wireless.
    I assume your letting your windows (or whatever) server do the DHCP, so it will be a setting in there that needs to be addressed
  3. sjaak500

    sjaak500 Member

    At home, i can indeed connect to the wireless network.
    So i am guessing that the cause of the problem indeed is in the router.

    I do know sure the router is configured for DHCP. Some years back, we had a Windows machine which was configured for DHCP, but for now, it is our router.

    I also had contact with the reseller of our router. He couldn't find the problem in the router and said it was an Android problem. It already seemed strange to me that the problem was in Android, since the Asus TF101 would connect to the network, and the other Android devices wouldconnect to another wireless network.

    But i was thinking, maybe he is right, and someone has a solution here ;)
  4. Hawker

    Hawker Well-Known Member

    I'm not so sure, as at work, the windows server does all the DHCP, and is not enabled on the router, and at home, the router obviously does the DHCP, and like I've mentioned, both work fine for me.

    the problem must be with your works router. To say its an android problem is utter rubbish as this would be a huge worldwide problem if this was the case. Like you said, your device works at home, so the problem is not the GS2 or android, but your works connection.

    I would delve into your router's DHCP settings further.
    Otherwise try disabling DHCP on the router and let one of your servers do the job instead and see if this sorts it.
  5. sjaak500

    sjaak500 Member

    It works!
    Problem was that our router does an IP header checksum.
    Apparently, the IP header Android sends are incorrect until Android 3.2?

    When i disabled this IP header checksum on our router, all the Android devices are getting IP addresses. :)
  6. hjbarten

    hjbarten New Member

    I have similar problems and troubleshooted this with my provider, and we've seen my Galaxy S Plus requests IP, and gets an IP offered, but during selection (acceptance) the phone doesn't sent the necessary response, which is seen as rejecting the offered IP.

    I'm running 2.3.5 (the latest to my best knowledge), and seems firmware corrupts overtime.

Share This Page