Problems with Samsung Galaxy 7.0 PlusSupport

Last Updated:

  1. Franki1015

    Franki1015 New Member


    I just bought a Samsung Galaxy 7.0 16gigabyte Plus last night from Best Buy.
    I was so excited to get this as it's my first tablet and it has a lot of problems.
    First the wifi won't connect to my home network. It knows it's there but just won't connect even with a password. I hooked up a wireless printer and it picked it up withough any issues. I didn't have to do a thing.
    I also work at a large company that has an excellent wifi and although it does connect after some trouble it won't go to any pages. It tells me to check my connection. I have no problem with my laptop.
    The touch screen works off and on and if I go to settings to try to work with the wifi most of the time it brings up 6 small icons on the bottom of the screen that have nothing to do with the settings. I usually have to access settings by touching where the time is in the lower right corner and press wifi two or three times to get it to come up.
    I spoke to Samsung last night for about an hour and the guy had not worked with one before so no real support there.
    I am going to take it back to BB on my lunch hour but don't expect much help.
    I hate to just return it after doing all the research and making the decision to get one, I actually like it but I'm very disappointed.
    Any help would be appreciated.

  2. skeeterpro

    skeeterpro Member

    I've read from some sources some tabs are just "squirrely" (great tech term there) especially screens and wifi drops. I'd take it back and keep at it until you get one that doesn't manifest quirkyness (another great tech term!)
    You're right, BB probably won't be of much help. Just swap it out and try the new one.
  3. Franki1015

    Franki1015 New Member

    Thanks for the reply.
    I did take it back and BB didn't even blink about giving me a new one.
    I brought it back to work and fully charged it then turned it on.
    Again it sees the connection and sometimes picks it up but even then if I try to load a web page it tells me I have no connection.
    I took it home and got it on my home network and it worked just fine.
    Only problem there is I bought it for work so I wouldn't have to take my laptop back and forth every day.
    In doing some research I came accross a site called androidpolice and this is one if the issues that is cited.
    Wi-Fi signal strength is weak - I constantly seem to be losing my connection
    Is anyone else having this problem besides me? Again, I really like it but not for the price if it won't connect at work.
    Are there any tablets that are wifi with great connectivity?
    Sorry, this is my first tablet and again after doing all the research this seemed to be the one to get. I don't want an ipad b/c of size but all that have them where I work report no problems.

    Thanks again,
  4. skeeterpro

    skeeterpro Member

    Get with your network admin at work. That you can connect fine at home and not at work implies your work place is suspect. Check login protocols, how far you are from the AP or router, any interference points, etc. Connect at work then walk around checking connection. Some businesses have configurations that restrict logons, users, connection times, etc.
  5. RhinoDoc

    RhinoDoc Well-Known Member

    I agree with discussing it with your network administrators. I know that my Xoom (and my android phones) can't connect with my office wireless, even when I put in the password, until they change some setting. Essentially, they have to put in my MAC address (I think that's what it was) so the network allows my tab or phone to connect. Once I provided that information it took less than 5 minutes to hook me up. It only has to be done once.
  6. Franki1015

    Franki1015 New Member

    Thanks for the help. I'm pretty much done with it.
    I work at a public facility. Two networks. One closed and one for guests.
    The device picks up the connection but it is very iffy even standing in the middle of one the hotspots. One minute it's on a webpage then it's gone.
    I just don't want this kind off on connection. This (to me) should be no different than my laptop. I had intended to use this at other places where there is wifi when I have to wait for things but if it can't connect here without issue will it connect elsewhere? It makes no sense that one minute it gets out and the next it doesn't and won't connect back up. Bugs me too that all the ipad/pod people connect right up to guest and off they go.
    Really disappointed. 7" had all the properties that I wanted.
    I guess I can do without a tablet.
    Thanks for the effort and have a great holiday.
  7. kemtots

    kemtots New Member

    my cousin played games using my tab. when i opened the application again, couldn't open it anymore and the dialog box came out "force to close or report". and my tab just hanged. so i powered it off hoping that it reboot. unfortunately it didn't. when i turned it on, t just froze and only the samsung logo appeared.
    please help me.... T_T

    i have tried to do some actions like turn on with the power button and volume up. some messages appeared, "reboot system now,apply sd card, wipe data/factory reset, wipe cache partition,. i chose reboot system now but it said that "cant mount" and "data application failed". and then, i chose the "factory reset". same thing happened.

    please help me.... T_T
  8. ravenas

    ravenas Well-Known Member

    I think you have a bad unit. My WiFi works perfectly. Even better than my Galaxy SII phone (that one keeps losing my Wireless-N network but handles G like a charm).
  9. calanthe42

    calanthe42 New Member

    My wifi was "squirrely" too until firmware update 2 days ago. Much better now. Still not great but hopefully will improve. It also does get warm after 30 minutes, but it is a very thin tablet, so to be expected.
    Also, I did a factory reset the second day I owned it and that helped wifi a bunch.
    A great tablet, but anticipating the 7.7 with amaloid screen, if it ever comes to the US.
  10. JSchu22

    JSchu22 Well-Known Member Contributor

    Firmware update? Can you elaborate because I have not heard, or seen, this as available.
  11. calanthe42

    calanthe42 New Member

    Nothing much to say. Unit was shut down, I started it up and there was a message that there was a firmware update pending. I installed it and it seemed to help a few issues I was having. Sorry I can't offer more info than that.
  12. wtherrell

    wtherrell Well-Known Member

    Mine has shown no updates available. Could you perhaps provide the version info after the update?
  13. RhinoDoc

    RhinoDoc Well-Known Member

    Mine shows build # HTJ85B.UEKK3 P6210UEKK3

    I was unable to get that via WiFi, I had to go to the Samsung website, download Kies, hook up my Tab, learn there was an update available, download the update and install it. It was easy, but took almost 2 hours.
  14. wtherrell

    wtherrell Well-Known Member

    Yeah. My Kies says updates don't work over Wi-Fi. Has to be connected by wire.
  15. calanthe42

    calanthe42 New Member bad. I got the update message when I was connected to Kies with the usb cable. It took a very long time to download, but seemed to help my issues.
  16. wtherrell

    wtherrell Well-Known Member

    Same here. Initially had trouble connecting. Took it upstairs next to the router and it connected. That was three days ago and and I have taken it on trips up to 12 miles away. As soon as I walk back in the door at home it is connected again automatically and has stayed connected with no drop-outs. Most everything is working well. My only complaint is all those greasy finger smudges on the screen!
  17. kcmartz

    kcmartz Well-Known Member

    I have a problem with the update, I updated the firmware, it worked until like a half hour ago, then it just wouldn't turn the screen on. Yes, I followed the root guide on XDA Developers. The only root apps I have are the 'basics.' Superuser, Busybox, and Titanium Backup (free).
  18. williammorrisiii

    williammorrisiii New Member

    I did an update last night over WiFi, no problem!

Share This Page