Problems with Wifi - 3G handoverSupport

Last Updated:

  1. Frogbone

    Frogbone Well-Known Member

    Not sure if this part of the known connectivity issues or a separate one so I am starting this thread.

    I work in a somewhat metal clad building which blocks most of the 3G signals from the outside.

    I do have strong wifi signal inside.

    Since I switched from my OGEvo to the LTEvo I have noticed that when going outside or inside I completely lose connectivity.

    For example, I am inside the building I have no problem doing stuff on wifi. As soon as I walk outside and the phone picks up 2 or 3 bars of 3G signal and also still has some wifi connectivity the phone refuses to pick either connection.

    I have to turn off wifi in order to acquire the 3g connection.

    When I go back inside I have to turn wifi back on.

    Now, I seem to remember that prior to the LTE launch Sprint announced that they implemented the Connection Manager with the HTC phones which supposedly handles these types of situations.

    DOes anyone else experience this? Could this be part of the 3G problems I have been reading on here?

  2. takirb

    takirb Well-Known Member

    I don't have to disable anything altogether, but the handover itself does seem to take a bit longer than it should for me
    Rxpert83 likes this.
  3. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Same here. There are times when I have no data connection going back and forth for longer than the OG EVO
  4. quijibo

    quijibo Well-Known Member

    I was at the cabin last week with terrible data coverage and my phone would claim to be connected to my WiFi network even though I was over 10 miles away. I assumed that it was because it couldn't acquire a data connection.
  5. EarlyMon

    EarlyMon The PearlyMon Moderator

    I don't see the old option to notify for open wifi networks. I think that they changed too much under the hood with too few options.
    marctronixx likes this.
  6. marctronixx

    marctronixx Moderator Moderator

    carriers WANT you to stay on WIFI as much as possible. it helps offload some data form hitting their network.

    im sure there are settings in the ##DATA# screen that can be tweaked to change the sensitivity of when the phone is handed off from wifi to cellular.

    sounds like the phone is doing it thing though. ive seen that ill be in the studio then walk out to the concrete parking structure and the phone will still hang on for dear life to that weak wifi signal from INSIDE the building. sometimes the phone will just not be connected at all until i get out and a bit away form the building. so I am probably seeing the same results as the OP....
    EarlyMon likes this.
  7. Frogbone

    Frogbone Well-Known Member

    Well, I suppose I am not alone with this issue.

    As much as I understand what is happening and why it's happening, as a user it is unacceptable to me !

    Prior to posting this I talked to Sprint and they set me up with an appointment at the repair center today.

    We'll see if they have a good explanation or a solution for this.
    marctronixx and EarlyMon like this.
  8. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    I believe that's the top option when you go into the advanced WiFi options.
    marctronixx and EarlyMon like this.
  9. Frogbone

    Frogbone Well-Known Member

    Took the phone to the Sprint repair store today. What a waste of time that was :mad:

    I swear, anyone on this board would know more about these phones than the technicians there.

    "Oh... Evo LTE...we never see those." Duh, they don't even have one on display in that place !!

    I was fully prepared that they would do a full reset but all the they supposedly did was a " data connection reset"
  10. EarlyMon

    EarlyMon The PearlyMon Moderator

    It's official, I'm blind. :D

    Sorry Frogbone, will keep an eye out for the fix.
    marctronixx likes this.
  11. Granite1

    Granite1 Zercron Encrusted Tweezer Moderator

    I have issues sometimes when I'm in a bad reception area / roaming, where I'll switch from roaming to network and it won't reconnect the data. I have to turn the mobile network off, then turn it back on.

    I heard of folks having this issue with the OG, I didn't have it on mine. A little annoying, but not a deal breaker for me by any reason. I still love the phone. :)
    EarlyMon and marctronixx like this.
  12. jackie08

    jackie08 Member

    Don't bother calling sprint either I did when my LTE would not send a text message And had 2 rep tell me to remove the battery Duh they have no clue about this phone :))

  13. Frogbone

    Frogbone Well-Known Member

    So I am still having issues with wifi to 3G switch over issues. This has been going on since I got this device at launch.
    Mind you, I never had these problems with my OG Evo or any other phone !

    I can't be the only one with this problem !

    So, here is the scenario:

    I travel a lot and stay in hotels all the time.
    Many hotels let you connect to their wifi network just by logging on to their open wifi.
    In order to get Internet connectivity they redirect you to a portal where you enter an access code. From that point on you have Internet connectivity.

    After an undefined time at night, the Internet connectivity drops out, while still connected to the wifi network.

    I know this because when I wake up, I have no email, Facebook notifications or any other Internet related push notifications.

    Now I can do one of two things which immediately solves the issue and gets my email and messages:

    Turn off wifi. This will make the phone use the available 3G or 4g connection to retrieve data.

    Go to the portal and sign in again. It will then use wifi to get my data.

    This obviously is a flaw in the way the manufacturer of the device or the carrier look at how to implement their bandwidth saving function.

    As it says in the mobile network settings, "uses wifi instead of 3G when connected to a wifi network"

    Just being connected to a wifi network does NOT ensure that you have connectivity. It should check if you are actually connected to the Internet, otherwise it should ALWAYS use the mobile network.

    Am I wrong on this?

    Is there any solution that someone knows about?

    This is getting very old for me, especially since I am dealing with people overseas so there is no " night time" for me.

    I also never understood how Sprint/Samsung came up with the idea of making the phone shut down data at night. Not everyone sleeps at night, some people work !

    I am really hoping someone can help me !
  14. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    The stock function is to shut off internet connectivity between like 2am and 7 am when the screen is off. I'm not aware of any non-root workarounds for this.
    There are rooted methods though
  15. Frogbone

    Frogbone Well-Known Member

    I am aware of that. There is a work around for the 2am to 7am issue for both rooted and non rooted phones. It's called Smart Sync disabler and is available in the Play Store.

    My problem however is that once the phone loses internet connectivity (not wifi connectivity) it will NOT switch back to 3G or 4G. In other words it's a paper weight.

    I have gone through 3 phones and it this behavior has been the same on all 3.

    Test it for yourself.

    Connect to your wifi.
    Pull your ethernet cable between cable modem and router.
    Now your internet is down but you are still connected to your router (wifi)

    If your phone behaves like mine, you will not get any messages until you either reconnect the router to your cable modem or until you switch off wifi on your phone.

    The phone thinks that as long as it is connected to a wifi network it doesn't need to use the mobile network for data. It doesn't care if your wifi is connected to the internet or not.

    This is what I have been observing since day 1 !!!

    Can you or anyone else test and confirm this behavior?

    After 3 phones I can't possibly be the only person that has this problem.

    PS: When I said that "at night the internet connectivity drops out" it was for the example at the hotels. I have the same problem at other places during the day, e.g. airports, coffee shops etc
  16. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    I can't confirm it right now, im syncing a large repo and don't want to lose it.

    Couldn't you just turn off WiFi before bed as a workaround?
  17. Frogbone

    Frogbone Well-Known Member

    Like I said, it's not just at night and I really shouldn't have to keep remembering to turn wifi on and off. I'd like to solve this issue, not work around it.
  18. EarlyMon

    EarlyMon The PearlyMon Moderator

    Have you tried settings, WiFi, menu, advanced, keep on during sleep? Also, the best quality click there may also help, but try the sleep one first.

    And I wonder if the internet disconnected/wifi connected isn't part of the newer Android.

    I think that a lot of desktops can work that way. Not that that helps, just saying - the problem may be too deep.

    And how is it that public networks are up without connecting to the backbone??
  19. Frogbone

    Frogbone Well-Known Member

    What do you mean by that ?
  20. EarlyMon

    EarlyMon The PearlyMon Moderator

    I mean that the way to simulate this is as you asked - disconnect the backbone connection from your home wifi router.

    How many public places are having that sort of connectivity issue (not literally unplugging, but losing that connection)?

    In my limited experience, that's rather rare.

    That's why I am wondering if the problem is elsewhere in the stack, hopefully fixed by one or both of those switches.

    I had an isp problem last week, I didn't get the auto-switchover either, so I agree, it's not you.
  21. Frogbone

    Frogbone Well-Known Member

    Some hotels make you log into their portal again after a certain time. I don't know why but that's how it is. They don't disconnect you from their router, that's why the phone insists on using that connection even though there is no internet.

    If you look at the Mobile Network settings it says "Use phone for data connection when Wifi is unavailable"

    It should be when wifi + Internet is unavailable.

    I'm glad that you saw this scenario when your ISP was down.

    I really think that this is a shortcoming on HTC's end. I have a case open with them since July. Maybe not enough people report this problem so they are not making this a priority to fix.

    Now that I am thinking about this a bit more. Maybe there is a way with an app like Tasker or the like to check for Internet connectivity and when there is no connectivity with wifi on it would turn the wifi off ?

    Something like this:

    -If Wifi is On
    -If Wifi is Connected

    Then check for data connectivity

    -If no data Connectivity
    -Turn wifi OFF

    Am I onto something or is this not possible ?
  22. flyjbaker

    flyjbaker Well-Known Member

    I think the phone is behaving as it should. As Marc said above, it's priority is Wifi. And it is going to continue on wifi as long as it has a signal....regardless of whether that signal is connected to the internet or not. I do not have this phone but am doing prepurchase research. And my EVO 3D behaves exactly the same way. It cannot be connected to two data sources at the same time. It defaults to wifi if it is available. If you want it to default to 3g/4g then you are going to have to turn wifi off. Simple as that.
    I have never pegged this as being a problem since wifi is a battery drainer if it is on and not connected. So my normal SOP is to have wifi off unless I want to use it. It is also likely why you are not getting any other folks on here with the same "problem". It is not a problem to them....just how the phone works.
  23. PyroSporker

    PyroSporker Well-Known Member

    I do not use WIFI, ever.
    I do not need the functionality being discussed here.
    BUT from the outside I can see what is going on and I have to side with Frogbone on this one. If I was in a situation where I needed literal 24/7 data connection like him I'd be a bit discouraged as well. I'm in a 24/7 business and I can see the need when sales deals are happening across the world at all hours of my night - my night is someone else's day.
    Fly j You probably have a good worldview too through your travels.

    The Evo 3D doesn't halt WIFI between 2AM and 6AM to preserve battery though I don't think (unless they added it with the update to Ice Cream Sandwich and newer Sense)

    The problem here is that when WIFI is automatically turned off incidentally, by the system or the connection is halted at the router etc., The WIFI stays turned on connected to nothing and the phone is not defaulting back to 3G/4G when left on in the background.
    This is a problem, because it should be programmed better/fixed on HTC's end. If the live WIFI connection stops, then the system should realize it try to receonnect a few times then default back to another active connection source.
    He cannot be expected to wake up in the middle of the night just to manually turn off WIFI. When going to bed you could make sure you are always on mobile internet - doesn't account for roaming/bad signal areas or non-sleeping times when the connection is halted at the router for any reason.
    It should not be up to us to Root or find workarounds to fix things that shouldn't be a problem in the first place.

    It being a different issue elsewhere in the stack or being a general ICS is a good idea and could be a significant part of it. Either way, in a perfect world, it should be up to HTC to support us, report back, and resolve if possible.

    The 2AM to 6AM WIFI turn off was added to preserve battery and should be an advanced option for advanced users in my opinion. I don't want or need the WIFI to turn off like that and don't appreciate the system thinking it needs to do that for me automatically. Leave the choice in the users hands (I can see HTC's perspective though too - honestly trying to help and preserve battery for us and keep the settings as simple as possible for the general user)

    I'm with you on that SOP and the fact that most people either don't need the functionality, know about this "problem", or just accept it as how the phone works.
    Most that do know about it probably have fixed it through rooting/market application.
    It likely has not been reported to HTC enough times for them to see a change needed?
    flyjbaker and Frogbone like this.
  24. Frogbone

    Frogbone Well-Known Member

    BTW, I am calling BS on the Smart Sync feature being there for "battery saving" reasons.

    As far as I know it doesn't just disable wifi, it essentially puts the entire data connectivity to sleep. Only calls and text messages come through between the hours of 2am and 6am.

    During these hours most people are sleeping and have their phone plugged in to a power source. The reason for this function is in my opinion strictly for the carrier to reduce bandwidth and data usage.
  25. smitty543

    smitty543 Well-Known Member

    Have you looked at, tried, the app entitled "AutoWiFi Enabler". It automatically turns on/off when going into/out of an active WiFi area. [Actually there are several similar ones available.]

Share This Page