Problems with Wifi - ICS on rooted XE


  1. 85jas

    85jas Member

    Mornin' all!

    I've got a really pesky problem when attempting to run ICS on my XE. I S-OFF'ed using revolutionary's method, installed 4ext recovery and rooted my stock Gingerbread release. So far so good... then I flashed UserFriendlyFirmware's 3.24 firmware to bring my versions up to the following:

    HBOOT- 1.27.1100
    RADIO- 11.21.3504.13_2
    OpenADSP-v02.6.0.2226.00.0104

    I've tried a few ICS ROMs, VirtuousInquisition, HyperNonSense and InsertCoin all boot and run just fine. BUT... when connecting to a WiFi network the phone never connects, and gets stuck at the DHCP client "Obtaining IP address". If you enter IP4 addresses etc. manually then it works just fine. All ICS ROMS I've tried seem to have the same problem.

    Soooo... I tried updating the radio to 11.59.3504.00U_11.16.3504.16 using the P58IMG.zip found on RootzWiki but, after flashing, the radio version displayed on the bootloader is actually an 11.15 version!

    AARGH! Anyone got any ideas? I REALLY want to play with ICS but not being able to get an IP off a wireless access point is just a bit too far ;(

    Thanks in advance,
    Jason

    Advertisement
    :
  2. 85jas

    85jas Member

    Update: Flashed the 3.24 firmware from here which contains the 11.68.3504.00U_11.21.3504.13_2 radio. The bootloader still shows the wrong radio version but it's correct when checked in ICS.

    Still doesn't get an IP address. Aargh.
  3. SmokyM79

    SmokyM79 Member

    85jas likes this.
  4. 85jas

    85jas Member

    Nice one smoky, I'm gonna try that firmware right now. Hell, this is what lunch breaks are for right... :D
Loading...

Share This Page