Problems with Wifi with the optimus mSupport


Last Updated: 2014-02-17 22:50:01
  1. I am using my own router, and my phone shows that the signal strength is excellent (the router is in my room) and the phone will occasionally tell me that its not connected or it would disconnect. Is it the phone? My iphone had no problem of this sort.

    Advertisement
  2. Kamikaze_D50

    Kamikaze_D50 Member

    I'm having the exact same problem with mine. I'm using the wifi right now on the computer so I know the network is available but when I go into the wifi settings it'll say scanning, then authenticating, then disconnected. I've tried all the wifi networks around, even forgetting my home one and still nothing. so i dunno what to do...
  3. bbfugitive

    bbfugitive Well-Known Member

    Hello there Pinkssss ;)

    1) In wireless and network settings, goto wi-fi settings, hit your menu button and go to advanced settings. Change your sleep policy to never.

    @Kamikaze_D50: Most likely you have an old-ish router. Can't say exactly why you are having trouble but I often see this problem with wpa2 on older routers. A quick reboot of the router (pull the plug its the fastest way) and you will be ok for a bit. Are you using a d-link?
    zbook, tyro70, DaniellieeE and 3 others like this.
  4. Hello hello.. Thanks for the sleep tip. I didn't know i could change that. The wifi sleeping thing was getting on my nerves. What I ended up doing was adding the same network, re-entered my password and it worked. I think some how the phone deleted my password. See if that works pp. Tootles.
  5. Kamikaze_D50

    Kamikaze_D50 Member

    I have a linksys wrt160v3... not too old I don't think. It's the Cisco one and I'm using dd-wrt. I've had it connect to everything that's tried to connect to it before but just a problem with the phone. It's running on the WPA2 also, maybe that's a problem?
  6. Kamikaze_D50

    Kamikaze_D50 Member

    @myself... I'm a complete idiot lol. I usually make my password this one specific one but I forgot I threw a party and someone got in and changed it... So I just changed it back I'm good now and zooming!
  7. ChazzMatt

    ChazzMatt Well-Known Member

    Yeah, you have to change the advanced setting to NEVER sleep on the wi-fi. Otherwise every time the screen goes on stand-by (goes dark), your wi-fi disconnects. Then, when the screen comes back on, it's constantly trying to reconnect. Annoying when you haven't changed locations (like at home or work).

    For newbies, here's the exact steps to fix this:

    On the Home screen,
    • (click the bottom left key), choose "Settings"
    • on that menu, choose "Wireless & networks"
    • on that menu, choose "Wi-Fi Settings"
    • (click the bottom left key), choose "Advanced"
    • on that menu, choose "Wi-Fi sleep policy"
    • on that pop up menu, choose "Never"
  8. hellohellohell

    hellohellohell New Member

    I just recently bought a LG Optiumus M from Metro PCS. I have a Linksys WRT45G router, with excellent signal strength. The Wifi Sleep Policy is on Never.

    When I try to connect to my router, it says that the network is secured by WEP. It then says, "Obtaining IP address." &Then it says, "Remembered, secured with WEP" Then it goes back to "Disabled."

    When I try to connect to public places with Wifi, like Starbucks, it connects fine.

    Help, please!
  9. Bird Dog

    Bird Dog Member

    That sounds to me like you either didn't enter a WEP password or entered an incorrect password when you first tried to connect to your router.

    Go to Launch the Settings App, select Wireless & Networks, select Wi-Fi Settings. Your router should be listed under Wi-Fi networks. Press and hold your finger on it and a menu should pop up. Select Modify Network and try re-entering your WEP password.

    WEP is pretty weak security. Unless you have older devices that only support WEP, I'd change your router (and the devices connected to it) over to use WPA or WPA2 security.

    Hope this helps!

    Bird Dog
  10. ChazzMatt

    ChazzMatt Well-Known Member

    Good guess. That actually happened to me when I first got my phone -- entering an incorrect password which was "remembered" and then I could not form a lasting connection with my wi-fi router. I was new to the phone keyboard and I accidentally hit a wrong key. Finally I realized what must have happened and re-entered the password VERY carefully. then, I connected and stayed connected.

    I'm using WPA2 security, not WEP -- but it was still a typo'ed password preventing the connection from lasting. :)
  11. Tequan

    Tequan New Member

    I'm having a similar problem. I've read through the threads. I change the sleep option to never & I can tell it's helped, but I still can't connect to my won network, but I can connect to one of my neighbors network. I've tried to connect to my guest network, which has no password to it, and to my network, but no luck. I've done the password oever and over again. I've also tried to enter the network information into the phone and into the router network/web page. Any Ideas or suggestions?
  12. stitan

    stitan Well-Known Member

    I was having a simaler problem I had to set the router to,
    Encryption Technique > TKIP
    Authentication > WPA-PSK
    Security Mode> WPA/WPA2-personal ( psk )

    I could not connect any other way , I hope this helps you out.
    Android Lover1 likes this.
  13. HappyBird

    HappyBird New Member

    I strongly believe there is a bug in the LG Wifi software. I have an Optimus V (Virgin Mobile), VM670ZV4, with Froyo 2.2.1, Kernel 2.6.32.9, Build FRG63.

    It does not process DHCP correctly. I can see from my DD-WRT status page the phone attempts to request an assigned IP address for the phone's MAC address. Thus the password and WPA encryption is working. But the lease time is only 60 seconds instead of the router's 21 day default. After a minute the IP request is shown failing on the phone and it marks the SSID as "disabled" which is meaningless because it will try to connect again and go through the same unsuccessful cycle. The same DHCP failures happen on any other encrypted WIFI that I have tried, not just mine.

    But if I change the IP address to fixed, everything works fine. So it is not the WPA aspect per se (and yes the Wifi sleep options is turned off on the phone). It also works on any unencrypted Wifi connection. So the problem is specific to DHCP on any form of encrypted link.

    This is actually my second phone. Virgin Mobile replace the first one that developed really bad habits like refusing to connected to the 3G network. Furthermore, the first one had acted as above until I did a factory reset. Then it ignore the fixed IP address and always tried the unsuccessful DHCP cycle. So there was no way to use my home network.

    I am curious if anyone has successfully used a Optimus V with an encrypted router without a fixed IP address?
  14. ChazzMatt

    ChazzMatt Well-Known Member

    Optimus V? :confused: NO. We all have Optimus M here. ;)

    My wife and I have two Optimus M and we use ours all the time on my encrypted Linksys N network. with DD-WRT. No fixed IP address. I've also used my phone on a friend's identical network. (I know it's identical because it's the same router model -- I installed DD-WRT on it also and set it up for her and swapped out the router at my house to test it before I gave it back to her.)

    All 3 of us -- me, my wife and our friend -- all have Optimus M with rooted 2.2 (not 2.2.1).
  15. new optimus

    new optimus Well-Known Member

    I have a rooted optimus m with 2.2.1 and my home network uses a trendnet wireless N router with wpa2 encryption and I never have problems, I think someone mentioned if you saved your password incorrectly, accidentally typo ed that might be the problem.
  16. HappyBird

    HappyBird New Member

    Nope. The password is correct. That has been checked and rechecked over and over. My phone is an Optimus V (might differ in detail, i.e. bugs from an Optimus M) and I have not rooted it. The thing is strict vanilla. The replacement phone from VM with the same firmware has the same problem.
  17. new optimus

    new optimus Well-Known Member

    My home router I have mac address filtering, as well as no broadcast ssid and wpa2 encryption, basically if someone did figure out my ssid and my passphrase they still could not connect to the router as the mac address of the device would be rejected unless its on the approved list is there any chance your using mac address filtering as well?
  18. reilus

    reilus Well-Known Member

    I had DHCP problems as well.

  19. reilus

    reilus Well-Known Member

    That's a good question.

  20. AndroidIsMyGPS

    AndroidIsMyGPS New Member

    I have an LG Optimus V with Android 2.2 and I have the same issue as recently posted: It is only happening at one location, the local laundromat. The phone tells me it is a "WPA PSK" connection there. At home I have a WPA2 PSK AES connection, and I have no problem. I have connected to numerous other wifi networks in different places. But there is something about this one location that I cannot connect. I have tried connecting four times now. Passwords have been entered correctly, SSID has been entered correctly.
  21. ChazzMatt

    ChazzMatt Well-Known Member

    Last night I had a similar problem at a pizza restaurant which had free, open wi-fi. Would connect for a few seconds, then disconnect. I would manually re-connect, it would disconnect after a few seconds. I discovered the solution by accident. Opened web browser while it was temporarily connected and there were TERMS I had to agree to -- to keep the connection. I clicked yes, and the phone stayed connected the remainder of the time we were there.

    The only reason I even thought to do that was that had also happened a few weeks ago at a Firestone tire place.
  22. Insanecrane

    Insanecrane Well-Known Member

    Yeah I have the same issue at work, free wifi but if I don't agree to the terms before I try and surf then I get nowhere.
  23. SikTroll

    SikTroll New Member

    Earlier tonight I logged into a friends wifi via Settings>Wireless & network..>etc., to access my ftp at home. Wouldn't connect. Turns out wifi showed as connected but I was still on metros 1x until I ran skyfire and it opened to the routers portal to input the security info again. I did and wifi was up. Funny enough, metro browser did not bring up the portal (tried it first to see if I had a connection at all) and decided it would surf at 1x without letting me know. EVIL
  24. ChazzMatt

    ChazzMatt Well-Known Member

    when it happened to me I had no intention of surfing -- I just wanted the connection for faster email and to check the Facebook app. I just happened to open the browser -- and that's when I saw the terms and conditions agreements. aha!
  25. Oli_817

    Oli_817 New Member

    Im having the same problem, except my phone is not yet on the Metro PCS network. Does my phone have to be activated first in order to use wi-Fi?

Share This Page