General Product registration

Discussion in 'Android Devices' started by siggy1964, Oct 8, 2012.

  1. siggy1964

    siggy1964 Well-Known Member
    48

    Feb 13, 2012
    206
    21
    48
    Male
    Virginia
    I can't seem to register my Infinity on the Asus website. I've tried using O and 0 but it says they are both wrong. I sent them an email but was wondering if any of you have had the same experience.
     

    Advertisement
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Moderator
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    no issue with it. i did it with the prime. but i have not registered my infinty. for me i have Best Buys geek squad protection so i see no need to.

    are you doing this on your pc or infinity?
     
  3. siggy1964

    siggy1964 Well-Known Member
    48

    Feb 13, 2012
    206
    21
    48
    Male
    Virginia
    On my Infinity.
     
  4. sikclown

    sikclown Well-Known Member
    213

    Nov 21, 2009
    1,910
    965
    213
    Male
    Business Owner
    New Orleans, LA
    I have the same problem. I have tried multiple times on multiple PCs, Tablets, phones etc. I had the same problem with the Prime and when I emailed them they said to pay attention to the 0 and o (why they use both is beyond me), which of course I had done a million times, but this time it went through. My guess is when they emailed me they also added my serial to the database. I haven't even bothered emailing them yet this time.
     
  5. pfs78

    pfs78 Active Member
    16

    Dec 21, 2011
    37
    1
    16
    Male
    Senior HelpDesk and Operations Specialist
    Western MA
    Make sure your using the serial number on the tablet and not on the side of the dock, that is the problem I had.

    Confirm the number your typing matches Settings > About Tablet > Status

    The actual serial number is in there

    Paul
     
  6. siggy1964

    siggy1964 Well-Known Member
    48

    Feb 13, 2012
    206
    21
    48
    Male
    Virginia
    Asus finally got back with me. The first one was the letter O and the second one was the number zero. It's registered now. Thanks guys.
     
  7. pfs78

    pfs78 Active Member
    16

    Dec 21, 2011
    37
    1
    16
    Male
    Senior HelpDesk and Operations Specialist
    Western MA
    Cool! :)
     

Share This Page

Loading...