[Profile] [front Camera] Photo/email image of device intruder


Last Updated: 2015-01-13 14:27:33
  1. biggoog

    biggoog Well-Known Member

    I seen that. Buy didn't see where duh! Found. Thanks

    Advertisement
  2. biggoog

    biggoog Well-Known Member

    For those of you who likes to save battery and you have data off, the sendemail will fail if data is off and you will not receive an email. Here's what I did. Tested it and it works for ME!
    You can adjust the wait time and some may not need to have that task. For me it takes a few seconds to bring data up.
    I added task 2, 3, & 10

    Attached Files:

    K55V, Tyseyh and SUroot like this.
  3. SUroot

    SUroot Well-Known Member Developer

    Yeah data always takes a couple of seconds to establish a connection so a wait will be needed.
  4. Tyseyh

    Tyseyh Well-Known Member

    i keep getting USER_EMAIL Missing.
    I have checked and double checked, no extra spaces at the end of the email address for example, the address is correct, any ideas?
  5. MaxPower1

    MaxPower1 Active Member

    I got it to work but I have to say, the instructions were a bit confusing. SL4A doesn't come with Tasker, I had to download it from the link since it's not on the Play Store either. Once I have SL4A installed, I opened it, and installed Python, I had to open Python and click on the install button. It downloaded and extracted some files, IDK what they were. Then I set up the email client on my phone and linked it to my Google account (I'm not sure it that was necessary or if the Gmail app would have been enough).

    After I did all that it still didn't work. I went into Tasker and opened the Task and pressed the play button, I got a "EMAIL_USER missing". I had to edit this:

    + Script > Run SL4A Script > Name (Search icon) sendemailA.py > Pass variables "%EMAIL_TO,%EMAIL_ATTACH,%EMAIL_SUBJECT"

    into this:

    + Script > Run SL4A Script > Name (Search icon) sendemailA.py > Pass variables "%EMAIL_USER,%EMAIL_PSWD, %EMAIL_TO,%EMAIL_ATTACH,%EMAIL_SUBJECT"

    And that worked.
    SUroot likes this.
  6. SUroot

    SUroot Well-Known Member Developer

    Thanks

    Yes you're right I missed two variables when I copied the text (you know you simply could have imported the profiles right? The steps are not so relevant now.)

    I too had to install sl4a but a couple of people in the first few posts said it now came with tasker. Amended back.

    There is a link that explains how to install interpreters (such as python). I am not responsible for its content however.
  7. Tyseyh

    Tyseyh Well-Known Member

    Aye I saw I could off, but I don't know anything about variables so I thought I'd follow the instructions.


    Edit - email now works, picture isn't attached though.
  8. SUroot

    SUroot Well-Known Member Developer

    Need tasker screenshots if you need help. Blank out email address and password first though. I assume the information in those fields is correct
  9. MaxPower1

    MaxPower1 Active Member

    I did see the link to download the profile but it says it's untested so I figured I'd do it manually. It was better that way because I learned a few things along the way :thumb:
  10. SUroot

    SUroot Well-Known Member Developer


    Of course, testers are always welcome too :)

    If anyone has successfully tested, I can remove the "untested"
  11. Tyseyh

    Tyseyh Well-Known Member

    I did it, i made a stupid mistake,turns out in the%EMAIL_ATTACH field, then /Sd/etc etc i had another %EMAIL_ATTACH in there..

    can't believe i didn't even notice!
  12. qandres12

    qandres12 Well-Known Member

    what if you dont want it to overwrite the last pic each time a new pic is taken?
  13. bberryhill0

    bberryhill0 Well-Known Member

    You would rename (move) the picture before saving the new one. It gets complicated if you want to save more than two.
  14. SUroot

    SUroot Well-Known Member Developer

    There are guides to this. I left it out because there would be hundreds of pictures of me. Still is mind. In my mailbox
  15. GTurn

    GTurn Well-Known Member

    Works perfectly on my esteem. Thanks.
  16. Fuzie

    Fuzie Member

    Hi there. My profile is almost the same except that the picture uploads itself by using Dropbox. My problem is that my HTC One X doesn't take a picture when I use pattern lock even though I use the same setup as you. So I was thinking, do you have a solution? :)
  17. silentwitness

    silentwitness Well-Known Member

    hey i am just curious this would only work with pattern unlock and not pin lock right?
  18. silentwitness

    silentwitness Well-Known Member

    @Fuzie do u have secure settings and secure settings helper installed?
  19. Fuzie

    Fuzie Member

    my phone is not rooted so i think that's the problem. Your Phone have to be rooted before you can install the helper.
  20. Fuzie

    Fuzie Member

    i'm currently using it with pin so it's not just for patternlock. it depends on the settings you make in secure settings I think
  21. silentwitness

    silentwitness Well-Known Member

    i dont think it works with pin i have it setup it only works when i set a pattern and not a pin
  22. Fuzie

    Fuzie Member

    Sounds like it depends on the phone now, is your phone tooted? now i really just want to know, because i would love to have it work with pattern too!
  23. silentwitness

    silentwitness Well-Known Member

    i am using the galaxy s3 rooted running omega rom 4.1.2 and it does not work with the pin lock only with pattern.
  24. Fuzie

    Fuzie Member

    that explains why u can use the pattern. I still can't figure out why you can't use pin option. doulbe checked that you are not using keyguard instead of pin?
  25. silentwitness

    silentwitness Well-Known Member

    im using pin option in the s3 but i dont think its supported

Share This Page