1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

"Protected" app Market fix tutorial - build.prop

Last Updated:

  1. Rogdor

    Rogdor Member

    This tutorial is for getting protected apps to show on the Android Market on your Samsung Galaxy Spica. It may work for other phones too, but your mileage may vary.

    NOTE: I cannot take responsibility if you mess up your phone using these instructions. I try to go into reasonable detail here but different firmwares behave differently.

    SECOND NOTE: This requires root. I also recommend backing up first using Titanium Backup.

    The Android Market is a bit confusing on how it shows apps available to your phone. There are basically three categories of apps:

    • Free & Unprotected - Everyone should be able to see these on the Market.
    • Paid & Unprotected - People in certain countries can see these apps, based on your SIM card information. If you can't see any paid apps at all on the Market, you can try a program like Market Enabler that will mimic SIM info for other countries. I don't cover how to do that in this tutorial but it's easy to find how-to instructions elsewhere. I'm in Canada so I haven't had to worry about the country lockouts.
    • Protected (Free or Paid) - If an app is set as "protected" then Google checks your firmware and only allows it to be seen if you have one of the firmwares on their accepted list. If you have flashed a firmware or have root, you probably cannot see these apps on the Market. That's what this tutorial will try to fix.

    Before we start, check the Android Market from your phone using the Market app (the official Google one, not Appbrain or others). Search for "dr droid". There are two Dr. Droid apps, a free and a paid version and both are "protected" apps. If you can't see them, then your firmware probably isn't cleared for "protected" apps.

    The first thing you can try is the Eris Market Fix. This works with some Spica firmwares (but not all). It doesn't hurt to try, here's the AppBrain link to the app: Eris Market Fix - Free - Android app on AppBrain

    What that app does is change your firmware's fingerprint in your build.prop file. After you've applied it, you may need to reboot your phone for all the apps to show up on the Market. If rebooting doesn't work, try setting the date on your phone manually to 11:59 and let it go past midnight (this resets the Market cache sometimes, but didn't work for me). If this works, it's all you need to do.

    The Eris Market Fix didn't work for me (I'm using firmware I570EXXJE1 on my Spica), so I figured out how to change my build.prop manually.

    Step One: Get your build.prop file using adb:

    This requires installing and using the Android SDK. You should be able to figure that out yourself. Once you do, use adb to copy your existing build.prop file by typing:

    Code (Text):
    1. adb pull /system/build.prop build.prop
    Step Two: Edit your build.prop file:

    Now, edit that file from your PC with your choice of text editor. You might want to back it up / copy it first. Find the line that starts with ro.build.fingerprint= and replace the whole line with:

    Code (Text):
    1. ro.build.fingerprint=verizon/voles/sholes/sholes:2.1-update1/ESE81/29593:user/release-keys
    What this will do is let your phone pretend its a different phone (a Verizon Eris upgraded to 2.1) that's been approved by Google. As far as I know, this info is only used by the Market and isn't used elsewhere. Theoretically there could be other limitations for the Eris, but realistically I haven't seen any apps restricted by that exact phone. If you keep your original build.prop file you can always put it back the way it was.

    Step Three: Put the build.prop file on your SD Card.

    Easy step, move the edited version of the build.prop to your SD card using your phone or a card reader. If you've read it directly from your phone, remember to unmount it after so your phone can read the card again.

    Step Four: Remount your phone's /system directory.

    Using adb again, type:

    Code (Text):
    1. adb shell
    2. su
    3. mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system
    This is temporarily removing the restrictions on the /system directory. Be very careful once you've done this, because you don't want to accidentally delete anything in that directory.

    Step Five: Move your build.prop over the old one.

    You should still have the adb shell open. Type:

    Code (Text):
    1. mv /sdcard/build.prop /system/build.prop

    Step Six: Reboot.

    Exit adb shell (typing exit will do it) and then reboot your phone. Rebooting will set the restrictions on your /system directory back to a protected state.

    Step Seven: Check the Market and remove cache if necessary.

    Check the Market for "dr droid" again. If you don't see the apps, then try setting your time manually to 11:59 and let it roll past midnight. Check the Market again. If you still don't see the apps, you may have to delete your cache. Deleting your phone's full cache may require a factory reset on your phone and that kinda sucks, but you can avoid losing everything by first backing up with Titanium Backup. Since Titanium doesn't affect the /system directory you won't lose your build.prop changes from a backup and restore.

    For deleting the cache, I used the Samdroid reboot recovery since I already had that installed. You should also be able to do a factory reset via the Settings menu in Privacy.

    . . .

    Hopefully someone finds this tutorial helpful. Again, I didn't go into absolutely full detail because I figure if you cannot figure out things like the SDK then you should think twice before modding your phone this way.

    Good luck. =)

    MHC59 and labarks like this.
  2. TMW597

    TMW597 Member

    Step One: Get your build.prop file using adb:

    This requires installing and using the Android SDK. "You should be able to figure that out yourself." Once you do, use adb to copy your existing build.prop file by typing:

    I can't figure it out myself. Can you explain this step a little bit please so it's more clear. Thanks.
  3. Beerkan

    Beerkan Well-Known Member

  4. TMW597

    TMW597 Member

    Thanks for that. (Said facetiously.) I'm aware of that. When I post, I'm just very specific with each instruction as to not raise too many questions. For example I wouldn't write "...put the file back on." I'd write put the sample.doc file onto the c drive by using example program, and going to..." You get the point. It just makes for a more concise posting. That's all I'm saying.
  5. TMW597

    TMW597 Member

    Getting a "su: not found" message when doing step four. Thoughts?
  6. Beerkan

    Beerkan Well-Known Member


    See second Note from Rogdor's post.

    Root is permission on the phone to make administrator changes.

    What firmware are you on?

    About Phone
    Baseband No.?
  7. TMW597

    TMW597 Member

    Samsung Galaxy S (UK unit)
    Firmware: 2.1-update1
    Baseband: I9000XXJE6
    Kernel: 2.6.29 umts_sm@S1-BUILD05 #2
    Build: Eclair

    I flashed this version to the phone in lieu of the factory firmware.
  8. Beerkan

    Beerkan Well-Known Member


    two things.

    I doubt you have root permission, as you specifically have to add that


    This is a i5700 Galaxy Spica forum, so I don't know much about rooting a Galaxy S.

    Gimme 5 minutes to look into it..

    Things are looking up...

    Root your Galaxy S

    LeshaK we know!!
  9. TMW597

    TMW597 Member

    Copy that. Thank you!

    Yeah, I was here just mainly because it's an Android OS device. I was just trying to piece it all together. It as been an experience for sure. I just want to download the Slingplayer app!
  10. Beerkan

    Beerkan Well-Known Member

  11. Beerkan

    Beerkan Well-Known Member

    Your best bet is to bounce onto the Galaxy S forums and seek further advice there.

    Once your rooted, you can continue your Market Fix.

    And when you're rooted, there's loads more you can do on your phone.

    Ask about Apps2SD on Galaxy S forum for example.
  12. TMW597

    TMW597 Member

    So once it's rooted, in theory, the same instructions for this thread should apply since it's the same OS correct?
  13. Beerkan

    Beerkan Well-Known Member

    yep.. 100%
  14. TMW597

    TMW597 Member

    Much appreciated Beerkan! I'm looking at the two guides. It looks like I have the choice of a SU and delete all of my current data, or the alternative. I just hope the alternative works before I have to resort to the former.

    Thanks again. I'll keep you posted.
  15. Beerkan

    Beerkan Well-Known Member

    You can checkout this quicke Backup Guide I wrote a while back for Non rooted phones.

    Beerkan Quickie Backup Guide
  16. TMW597

    TMW597 Member


    Thanks again for all of the help. I'm good to go now on my Galaxy S. I used one of the links you pointed me to, to root using Superuser+su+busybox for i9000 v.2. After that I tried the fix here in the post, but I kept getting a protected error in the terminal program. Lastly I installed MarketEnabler 3.0.8 did one of the searches in he Market, and all four showed up!

    Download MarketEnabler 3.0.8 for Android Free - MarketEnabler is an application to fake the phone's location and access markets from other countries. - Softpedia
  17. rommel_espino

    rommel_espino New Member

    sir may be you could help me with my problem. i bought my new samsung galaxy spica with a 1.5firmware..but when i start browsing the menu app i do not have the market app. so i wonder if this normal and i have to download it first or i my phone has some problem...manual say it has but the phone does not have this application. sorry sir this is my first time to own a android phone. thank you in advance sir
  18. mattdilbeck

    mattdilbeck New Member

    At Step 5 I get this error:

    "failed on '/sdcard/build.prop' - Cross-device link"
  19. dexmix

    dexmix Active Member

    this happens when you don't have r/w access to system. You need to remount. If you have S-ON you need to boot into recovery before adb shell. This is the only way to get R/W to /system with S-ON. Are you fully rooted?

    (My rooted Aria - keeps S-ON. I have to be in recovery to push to /system)
  20. labarks

    labarks New Member

    Using these instructions and the old Aria fingerprint from XDA, I was able download protected apps from the market again. I did need to reboot my Aria into recovery mode to move the build.prop file and clear the Market app cache before it worked though.

    xda-developers - View Single Post - Stock 2.1 build.prop fingerprint

    Someone should make an app for this (and that would remove it when its finally fixed for real), just like the Eris Market Fix app.
  21. snakemanuver

    snakemanuver New Member

    Hello, I recently unlocked and rooted my samsung captivate from rogers here in Canada. I used this guide:
    Installing Froyo on Rogers Captivate - xda-developers

    Everything seems to be working fine except my android market which only shows limited apps. After hours of searching through forums, almost all of them required getting apps such as clockwork or root explorer to overwrite the old build.prop file.

    Your guide is the one that will only work for me. I am just having a problem getting the file into the /system/ folder through adb. What exactly do u mean by S-on? Also, even in recovery I am denied access to /system/
  22. yellowsnow

    yellowsnow New Member

    I'm stuck at Step 4.

    I'm so close, I got everything else done. I edited build.prop, backed it up on my HDD, and copied over build.prop to the root of my Archos 32.

    Now I'm trying to move it to /system/ and overwrite the build.prop file there.

    I keep getting a "permission denied" error:


    BTW, I'm running Ubuntu 11.04 x64

    If anyone can help me in any way I'd really appreciate it; I've been at this for hours.

  23. watley94

    watley94 New Member

    OK im not sure if this post is in the right location but here's my dilemma:

    I have a rooted motorola cliq and adb on my computer but recently i was trying to "unprotect" my market by editing the build.prop file in my phone's system.
    CMD prompt was giving some weird "cross device link" error whenever i tried to copy the new edited build.prop from my sd card and replace the old system file so i decided to use an app instead, root explorer. the app worked perfectly, the problem is that i made an error in the edited file...
    I deleted the line that starts with "ro.build.fingerprint=" like i was suppose to but i made a copy n paste error from your post and i replaced that line with
    "ro.build.fingerprint=verizon/voles/sholes/sholes:2.1-update1/ESE81/29593:user/rel (rest of lines)"
    instead of
    "ro.build.fingerprint=verizon/voles/sholes/sholes:2.1-update1/ESE81/29593:user/release-keys (rest of lines)"

    (Ill attach the bad build.prop and the original so you can see what i mean)

    Ok here comes the main issue:
    I didnt catch my mistake and i reset my phone to factory settings like the next step says to (i backed my apps up using mybackup which saves to the sd)
    but when my phone turned back on, it repeatedly says that
    The process "(EVERY SINGLE PROCESS)" has shut down unexpectedly. Please try again"
    I can see the motoblur screen in the back and in between pop ups i can click next and get the phone to the main menu which is completely blank
    even the process "HOME" wont open. Luckily, in between fighting the pop ups of "this process has shut down" i can manage to get the phone to turn on usb mode. I COULD EASILY FIX MY PROBLEM BY EDITING THE build.prop but i need a way to get into my system folders, not sd card. On my computer, if i type adb devices in cmd is doesnt list any devices so cmd wont help me here...
    THANKS IF YOU READ THIS FAR and wish me luck!!!

    P.S please recommend me to some other android help forums or anywhere i can get help is appreciated. this doesnt seem like it should be that hard a problem to fix...

    Attached Files:

Share This Page