[PSA] You can flash sbf files in Linux


  1. OMJ

    OMJ Bazinga VIP Member

    I have addressed this in a number of threads but I think it needs it own. [MBM] the guy would reverse engineered an sbf file to flash SPRecovery also made it possible to flash sbf files in Linux.

    Instructions and needed files can be found on his blog here

    OPTICALDELUSION: sbf_flash



    I don't currently run Linux on any of my computer so I cant be of much help with this but I have talked to people that have done it and it does work.

    Just wanted to show people there is another option other than just windows for rooting the droid. If you run Mac Os then I cant help you though.

    Advertisement
  2. Very cool thanks for the heads up!
  3. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    My guess is that it should not be too different to run it on MacOS as well...

    Unfortunately I am already at home, so I cannot try it - let me see tomorrow on Leopard....
  4. Earthalker

    Earthalker Member

    I tried using it on Mandriva 2010. Got stuck at waiting for phone loop. I tried it with the phone in bootloader mode, regular mode. Tried running it as a regular user, and as root.

    I downloaded and tried again, same results.

    I understand that this installs the SPRecovery so that I can save the data and info off of my phone. Does it do anything else?

    I went ahead and tried flashing using update.zip from the recovery menu. Get an error about signature and aborts update.

    I am not clear on what each step does. The instructions just say do this, then that now you are done. I would like to understand what each step is doing.

    Thanks
    Earthwalker
  5. OMJ

    OMJ Bazinga VIP Member


    If you boot into recovery does it Say SPRecovery?
  6. Earthalker

    Earthalker Member

    When I went to the bootloader there was no SPRecovery.
  7. nstallion

    nstallion Well-Known Member

    You need to flash the .sbf with SP Recovery on it before you can load a custom update.zip

    I was gonna try this in OS 10.6.4 but it looks like I can't run the binary without actually having the phone attached and an sbf ready. Since I don't actually want to flash anything did anyone ever figure out if this works in OS X?
    Earthalker likes this.
  8. Earthalker

    Earthalker Member

    Is there a way to tell if the SBF file has SPRecovery? I have found a few different SBF files.
  9. nstallion

    nstallion Well-Known Member

  10. nstallion

    nstallion Well-Known Member

    I'd still like to know if anyone has tried using this to flash from OS X.
    Earthalker likes this.
  11. OMJ

    OMJ Bazinga VIP Member

    dont go into the bootloader go into recovery. Hold X while powering up the phone to get into recovery. Hold up on the Dpad to get into the bootloader
    Earthalker likes this.
  12. Earthalker

    Earthalker Member

  13. Earthalker

    Earthalker Member

    Sorry I miss spoke. I have only been able to get into recovery mode. Pushing up toward the screen, or up toward the keyboard, I get a normal boot.
  14. OMJ

    OMJ Bazinga VIP Member

    Yea I havent had time to do the section on Linux and really havent played with it much at all myself yet. I may have time this weekend to work on that.

    If you are unable to get into the bootloader that is the problem. With the keyboard out and the phone in landscape orientation. Hold up on the dpad (pressing towards the capacitive buttons) while powering on the phone should get you to the bootloader. You have to be in the bootloader in order to flash sbf files. If you cant get there thats the entire issue.

    There may be a way to root 2.1 without having to flash sbf files coming along shortly. I know its possible to adapt the root method for the Droid X to the droid but its beyond my ability to do. I mentioned it to Birdman today so I am hoping that he will do it.
    Earthalker likes this.
  15. Earthalker

    Earthalker Member

    Thank you so much for clearing that up. By working with up towards the screen. I know can put up, power button, reliese power button.

    Now I am getting into the boot loader each time. I can't wait to get home and give it a try!
  16. Earthalker

    Earthalker Member

    Thank you so much! That was the problem. I got into the boot loader, and now I have a rooted Droid with a custom ROM! This community rocks! One of the many reasons I am an open source fan!

    Thanks
    Again.

    PS. OMJ I am writing up the steps I did to root my Droid with Mandriva. Would you like to add them to the guide?
  17. OMJ

    OMJ Bazinga VIP Member

    no problem glad you got it working. If you write it up I will add it to the guide.
  18. nstallion

    nstallion Well-Known Member

    But does it work in OS X?? That's the REAL question here. And by real question I mean the one that has nothing to do with the original thread really but I am interested in knowing the answer to.
  19. Earthalker

    Earthalker Member

    All done with the steps I took. It is on an OpenOffice document. How would you like to get the info?

    Thanks again for taking your time and helping me out with this. So far I am so much happier with 2.2 on my phone! It just rocks.
  20. OMJ

    OMJ Bazinga VIP Member

    I dont think it does but then again I dont have OSX so I havent tried.
  21. Earthalker

    Earthalker Member

    Unfortunitly Apple changed things enough that lots of things that work on one will not work on the other. I don't have an Apple to know.

    Good luck, and thanks for the link. It worked like a charm!
  22. OMJ

    OMJ Bazinga VIP Member

    if its the same thing that you just posted in another thread I will just take it from there. Probably wont get around to putting it up today though. I actually have work to do at work today who would have thunk it.
  23. Eugene

    Eugene Well-Known Member

    Rooted mine last night from my netbook running slackware, just trying to decide on a 2.2 rom now.

Share This Page