Pulled battery early, hosed appsGeneral


Last Updated:

  1. nickf77

    nickf77 Well-Known Member

    I was doing a routine battery swap just before running out the door today, during which I usually power down and remove the battery, put another one in, turn it on, and get on with my life. Today, however (and this is about the 3rd time I've done this), the phone was feeling a little sluggish I guess, because it didn't fully power down before I plucked the battery. I cursed myself. I knew what I had just done.

    It started up again like normal, the "htc Incredible" screen and the red eye screen showing nothing different, but when Sense loaded, I got about 25 "Force close" dialogs for tons of different apps. And hardly any of the apps even opened anymore (they open for like 1-2 seconds, then force close) except for the stock apps. This time I couldn't even get aTrackDog to open up to do a last second backup of my apps list. Screw this. Luckily, I was able to use the Market and hastily searched for "apps backup", yielding, among others, "OnTheFly Backup", "App Backup & Reinstall", and "App List", which I downloaded successfully and used to backup my dying phone.

    Factory reset time. Sigh. I decided to make a chart of my home screens this time before wiping it though - you'd never believe how much you rely on those home screen shortcuts until you don't have them. 10 minutes later, factory reset finally done, and I'm burdened with the task of getting the "extension of my brain", as I like to refer to my phone as, working again. "App Backup & Reinstall" turned out to be the best backup app, and it literally took 5 minutes to batch install all the apps. That doesn't include all the time to reset all of your settings and junk in every single app. Talk about a pain in the buhoot. I'm still working on getting it back to operational status as I write this. All because I pulled the battery 0.35 seconds too early. That's just wrong. Hopefully this bug, no ISSUE, gets realized and fixed in the near future, because "battery hotswappers" like me are bound to do this one time or another.


    A few notes, after that long-winded story:
    • This only happens on Froyo (Android 2.2)
    • Some apps were uninstalled completely from my phone when the hosing happened, and the homes screen shortcuts just linked to nothing.
    • None of your personal data (settings, highscores, preferences, etc.) is saved when you backup/reinstall the apps. Sucks.


    So, any similar stories? Also, did anyone else come up with a better way of dealing with the problem or a better way of disciplining yourself to wait until the phone COMPLETELY shuts off (which, by the way, is a split second AFTER the screen turns off, for the record)?

    Happy Holidays, though this wasn't the ideal Christmas present I was hoping for. Oh well. Droid > iPhone anyday.

    Advertisement
  2. sta7ic

    sta7ic Well-Known Member

    i swap batteries all the time and this hasn't happened to me. My phone is rooted so I'm able to use titanium backup to back up all my apps and their data. You can use nandroid as well every couple of weeks to make sure you have a nice safe image on your phone.
  3. nickf77

    nickf77 Well-Known Member

    Is Nandroid available for the Incredible? A Market search for 'nandroid' turns up nil.
  4. sta7ic

    sta7ic Well-Known Member

    a nandroid backup is part of being rooted. You use rom manager to do the nandroid.
  5. cpupeli1

    cpupeli1 Well-Known Member



    Same thing happened to me. I was pissed, it occurred doing the same thing. I was swapping batteries and while it was powering down I must have pulled the battery too early. I've since learned and moved on to using the 'power off' option on Quickboot, it powers down my DINC at least 3x faster than the stock option....just a thought if you are rooted.
  6. chenzales

    chenzales Member

    this used to happen to me too. at first i thought something got messed up because of rooting (although it ran perfectly fine for several days), but even after a factory reset to stock it happened a few more times. i also thought it was my fault for pulling the battery too soon before the phone powered off, but even when i shut down the phone completely before pulling the battery it happened once or twice. it also happened after a random reset.

    do you happen to use launcherpro? it stopped ever since i switched to ADW. sucks since i had the paid version of launcherpro... still not entirely sure if that was the problem or not, since so many other people are using it on the dinc, but my phone is running pretty smoothly now.
  7. Bluecrema

    Bluecrema Member

    This seems to be the right thread for me tonight.

    My Phone battery reached critical and shut down. I got home plugged it in and let it charge for a while. I then turned it on and all things seamed normal and as soon as I unlocked the screen everything was force closing.

    When I try to launch any application it force closes. What is interesting is that most apps when launched will prompt with release notes or user agreements continuously before Force closing.

    I launched the Market Place and noticed it reverted back to the old Market Place style prior to the recent update it then prompts to the user agreement then force closes. (Note that after several Power Downs & Battery Pulls it is now showing the new version but still force closes)

    I use Apps Organizer and it crashes and I can not launch it either.

    The programs I can open have all reset to defaults settings, including default options when accessing say contacts it asks if I want to use People or Youlu Addressbook.

    Has there been some sort of OS update pushed down today possible that could be causing these issues?

    I have need to get my phone working 100% again. It has been working flawless since I got it in April this year. Any help or advice from you guys is greatly appreciated. I would prefer NOT to factory reset if possible. I need to get my apps working again.

    I don't root, Running Froyo 2.2
  8. Bluecrema

    Bluecrema Member

    Additional information. I have been able to get some programs to work like tweetdeck and my Youlu Addressbook however both applications lost all my configurations. Like tweet desk did not have my twitter and facebook account setup and I had to re-setup. Youlu settings were all defaulted to original install. I reset up my favorites. Things don't appear to be saving my settings and reverting back to the defaults again. UGGGGHHHHHHHH
  9. droidmo

    droidmo Well-Known Member

    I made this mistake of pulling the battery while it is powering down and had to do the exact same thing, factory reset. Now I dont even bother turning my phone off when I pull the battery and have had no problems with this technique.
  10. HoochieCoo

    HoochieCoo Well-Known Member

    I was going to say this. The few times I've done a battery pull, I just pop the back and pull it. Didn't even bother shutting it down. I can imagine that during shutdown it's possible the OS is writing data, and pulling the battery during this process leaves something in some partially written state. Dunno.

    If you are rooted, I would probably see what a cache and dalvik wipe would do before doing a factory reset.
  11. Eris DeWitt

    Eris DeWitt Active Member

    I was told by VZ that the phone holds a charge for about thirty seconds after you power down. Since then I've always waited a couple of minutes before pulling the battery after powering down. Anytime my phone slows down or gets a little buggy I pull the battery while the power is on, and it always fixes the trick.
  12. FramCire

    FramCire Well-Known Member

    This is a place where root is so nice.

    Schedule Titanium Backup to do regular backups.......do nandroid backup through ROM Manager....... never worry....
  13. Bluecrema

    Bluecrema Member

    I am going to do a Factory Reset. Can't take the pain anymore today. I tried searching the forum on this but can not get a clear answer. If I do the Reset how do I get my apps back? including the paid ones? It sounds like the market place knows based off your gmail account but I am not sure. If it is tracked by your gmail account is there a way to see the apps you have downloaded online?
  14. twmarrs

    twmarrs Member

    First get the 3500 battery and case, if not then don't power down when changing the battery just open it up and switch out the battery with it still on and it will reboot just fine. My 2 cents get the battery changed to the 3500 and you'll never look back...
  15. nickf77

    nickf77 Well-Known Member

    I'm not rooted, as you can probably tell from my confusion about the whole nandroid backup question I asked, but I'm seriously considering it as I'm fairly tech savvy and it looks like it's got some nice little tweaks.

    What's launcherpro?

    Good point; I'll be trying that.
  16. nickf77

    nickf77 Well-Known Member

    It's happened to me 4 times now, and each time I've searched as vigorously as I'm sure you have for some kind of a solution other than a factory reset. Unfortunately, that's all I've been able to come up with. Hopefully you can get an app backup (try the ones I mentioned in my first post) so you don't have to find all your apps again.

    EDIT: I'm also running Froyo, unrooted. And it only started happening after updating to 2.2
  17. BetaMan

    BetaMan Well-Known Member

    I've NEVER experienced this. With Froyo, without froyo. Rooted or unrooted. The only time something like this has happened to me is when I forgot to dismount the drives while attached to a computer before unplugging the usb cable. Never from pulling the battery or shutting it down.

    Hmmm....
  18. nickf77

    nickf77 Well-Known Member

    It must just be a certain time during shutdown when the OS is writing system files or something (maybe?) because there's been times when I rip the battery out far earlier than this time and it doesn't cook the OS alive. I can't really narrow it down without doing some testing, which would just be silly I think.
  19. katsworld

    katsworld Member

    Bluecrema I had the exact same problem this morning, everything went haywire and was wacky acting! Had to put everything back the way I had it! Funny thing was I thought I saw in all the flashing on and off I saw the word update but I don't see where anyone else has said anything!!
  20. twmarrs

    twmarrs Member

    I'm telling you do not power down just pull out your battery.

    Think about the time you dropped the phone and case flys open and battery go's too and then you just put it back in and fire it up, hey it still works remenber..........

Share This Page