Pulled the battery and hosed my IncSupport


Last Updated:

  1. ctc

    ctc Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    281
    Likes Received:
    30
    I was going to swap batteries this evening because I drained the one in my phone. I chose the "power off" option but didn't let it shut completely off before I pulled the battery (I got distracted and pulled the battery without checking if it had shutdown). I booted up the phone and all of my installed apps are hosed. They force close as soon as I open them. Third party widgets don't load either. Any apps that were preinstalled are fine (such as Gmail and Maps).

    I connected the phone to my laptop and both the internal storage and SD card appear to be fine.

    Anyone have any ideas to fix this? If no one has any ideas I'm gonna have to do a factory reset....
     

    Advertisement
  2. A.Nonymous

    A.Nonymous Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    7,061
    Likes Received:
    965
    I don't suppose you have a nandroid backup.

    You may be able to get away with uninstalling/re-installing the apps that keep crashing.
     
  3. jtb199

    jtb199 Well-Known Member

    Joined:
    Feb 3, 2010
    Messages:
    124
    Likes Received:
    4
    Wow...

    Just got through doing the same thing...

    I did a factory reset today to try and fix some problems...type lag, battery life..blah,blah,blah...started rebuilding my phone with apps and such.

    I have the dreaded not showing my city in the weather app...the only way that I have found was to shut off the phone, battery pull...leave it out for a few mins...boot back up...problem solved...for some crazy reason that fixes it...

    So...I was going to do the "fix" and pulled the battery to soon...and everything started happening to me as you described...

    I really dont have an answer other than I uninstalled and reinstalled my apps...some took a couple of times of installing and reinstalling...but so far so good...

    And...I took my micro SD card out without unmounting it also during all this mess also...

    So who knows...dont know if it was the battery pull...or taking the card out...

    Sorry for the long winded reply...

    My only advice is trying what I mentioned above with your apps...


    I also took my card out...with the phone off...blew out the card slot...dont have a clue if that had anything to do with it but I was freaking out and was trying anything...

    Good luck...hopefully someone else can chime in with a better fix?...
     
    nickf77 likes this.
  4. ctc

    ctc Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    281
    Likes Received:
    30
    Yeah I'm not sure if uninstalling/reinstalling my apps will be easier than just doing a factory reset and resinstalling the apps w/ appbrain. Also, Sense has crashed on me twice so it is unstable as well.

    I guess I'll be doing a factory reset soon....
     
  5. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Joined:
    Aug 5, 2010
    Messages:
    5,577
    Likes Received:
    1,958
    Hope you blew out your card slot with a can of compressed air and not your mouth that can do damage to the slot
     
  6. ctc

    ctc Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    281
    Likes Received:
    30
    Ok did factory reset and all is good.

    Don't pull your battery during shutdown!
     
  7. jtb199

    jtb199 Well-Known Member

    Joined:
    Feb 3, 2010
    Messages:
    124
    Likes Received:
    4
    I did...:D
     
  8. jtb199

    jtb199 Well-Known Member

    Joined:
    Feb 3, 2010
    Messages:
    124
    Likes Received:
    4

    Good...glad to hear...
     

Share This Page

Loading...