Push Email while roaming


Last Updated:

  1. stoked

    stoked Member This Topic's Starter

    Joined:
    Nov 29, 2009
    Messages:
    7
    Likes Received:
    0
    I have a TELUS HTC Hero and a few days ago I was visiting Seattle. While roaming on AT&T my Hero would not do push for my Exchange mail. When I checked the update frequency it was set to "As items arrive" but the field said something like "Sync disabled while roaming". I find it really stupid that this isn't a user setting. Has anyone else found this? The other odd thing was that I couldn't send out mail via Exchange while roaming.
     

    Advertisement
  2. chickenlump

    chickenlump Member

    Joined:
    Nov 28, 2009
    Messages:
    23
    Likes Received:
    3
    I think they do they so you wouldn't connect to Rogers and end up with roaming charges in Canada.
     
  3. stoked

    stoked Member This Topic's Starter

    Joined:
    Nov 29, 2009
    Messages:
    7
    Likes Received:
    0
    Doesn't make sense to me. Do they do the same for Iphones? I can connect with everything else, websurfing apps that use network.
     
  4. afonja

    afonja Well-Known Member

    Joined:
    Oct 26, 2009
    Messages:
    203
    Likes Received:
    7
    Hello,

    Please check that in Settings > Wireless controls > Mobile network settings > Data roaming is checked.

    Regards
     
  5. stoked

    stoked Member This Topic's Starter

    Joined:
    Nov 29, 2009
    Messages:
    7
    Likes Received:
    0
    That was set. I should have posted that in my original post. Surfing, other apps, etc could all access internet while roaming. I could manually refresh my exchange mail but push and sending was not working.
     
  6. afonja

    afonja Well-Known Member

    Joined:
    Oct 26, 2009
    Messages:
    203
    Likes Received:
    7
    Correct me if I'm wrong,

    But it's using SMTP server of your mobile provider to send email's and they very often allow it only when you are in their "home" network. So while roaming they recognize you as "outsider"?!
     
  7. stoked

    stoked Member This Topic's Starter

    Joined:
    Nov 29, 2009
    Messages:
    7
    Likes Received:
    0
    With Microsoft Activesync the phone doesn't use SMTP servers directly. The exchange server sends the email and your phone generally communicates with the exchange server via HTTPS.
     
  8. afonja

    afonja Well-Known Member

    Joined:
    Oct 26, 2009
    Messages:
    203
    Likes Received:
    7
    As I never use it I cannot help you any more... :(

    Just try to go

    Settings > Data synchronization > Exchange ActiveSync and try to look there
     
  9. Cypherak

    Cypherak New Member

    Joined:
    Feb 16, 2010
    Messages:
    1
    Likes Received:
    0
    Ok, My Hero was doing the same thing. I found the settings here to enable sync while roaming.

    Press HOME > MENU > Settings > Data synchronization > Exchange ActiveSync. Press MENU, and then tap Settings. Check "Sync when roaming."
     

Share This Page

Loading...