[Q] Samsung Exhibit 4g was brickedGeneral

Last Updated:

  1. anushm

    anushm New Member

    Hi All,

    My samsung Exhibit 4g was bricked. I installed ROM Manager on it and restarted. It was bricked 2days ago after installing ROM Manager.It is not booting up blank screen or Samsung exhibit screen is shown up dats it..Can any one help me in fixing this?

  2. Baddude8

    Baddude8 Member

    Easy fix. Fixed that many times.
    You need Odin 1.85, zimage.tar, and a good Samsung tether drivers. If the drivers you have don't work, let me know.
    Take the battery out of phone. Hold both up and down buttons down. Plug your USB to phone and PC. Then put in battery. Make sure the up and down buttons are hold down the whole time. That should take you to the download screen on your phone. Yellow digging android.
    Stay away from Rom Manager. We don't have any custom rom for our phones yet.
    Samsung Exhibit 4G - Page 19 - xda-developers
  3. Wanted11

    Wanted11 New Member

    my phone got stuck at start up screen...it says exhibit 4g and on the botton samsung thats it..can anyone help plz..noob at this..
  4. Baddude8

    Baddude8 Member

    Try reading my post above, if both of you guys are still having problems, I can help. But you learn much more by discovering it by yourself, like I did last Christmas when my phone was soft bricked.

    Good luck.
    korfus likes this.
  5. satanschild666

    satanschild666 New Member

    i had the same problem iit bricked, i even tried odin no dice, and then i went to heimdall, i used the pda option using zimage.tar. nothing worked, i thought my phone was toast.. after two hours of being frusterated and reading these posts (thank you all so much) i did as you said above pulled out the battery held down the up and down volume, plugged the phone into the computer and didnt replace the battery, removed the sd card and the sim card as well. in seconds it flashed the zimage.tar file, it restarted i immediatly put back in the sim and sd and hard reset the phone after reboot. all is well! hope this helps out anyone unable to recover brick after odin.
  6. jmanmontel

    jmanmontel New Member

    i bricked my phone yesterday and ive been going nuts, my computer wont recognize my exhibit even though i dowloaded the drivers 100 times, i also have the original usb cord that came with the phone but my computer still wont recognize it, can someone plz help me
  7. korfus

    korfus New Member

    I found that if you do what baddude8 describes above (but with mine I also removed the SD card #hot# before the battery) then it finally worked, kind of "trial and error" learning here myself... all good now.
  8. qnl44

    qnl44 New Member

    ODin doesnt recognize my phone
  9. onsketch

    onsketch New Member

    hi i know this was answered with the first posting but i really didn't understand how to unbrick the galaxy exhibit . could some one please explain it better or a link were it goes thru all the steps thoroughly. thank you
  10. sc2dave1

    sc2dave1 Member

    Mine keeps acting weird. At times it keeps calling the same number by itself over 10-15 times,it freezes, I try to call and it disconnects,camera sometimes won't work,etc.... what can I do to perhaps fix this? I don't know anything about roms, drivers,etc... Very NOOB!!!
  11. onsketch

    onsketch New Member

    My boy what have you done to your phone so far , what ROM are you currently using?
  12. sc2dave1

    sc2dave1 Member

    Weird thing is that I have never done anything to it.no root no nothing.It does this on its own.
  13. sc2dave1

    sc2dave1 Member

  14. LckyBoy

    LckyBoy New Member

    I am sorry to bother you. I know you've explained this already and I've read screw all of it. And sounds like these guys have done exactly what I did to my exhibit 2. I flashed custom recovery for clockworkmod from Jocala my phone wouldn't stay in recovery when I manually did it with the buttons so I used ADB to force it into recovery. Once there I applied the update. And then I rebooted the system rebooting the system didn't get all the way up it stopped just after the ferry first Samsung sign it went to a backlit black screen if that makes sense. Like lights are on but nobody's home. I believe I have everything I will need to fix the problem except for the tether driver I'm running Windows 7 Ultimate 64 bit on my desktop do you by chance have a link or a copy of the driver I would need? If so that would be fantastic. You can reply here or LckyMe420@Humanoid.net. Thanks again, here's a link to my Dropbox so you can see all of the files that I handed tended to use first time around
    the file I used: cwm.6012.t679.Zip
    can you can you help me or maybe tell me what I did wrong. Much appreciated

Share This Page