[Q] Unable to root..


  1. Phryxus

    Phryxus New Member

    First off, yes I know there are a bagillion threads on not being able to root, and I have spent hours looking through them and my issue isn't resolved, so hear me out.

    I just got a Droid Incredible (has Froyo and an AMOLED screen) after my Droid 1 cracked its screen (easily rooted, btw), and tried rooting this with unrevoked 3.32 (newest from his site). I followed this explicit guide verbatim (here).

    Unrevoked fails to root, install recovery, or turn off security, giving me the ERROR "Backup CID is Missing" that is mentioned in the guide, so I follow the linked instructions on how to manually flash a recovery image to the device (here)

    After booting into hboot with the PC36IMG.zip file on my SD card, hboot scans and says no image or wrong image found for all four checks.

    SUMMARY: I cannot flash a custom recovery, so cannot flash a ROM, so no root, and security is still enabled.

    I tried using ADB to flash it manually following this, but I get the following error in cmd prompt
    fastboot flash recovery recovery.img
    sending 'recovery' (4200 KB)... OKAY [ 0.606s]
    writing 'recovery'... INFOsignature checking...
    FAILED (remote: signature verify fail)
    finished. total time: 1.183s

    Some notes that people said to try:
    - I have tried three SD cards that all work in my Droid 1
    - I reformatted all of them to FAT32 to be sure
    - I have tried two windows 7 computers with ADB and unrevoked
    - I do not have HTC sync, but I tried installing it and uninstalling like the guide suggests
    - I have removed all drivers and reinstalled the unrevoked once again
    - I uninstalled Dropbox
    - Debugging is enabled, as is everything else in the first guide
    - I tried many PC36IMG.zip files (clockwork, RA, stock, different versions) (named them .zip, extracted .img, PC31, etc)

    Help would be much appreciated because I am too used to root on my Droid 1!

    Advertisement
  2. sdrawkcab25

    sdrawkcab25 Guides Guide

    Very simple reason it didn't work....Both guides you tried to follow are for the EVO4G, you have an incredible... Or you are posting in the wrong forum.

    Incredible files would be named PB31IMG.zip

    Follow the guide on http://dougpiston.com/?cat=7
  3. Phryxus

    Phryxus New Member

    True, I was following an Incredible guide that sent me there. My bad, not used to dealing with this from my old phone. I followed the guide you provided, but it is the exact same as the Evo guide in terms of using unrevoked (which does not work for me). Thanks though.

    I tried the correct PB31IMG.zip files for the Inc and the same thing happens in hboot. It says loading...all the zip files... checking... then goes away. Like this one for instance, I took the clockwork PB31IMG.zip. I never get prompted to install the zip.

    If I go to recovery, I see a phone with a red triangle on it and the phone is frozen.
  4. sdrawkcab25

    sdrawkcab25 Guides Guide

    If your phone is not recognizing the PB31IMG.zip, then there either is a problem with the sd card or the file you are downloading is corrupt and you need to check the md5 hash for the file.

    What error or screen is it getting stuck at in unrevoked? (waiting for device, waiting for root, etc?)
  5. kidhudi

    kidhudi Well-Known Member

    i am almost embarrassed to ask this. i have a reletively new dinc with the slcd screen. do i have to install the PB31IMG.zip first BEFORE i run unrevoked? i thought unrevoked works on most all dincs right out of the box. thanks for any clarification
    Peace
  6. sdrawkcab25

    sdrawkcab25 Guides Guide

    You should only have to just run unrevoked (after you install the drivers if using windows)
  7. kidhudi

    kidhudi Well-Known Member

    thats what i thought. well the search continues. thanks
    i will gladly supply anyone in the NJ area with an ice cold case of Milwaulkees best beer who can successfully root my Dinc. :)
    just throwing it out there.
  8. sdrawkcab25

    sdrawkcab25 Guides Guide

    I'd reccomend trying on a mac or a linux distro.
  9. Phryxus

    Phryxus New Member

    Hmm.. tried more than 5 files on three SD cards, all reformatted to FAT32..

    Unrevoked fails at "Backup CID is Missing"

    I managed to mostly fix my problem by using the z4root application to give me temporary root, ROM Manager to flash Clockwork recovery (after crashing the phone like three times, it decided to work for some reason), then just flashed a new ROM with root access. No idea why everything failed, still.
    Matlock likes this.
  10. sdrawkcab25

    sdrawkcab25 Guides Guide


    have you tried this fix for that error(cid):
    http://forum.xda-developers.com/showpost.php?p=8729697&postcount=8

    Guess it doesn't matter now that you got it rooted, just curious.
  11. Matlock

    Matlock Well-Known Member

    Great work on getting past the CID error. You did exactly what needed to be done and gave yourself Root. Welcome to the world of Root!!

Share This Page