Question about "Keep WiFi on During Sleep"General


Last Updated: 2012-11-07 15:41:28
  1. SoCalScott

    SoCalScott Member

    If I have my phone set to "Keep WiFi On During Sleep," and I'm out of Wifi range, what happens when the phone goes to sleep? Does the WiFi radio stay on even though it's not connected to WiFi? If that's the case, does it keep the cellular/4G radio off, thereby preventing the phone from downloading email?

    Thanks!

    Advertisement
  2. Szadzik

    Szadzik Well-Known Member

    The moment you get disconnected from WiFi you 3G will come back one.
  3. SoCalScott

    SoCalScott Member

    That's what I thought, but I'm having a weird problem.

    When my phone goes into sleep mode and I'm NOT connected to WiFi, I stop getting emails so I'm assuming that the 3G is going to sleep, too. Is there a setting to change that?

    Thanks!
  4. tdorovski

    tdorovski New Member

    I have exactly the same issue. Even when I have my WiFi stopped, looks like when the phone is sleeping the 3G radio goes off and I stop receiving e-mails.
    Basically in order to receive an e-mail, I have to specifically turn the screen on and manually check my e-mail.
    That is really a big issue I see here. On every other phone I had I would receive my e-mails when they come. Here, not only that the stock app does not support push e-mails, but also now the 3G radio goes off and basically receiving e-mails via mobile data becomes a strictly manual process?

    Is there any why that can be fixed. Maybe installing an app or something.
    All I want is when I have my phone in my pocked, if I receive an e-mail, to get notified. And not needing to check my e-mail manually every 10 mins?

    Thanks very much

    Tsvyatko
  5. Heisenberg123

    Heisenberg123 Well-Known Member

    no there is no setting your phone is not functioning properly if thats what its doing i would try a factory reset
  6. tdorovski

    tdorovski New Member

    Hi. Looks like i might have that resolved. That's for the Jelly Bean e-mail stock app.
    Now, under the e-mail account settings there is the Sync schedule.
    And in there you can select peek and off peek intervals and how often the phone would check the e-mail.
    The last setting there is called [While roaming] and what I though was right I had that set to [manual]. But then, looks like when I set it to [Use above settings] then the phone will check my e-mails over the mobile data.
    Note that I am not on roaming all the time when that is all happening.
    Looks like that setting there for some reason was assuming that I am on roaming and that is why it was not really checking my e-mail. It was not really that the 3G radio goes off.
    So yes, that resolved the problem for me. Again, that's with the Jelly Bean, but I think there was something like that with the older OS as well.

    Regards

    Tsvyatko

Share This Page