Question about "task" barSupport

Last Updated:

  1. cjkeeney

    cjkeeney New Member

    I plan on rooting this phone soon to remove all the awful bloatware that I imagine would free up some RAM, but so far my main complaint with this phone is the task bar. I do not use the stock messaging app and use Handcent or may try out GO SMS (I have been out of the smartphone world for a few months).

    I have disabled notifications on the stock app, but it still shows up on the task bar with unread messages. I also would like it to open handcent if I pressed the messaging app on the task bar. Is there any fix for this if I rooted it?

  2. FulciLives

    FulciLives Well-Known Member

    My phone is rooted (which is very easy-to-do) but I use the stock msg'ing app for texting. I can try downloading handcent (I used it once before on another phone but didn't like it) and see what I can come up with ... BUT ... I'm rather busy now so give me a day or so.

    By the way I tried using Google Voice texting on the phone and that works well (without a double notification) but Google Voice only does SMS ... no MMS ... and if someone sends you MMS to your Google Voice number then you get no notice of it and they get no notice of it not going through.
  3. Nilpotent

    Nilpotent Well-Known Member

    I'm using Go launcher ex and there's an option to hide the status bar. menu > preferences >screen settings > status bar

    I'm not using it because I play a lot with the status bar but it seems to work. Root is not needed in that case. I do not use handcent.
  4. gvc

    gvc Well-Known Member

    I think there is an area under "manage applications" that you can set a default app for messaging. Look under "all" and go to messaging and scroll down to see if there's a button to "clear defaults". if there is, try that, then touch the messaging app icon to see if then asks you which messaging app you want to use and a box to checkmark if you want to set it as "default".

    I dont use multiple messaging apps but I do use more than one browser and If I touch the web globe icon a box comes up asking which browser I want to use and also a checkmark box to input the selected browser as my default.
  5. FulciLives

    FulciLives Well-Known Member

    Well I installed "Handcent SMS" and after doing so this is what I did ... I went to my contact list and selected a friend and selected to text them. It gave me options as to how I wanted to do that. The options included the standard built-in text msg app, Handcent SMS, Google Voice and Skype. There is an option to make your choice the default. So I clicked that default box and then selected Handcent SMS.

    It then took me to Handcent SMS and I sent a short text to my friend.

    When he sent a text back the notification bar showed the Handcent SMS icon as well as the standard text msg app icon.

    Not good.

    I then went back to my contacts and tried to send another text and again I was presented with the list of apps to use even though I had already picked Handcent SMS as my default. Weird huh?

    But then I went to the Handcent website:

    Handcent sms HomePage --sms plus software for android

    Along the left side are some options. One is FAQ and when you click on that you see a bunch of questions. One of the questions is, "How to make handcent sms to my default sms software?"

    Click on that and it gives directions on how to turn off notifications from the standard msg app and then how to turn on notifications for Handcent. The result? The standard msg app will no longer give a taskbar notification when you receive a text.

    It works!

    However I've noticed two issues.

    1.) In Handcent you can select an avatar picture but my friend (who I texted) is using an iPhone and the standard text app on it and he didn't see the avatar picture. I'm guessing in order to see it he would also have to be using Handcent?

    2.) The "dock" or whatever it is called (at the bottom) that shows:
    Well where it says MESSAGING (with an icon of what looks like an open envelope) it shows a "1" meaning I have 1 unread text msg and this was AFTER reading the text with Handcent. Apparently this icon is a link of sorts to the built-in standard msg text app. Is there way to remove it and replace it with Handcent? In short have no idea how (or if we can) edit that "dock" stuff.
  6. FulciLives

    FulciLives Well-Known Member

    I installed "ADW.Launcher" which allowed me to change my dock along the bottom. In this way I was able to put Handcent SMS there instead of the default msg text app icon.

    Now I only get the Handcent notifications :)

  7. ZenPit

    ZenPit Well-Known Member

    If you want to hide notifications from your stock messaging app go like this:

    --Turn off delivery reports if on
    --Turn off Notifications (at the very bottom)

    Now if you want to completely hide the messaging (stock SMS app) you need to either get Go Launcher, or some other Theme customization app. It generally puts what ever you have set as your default messenger app in the dock tray. If it doesn't you can select it (press and hold over the icon) and select change shortcut.

    I use LauncherPro so the wording in the dock tray may be different, but it should work the same. I know I was able to do that on MT3G when I had it a couple years back.
  8. lethalgorman

    lethalgorman Member

    you can change the tray icons easy. 1,applications 2,menu 3,edit 4, drag and drop what you want to the tray and the old icon goes away.

Share This Page