1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

question on desire HD internet pass-throughSupport


  1. robertlau

    robertlau Member

    tried to connet the phone to internet using its so called "internet pass through" function, but never be successful......:confused:

    has installed the latest HTCV sync, turned off all firewall, and found HTC device in the device manager, but still cannot do it..

    on the phone, it showed that "you either do not install the latest sync or another phone is connect to your PC". How can this happen???:mad:

    anyone who has the same problem as mine?

    Thanks a zillion....

    Advertisement
    :
  2. mintynufc

    mintynufc New Member

    yes im having same problem phone will not sync to pc keeps saying cant connect to the port on my phone as well.
  3. robertlau

    robertlau Member

    serious help needed here...
    SOS....:eek:
  4. Betyama

    Betyama Member

    Are you using USB 1.1 or 2.0, on my work PC I have 2.0 and it works but on my home PC I have 1.1 and it doesn't.
  5. AndroidFreud

    AndroidFreud Member

    Hi robertlau & mintynufc,

    I've been using the DHD for about 3 weeks now and the internet pass-through mode works flawlessly.

    Am unclear from your input if the following has been done but I will cover it just in case.

    First time setting up Internet Pass Through:

    1. Ensure that you have a working net connection on your PC (this can be wireless/LAN/ wired - whatever - as long as the net's working.
    2. Before connecting the USB cable, Go to Menu>Settings>ConnectToPC and make sure the 'Ask me' section (on what type of USB connection to establish is ticked. FYI, my 'Default connection type' is set to 'charge only'
    3. This will ensure that everytime you plug in your USB cable to your PC a pop-up should show up on your DHD asking what type of connection to make. Connect your cable and in the popup - Choose the very last one - 'Internet Pass Through' mode. (I am connecting via a USB 2.0 connection - not sure if this matters)
    4. A popup regarding 'Connection Troubleshooting' shows up - click OK.
    5. You should get a little icon that displays that the connection has been established in Internet Pass-through mode in your notification bar.
    6. I also do have USB debugging turned on (not sure if this makes any difference but in mine it's on. This is found under Menu>Settings>Applications>Development>
    7. You can also verify that your phone has established an Int. Pass-Thro mode by going to Menu>Settings>Wireless&Networks> and scrolling all the way to the bottom should show the Internet PAss-Through option now checked (It would have been grayed out when the USB cable was not connected.
    8. In the event that plugging in the USB cable still does NOT give you a pop-up asking you to establish the connection type, despite the fact that you have the 'Ask Me' option on connection type turned on - then hold down the power button for a few seconds and choose to 'Close all Apps & Restart Phone' with the USB cable unplugged and then replug - this should fix the problem.
    9. Sometimes when connecting ESET Smart Security (my firewall) asks me what type of connection to establish - 'Strict Protection' or 'Allow Sharing' - I click Strict Protection and it still works. In case you have a different firewal - make sure you allow it to connect (this depends on the kind of software you are using so can't tell you exactly which option to choose here- but try first with security and see what happens - else keep it open or disabled (not recommended).

    I would highly recommend you get this and the Wi-fi mode definitely sorted out cos it will save you big time on costs by not just using your expensive/limited mobile internet connection (not to mention the speed is also blazingly faster - at least where I am

    A few other tips - have '3G Watchdog' installed from the AppMarket - this gives you a data counter to keep track of how much data is being transferred through the mobile net connection (since many carriers in India cheaply don't give you a usage statistic until your bill arrives (like Airtel does). This will help you keep a track - as you can set a counter and a data limit as per your plan and the start of the bill cycle date - so it will warn you when you're coming close to the limit.

    As a good habit, I'd also recommend to have the latest version of HTC Sync also installed - when doing Syncs simply choose the HTC Sync option instead in the pop up when the USB connection is established.

    Also while disconnecting - I might just be very cautious - but I do do the old school method of "safely removing hardware' when the phone is connected in sync or hard disk mode. Same applies especially for the SD card inside the phone - you need to unmount it from within the phone and then physically remove it....

    ....ok I think I went way off topic and am rambling now....
    Hope this helps somewhat and I hope it covers your question.
    anandv76 likes this.
  6. robertlau

    robertlau Member

    Hi AndroidFreud,

    Really appreciate your effort here.....

    But I have done all that you have mentioned, get the latest HTC sync, USB debug on, firewall off, USB 2.0, choose internet pass through upon USB plugged in........

    The damn phone just won't connect to internet anyway....
    If i go tothe "wireless control" page, the internet passthrough is just showing ""turning on" for about 5 min, and then show error message on the phone: "you either do not install the latest sync or another phone is connect to your PC", which totally does not make sense anyway..
  7. georgeeasten

    georgeeasten Member

    3G Watchdog drained my battery so I would be mindfull installing this if you're having battery issues like so many of us are.

    I was wondering if you had the modem connected directly to you PC. Also, if you have a wired network or another device plugged in there may be a conflict.
  8. Cosmi

    Cosmi New Member

    Make sure you connect the USB Cable in motherboard (in the back of PC)... not in third party USB slots...
  9. xXPing_PongXx

    xXPing_PongXx New Member

    I had this same issue and what I did was Uninstall and Reinstall HTC Sync. After that, every time I plugged in my phone to my PC internet pass-through worked perfectly. Thanks for your help on this.


    HTC Inspire 4G, Android 2.3
  10. saurab

    saurab New Member

    Connect the usb cable normally.
    if the popup does not shows up to change the connection type although it is set to 'Ask Me' in settings, to solve, enable the USB debugging once, and then you can disable. It works for sure.
  11. h3lman

    h3lman New Member

    This is my first post on this forum but I have found you all to be very helpful with many of the challenges that I have faced and I thank you for that. Now to USB pass through

    Ensuring that the usb cable was plugged into the ports on my Lenovo laptop ensured that I could once again access the USB pass through BUT the curious thing I found was that disabling the Symantec End Point Protection "Network Threat detection" component achieved a restored service when using the USB ports on my docking station. How symantec interacts with this is beyond me as I could not find a setting in SEP relating to USB ports.
  12. mehdikoochek

    mehdikoochek New Member

    There is a service "Internet Pass-Through Service" which should be started on your PC.
Loading...

Share This Page