Question on using Clockworkmod


Last Updated:

  1. d.scardino

    d.scardino Well-Known Member This Topic's Starter

    Joined:
    Apr 7, 2010
    Messages:
    78
    Likes Received:
    27
    Quick question when using Clockworkmod. It installed correctly using the downloaded exe. Program ran through to done. I boot up as normally into recovery leaving me at the Clockworkmod Recovery screen. From there, I open cmd and try to remove my various apps but i get errors.

    What I enter:
    adb shell
    su
    /system/bin/rm /system/app/com.htc.FriendStreamWidget.apk

    What I get:
    /system/bin/rm /system/app/com.htc.FriendStreamWidget.apk
    /sbin/sh: /system/bin/rm: not found

    Any words of wisdom please?
     

    Advertisement
  2. jwm2

    jwm2 Well-Known Member

    Joined:
    Mar 30, 2010
    Messages:
    1,109
    Likes Received:
    270
    You may have to enter the terminal from within the phone and enter in those commands. I don't know yet what methods are working and whats not. Obviously the method you tried is not working, but someone else said they opened a terminal app and used a command to remove an app and it worked.
     
  3. Blotto

    Blotto Member

    Joined:
    Apr 28, 2010
    Messages:
    11
    Likes Received:
    3
    You need to mount /system within Clockwork.
     
    clickster likes this.
  4. d.scardino

    d.scardino Well-Known Member This Topic's Starter

    Joined:
    Apr 7, 2010
    Messages:
    78
    Likes Received:
    27
    ok what is typed and when?
    thanks
     
  5. jwm2

    jwm2 Well-Known Member

    Joined:
    Mar 30, 2010
    Messages:
    1,109
    Likes Received:
    270
    power off
    plug in usb cable
    hold volume down+power
    volume down once to select recovery and then hit power
    now you should be at the clockworkmod recovery menu
    select "partitions menu"
    select "mount /system"

    on your computer, click start, run, and then type "cmd" and hit enter to get a dos prompt

    go to the sdk\tools directory and type adb shell

    Then make sure to type su to get superuser permission before typing in the commands to remove the apps you want to remove.
     
    clickster and d.scardino like this.
  6. crimton

    crimton Well-Known Member

    Joined:
    Apr 1, 2010
    Messages:
    1,055
    Likes Received:
    180
    /* City ID */
    /system/bin/rm /system/app/CityID.apk

    /* Friend Stream & Widget */
    /system/bin/rm /system/app/com.htc.FriendSteamWidget.apk
    /system/bin/rm /system/app/FriendStream.apk

    /* HTC Facebook */ <------------*****REPORTED TO CAUSE FC's if removed******
    /system/bin/rm /system/app/HtcFacebook.apk

    /* HTC Twitter & Widget*/
    /system/bin/rm /system/app/HtcTwitter.apk
    /system/bin/rm /system/app/com.htc.TwitterWidget.apk

    /* Teeter */
    /system/bin/rm /system/app/teeter.apk

    /* Stock Facebook */
    /system/bin/rm /system/app/Facebook.apk

    /* Verizon Visual Voice Mail */
    /system/bin/rm /system/app/VVM.apk


    /* HTC Footprints and widget */
    /system/bin/rm /system/app/HtcFootprintsWidget.apk
    /system/bin/rm /system/app/HtcFootprints.apk

    once system is mounted you can enter any of these commands to remove apps
     
    clickster and d.scardino like this.
  7. crimton

    crimton Well-Known Member

    Joined:
    Apr 1, 2010
    Messages:
    1,055
    Likes Received:
    180
    hmm, i never put in su and it still removed it.
     
  8. d.scardino

    d.scardino Well-Known Member This Topic's Starter

    Joined:
    Apr 7, 2010
    Messages:
    78
    Likes Received:
    27
    worked great, thanks so much!
     
  9. jwm2

    jwm2 Well-Known Member

    Joined:
    Mar 30, 2010
    Messages:
    1,109
    Likes Received:
    270
    Oh ok, thats good to know. SU is probably only needed once the os is loaded.
     
  10. mgraham

    mgraham Active Member

    Joined:
    May 6, 2010
    Messages:
    37
    Likes Received:
    3
    Yep, you're right. When you run adb shell you are root so typing su is redundant (doesn't hurt though). If you want to check to see what user you are, type:

    id

    When the OS is booted, you are not root so running su would switch to the root user.
     
  11. hexto

    hexto Guest

    Thanks. That was easy
     
  12. killadanny

    killadanny Well-Known Member

    Joined:
    Apr 26, 2010
    Messages:
    847
    Likes Received:
    102
    ^ Very easy! removed city id!
     
  13. mickym5

    mickym5 Well-Known Member

    Joined:
    Mar 16, 2010
    Messages:
    90
    Likes Received:
    1
    all other commands to remove bloatware work great. what commands remove stocks, google talk, and footprints? also will removing footprints cause an infinate auto sync loop like removing the friendstream app did?
     
  14. coolbone

    coolbone Well-Known Member

    Joined:
    Mar 21, 2010
    Messages:
    198
    Likes Received:
    85
    if you type: ls
    you can see the names of all the .apk files. then use the same idea but replace the names as before.
     
  15. scott51

    scott51 Member

    Joined:
    May 7, 2010
    Messages:
    7
    Likes Received:
    0

    I couldn't get this one to work
    " /system/bin/rm /system/app/com.htc.FriendSteamWidget.apk"

    After many tries i seen the error,"FriendSteamWidget" Forgot the "r":eek: FriendSteam Lol
    On a side note though,your little list there was a huge huge help and i thank you!
     
  16. iowabowtech

    iowabowtech root@android:/ #

    Joined:
    May 2, 2010
    Messages:
    12,067
    Likes Received:
    8,534
    Yeah, I just removed CityID and it said "permission denied" yet after reboot, it was gone. Didn't enter SU. Not sure if that's normal or not but gone = good. :D
     
  17. Hand76

    Hand76 Guest

    disregard I think I got it.
     
  18. Marlboro

    Marlboro Active Member

    Joined:
    May 8, 2010
    Messages:
    42
    Likes Received:
    3
  19. welbinator

    welbinator Well-Known Member

    Joined:
    Jul 1, 2010
    Messages:
    581
    Likes Received:
    44
    whats the big deal with CityID? why does everyone seem so adiment about removing it? its never caused me any problems.
     
  20. Skaw

    Skaw New Member

    Joined:
    Apr 10, 2010
    Messages:
    1
    Likes Received:
    0
    I've been trying to remove bloat all morning and i cant get cmd to work with me, after i go to recovery cmd tells me "device offline" ive tried other metheds, im getting frutrated. i am on the offical 2.2 s/w. and i really hate these apps. i read one thing it said after selecting recovery and hitting power to select partitions menu, then select mount /system. I've never Seen this as an option. i am new to this rooting thing. any one got advice
     
  21. iowabowtech

    iowabowtech root@android:/ #

    Joined:
    May 2, 2010
    Messages:
    12,067
    Likes Received:
    8,534
    Howto: Root the HTC Droid Incredible - Technology - Jonamerica.com

    Good description of the tools and processes needed in this link. Depending on what version of Clockwork you have, if you're running CW, I think they changed the menu awhile back. Check through all the menu options.

    Most of us move unwanted apps to a disabled folder as it shows in the above tutorial. However, if you there are a few apps you are SURE you want to get rid of, you can delete them with Titanium when rooted. Be careful and you may wish to make a Nand backup right before you start debloating just in case you need to go back.
     

Share This Page

Loading...