QUESTION...Should I....?


  1. pacothebandit

    pacothebandit Well-Known Member

    Hey Guys PACO here, after watching this amazing video on how to root your phone and apply the JF 1.5 ADP I am really tempted to do it. As of now I have a stock G1 but really really want to do this update. soo what do you think, should I wait till the OTA release orrrr should I just do it now. What are the pro and cons, I know I can roll it back and did it before on my last G1. SO what do you think.

    Advertisement
    :
  2. justjimjpc

    justjimjpc Premium Member VIP Member

    I dont think you will be unhappy ... and if you try also Moving apps to SD ... the Build in my Signature is the Build to get ...

    If you want to return to RC29 and then manually update to the OTA version you will have that option...
  3. pacothebandit

    pacothebandit Well-Known Member

    Soo what your saying is....I can just swap back just like that. well then...I think I know what I'm doing today...
  4. dynodroid

    dynodroid Well-Known Member

    Do it or else!!
  5. justjimjpc

    justjimjpc Premium Member VIP Member

    If you want to UN-Root .. You have to flash with the Same file that took you back to Pre-Blocked Root-Acces ... then work you way back up to the most recent Legit TMO build ...

    I am not sure ... but in Settings you MAY/Should be able to do a Check for Updates ... and go from there via OTA ...

    I have not done this yet ... So if you do ... Please return and let me know your findings .. and how things went ... then I will add this as a FAQ to the forums ...
  6. pacothebandit

    pacothebandit Well-Known Member


    Yah I tried it on the last G1 I had, there is no "Check for updates" in that build, So I guess I would have to find a legit RC33 and manually update it...if thats even possible. Otherewise wait for it to come OTA
  7. justjimjpc

    justjimjpc Premium Member VIP Member


    ==============================================================
    THIS GUIDE ASSUMES YOU ARE STARTING FROM A WORKING ROOTED VERSION
    ==============================================================


    EDIT: Here are the files you will need To Go From : Root to Legit RC33 build 1.1

    GUIDE : >>> Follow the procedures on this forum : http://androidforums.com/updates-cupcakes/5006-g1-t-mobile-total-newbie-help.html#post32119

    Used the following files instead and in this order :

    RC29 IMG pre-Root : http://www.getyourdroidon.com/root/DREAIMG-RC29.zip
    --- Use Steps 1, 2 & 3 --> in the Guide above .. (corrected 5/22/09 had wrong Step #)

    RC30 Legit Build : http://android-roms.googlecode.com/files/signed-RC30-from-RC29-fat.1582cace.zip
    --- Use Step 4 in the Guide above ..

    RC33 Current Build 1.1: http://android-roms.googlecode.com/files/signed-PLAT-RC33-from-RC30.zip
    --- Use Step 4 in the Guide above .

    RADIOS for RC33 : http://android-roms.googlecode.com/files/Radio_Dream_RC33_1_22_14_11.zip
    --- Use Step 5 in the Guide above .

    Factory Bootloader : http://www.getyourdroidon.com/root/G1OrigBootloader_nocheck.zip
    --- Use Step 3 in the Guide above .

    +++++ ========================== +++++++
    Quick LIST
    +++++ ========================== +++++++
    OTA / Un-Root Files
    - DREAIMG-RC29
    - OTA RC30
    - OTA RC33
    - RC33 Radio
    - Original G1 Bootloader
    - Justjimjpc Un-Root Guide

    .
  8. justjimjpc

    justjimjpc Premium Member VIP Member

  9. Crackbone

    Crackbone Well-Known Member

    I just rooted last night, and I have to say, not only did I find the process extremely easy, I'll never go back again.

    Too much freedom, too many possibilities.

    IMO, there's simply no reason not to root.
  10. pacothebandit

    pacothebandit Well-Known Member


    Question for you. All your doing is putting the files on your fat32 sd card and naming them "update" right...? same as if you want to update to a newer JF version or whatever your just going backwards...im just curious.
  11. dynodroid

    dynodroid Well-Known Member

    Pretty much.
  12. Swathi

    Swathi New Member

    I have tried with the following code ,but i got an error message"NO applications can perform this action".

    Intent sendIntent = new Intent(Intent.ACTION_SEND);
    sendIntent.putExtra(Intent.EXTRA_EMAIL, mailto);
    sendIntent.putExtra(Intent.EXTRA_SUBJECT,
    subject.getText().toString());
    sendIntent.putExtra(Intent.EXTRA_TEXT,
    body.getText().toString());
    sendIntent.setType("text/plain");

    startActivity(Intent.createChooser(sendIntent, "MySendMail"));

    Can anybody tell me, the solution for this ?

    I have tried to send an email using SMTP server (Gmail), but i got an error
    "java.lang.verifyError:javax.mail.internet.Mimemessage."
  13. pacothebandit

    pacothebandit Well-Known Member

    Man that is way over my head, what are you trying to do?
  14. MichaelSF

    MichaelSF Member

    Any chance of clarifying all this.

    I go to the link you post for Root 2 Legit (which I assume means what I want to do) and it takes me to how to root and install cupcake (which I do not want to do). I installed cupcake and need to get back to T-Mo U.S. legit.

    I installed RC29, 1.0 firmware, but getting to step 2 is confusing because the link appears to be talking about installing cupcake.

    http://androidforums.com/updates-cupcakes/5006-g1-t-mobile-total-newbie-help.html#post32119


    All the posts on the net say "how to upgrade and downgrade."

    I need to downgrade. Is there any thread that says how to ONLY downgrade.

    I have the files that were posted and downgraded with the Dream file, so now I show build TC4-RC29 115247 installed.

    So now what. :(

    UPDATE: I think I see how it's done.

    I simply renamed and numbered each of the OS updates and installed them in order.

    E.g. gave each file a distinct name. "01 Original OS", "O2 next update" and so one.

    Transferred all files to my G1 microSd chip.

    Then one by one renamed each to be installed, to "update.zip"

    Installed each "update.zip" file, starting with file I named "01"

    Rebooted after install.

    Then deleted file just installed, the one named "update.zip"

    Renamed the next one in order, "02" for example, to "update.zip"

    Then installed that.

    Did this for all four files you provided.

    I confirmed after each install that the OS had in fact been updated. It went from 1.0 to 1.1 (or builds 29, 30, 33)

    Just now I installed the RC30 to RC33. "About" shows successful install to RC33.

    WOOT....

    Also, I now have the T-Mo menu item that says "System updates."

    I assume that now I can wait for the OTA cupcake from T-Mo.

    Thanks for the help!

    Sidenote: was I able to do these updates because I rooted my phone, used TelNet, etc.? IN other words, can one do these updates and downgrades if they had not rooted their G1?
  15. pacothebandit

    pacothebandit Well-Known Member

    If your going from a non-root phone you cannot just simply throw these onto your phone and update them and have cupcake. You have to take advantage of the root hole in RC29 by using the telnet. as far as YOUR phone goes I am curious to see if you can just update to cupcake again now that you have already gone through all that.
  16. MichaelSF

    MichaelSF Member


    That's a good question. Is my phone permanently rooted or do I have to go back to installing the original OS (RC29), do the TelNet thing, and after that install cupcake?

    Or when I returned to the latest pre-cupcake OS (RC33, 1.1) did that close the security hole that was in RC29. If it's closed, do I have to downgrade to RC29 to reopen the security hole?

    I guess I could try to install cupcake directly from the MicroSD chip and see what happens.

    But as you may suspect, I am not willing to risk I might brick the phone, especially since the reason I went back to the original 1.1 firmware OS was to be able to receive the T-MO OTA cupcake update.

    Sidenote: For those who might wonder, reasons I got rid of cupcake was because it showed that I was with Vodafone and the default location was in the UK. For example, when I opened GPS mapping software it opened to the European map and not the U. S. map.

    So while none of that affected the phone and features, I did not like seeing that "Vodafone Magic" in the <Settings> <About phone> <Model Number> box.

    Another thing is that in the version of cupcake I downloaded it had a different interface and icons. E.g., while I had the camcorder feature, I did not have a camcorder icon. I did not like that. A niggle, I know, but I wanted that icon in my menu. :rolleyes:
  17. bfdarren

    bfdarren Member

    When I try and downgrade my phone, it fails verification. I cannot find a otacerts.zip file on my phone, what can I do to get it back, get a new one, or ignore the verification so that I can un-root my phone? Thanks, Darren
  18. justjimjpc

    justjimjpc Premium Member VIP Member

    UN-Root with the link in my signature .... pay attention to whether your are US or UK and select the correct Builds and Radios ...
  19. bfdarren

    bfdarren Member

    Your link ends up back at this thread. I have tried to follow this thread several times, but each time I alt+s to install the RC29 update, it fails because it cannot verify the update. I have read elsewhere that it is because the otacers.zip file is incorrect/missing. Am I missing something in your guide that should help me get past the verification step?
  20. justjimjpc

    justjimjpc Premium Member VIP Member

    Except for the .nbh file in STEP 1. .. the other downloaded zip files must be named update, update.zip make sure (depending on your OS) that you dont end up naming it update.zip.zip, on XP desktop the files would just show the base file name like (JFv1.42_RC33) just change it to Update ... if you right mouse the file and check the properties you will see the file is still a zip file ....this is what you want ... the file can then be copied to the phone into the /sdcard directory ...
  21. buzzdroid

    buzzdroid Active Member

    Quick question about unroot. When I get tto the bootloader step, is it necessary to do this to get ota updates? or is it just nesecary for the whole process to work smoothly?. Is it ok to leave the bootloader as the eng boot loader or does it realy matter
  22. justjimjpc

    justjimjpc Premium Member VIP Member

    If you are following the guide in my signature .... then you need to all the steps in order to return phone to standard ... so the OTA will work as if the rooting had never been done.
  23. bfdarren

    bfdarren Member

    Thank you for all the help, but I am still having problems.

    I followed the instructions without a problem in the G1 t-mobile total newbie HELP link up to step 4 without a problem.

    I installed the engineer boot loader per your recommendation.

    Once I get to step 4, I download RC29 IMG Pre-root (45.2MB file that I have downloaded a couple of different times to make sure that it is not corrupt).

    When I follow the instructions for step 4, this is what I see:

    Android system recovery utility
    Using test keys

    E:Can't open /cache/recovery/command

    Home+Back - reboot system now
    Alt+L - toggle log text display
    Alt+S - apply sdcard:update.zip
    Alt+W - wipe data/factory reset

    Installing from sdcard...
    Finding update package...
    Opening update package...
    Verifying update package...

    E:No signature (1 files)
    E:Verification failed Installation aborted.

    Press Home+Back to reboot

    I have verified that I followed the instructions as outlined. I have verified that there is only a single extension (I run windows XP with "hide known extensions" turned off).
  24. justjimjpc

    justjimjpc Premium Member VIP Member


    SO IF YOU DID INSTALL the RC29 IMAGE in Step 4 as you stated above you have mixed up the files and steps... and things should be going wrong ...

    Please place the link you are talking about .. because the RC29 45MB zipped file is the 89GB DREAIMG.nbh And the one zip that you do need to extract .. and that file is USED in STEP 2 not in step 1 ... because this is the IMAGE file that has the root security hole.


    Step 1 the RC29 IMAGE (has root security hole) ....

    Step 2 Is for RECOVERY, TEST KEYS and SU service the actual root service...

    Step 3 Is to install The Boot-Loader so that additional Modified-Builds can be added ...

    Step 4 is where you would be installing the latest/Final build like RC33 (~42GB) or Possibly the ADP 1.5, Or Haykuro 1.5, etc ...

    SO if you WILL POST the file links you used for each step ... then that will let us verify that you have them in the proper sequence NOW !!!

    PS: DONT Forget STEP 5 ... which is the Radios for the Build you are using as you final Install version ...

    .
  25. bfdarren

    bfdarren Member

    Since I am trying to go from root to legit, I have been following the post from above. After following the instructions for steps 1 to 3, I was using the instructions with links as quoted below. It specifically states to use the RC29 IMG Pre-Root in step 4. If this is not correct, then I will try again and skip the RC29 IMG Pre-Root step.

Loading...

Share This Page