Questions using an OTG Adapter/connecting issuesSupport


  1. rottonj

    rottonj Well-Known Member

    I don't have this phone yet but a question for those that do. if using a OTG adapter with a thumb drive attached is there a way to save the file from the drive to the phone or do you have to just keep it attached the whole time. Considering this as an alternative to hold HD movies on a drive and putting on the phone when needed. Thanks

    Advertisement
  2. danski

    danski Well-Known Member

    I don't have an answer on that, but thought I should mention that I've been messing with an otg cable with my one x and it won't work if I format the pen drive in ntfs or exfat, has to be just fat system.
    Reason I thought you may want to know that is if you're thinking of getting a big drive for big movie files...I just got a 64gb and it won't format as just fat, only gives me the option of exfat and ntfs and also, the biggest file size you can transfer onto fat is 4gb
    rottonj and KOLIO like this.
  3. rottonj

    rottonj Well-Known Member


    Good to know, thank you. I have a 64gb card , maybe I can format that to fat and use it in a card reader attached to the cable. I will look into that option before purchasing a thumb drive. This phone not having a sd card is one of the things keeping me from jumping on this phone. 32gb may be more then enough for some, but it probably wont be for me with my music and movies.
  4. clsA

    clsA Guides Guide

    I have a Lexar USB 3.0 64 gig drive that works fine.
    I don't remember doing anything to it, just loaded a bunch of videos and music and it plays on the phone just fine.
  5. rottonj

    rottonj Well-Known Member


    Can you save them to the phone from the drive?
  6. clsA

    clsA Guides Guide

    sure, you can copy anything from the drive to the phone and vice versa
    toad6386, KOLIO and rottonj like this.
  7. marctronixx

    marctronixx Moderator Moderator

    i currently have an OTG adapter and i have successfully attached my 64gb sandisk to transfer files back and forth with no issues on the ONE. This phone supports OTG so you can also connect mice, keyboards to the phone as well.

    Attached Files:

    • otg.jpg
      otg.jpg
      File size:
      61.5 KB
      Views:
      44
  8. danski

    danski Well-Known Member

    Cool, as I say, I was speaking of my experiance with a 1X, so hopefully theres something in the One that makes it ok, as my 64 GB pen is a Lexor too...good to know that it probably wont be a wasted purchase after all :)
  9. Rhyan

    Rhyan Well-Known Member

    If anyone is interested, there's this project on Kickstarter, which looks like a pretty neat potential product that's reached its original goal many times over.

    I believe it's meant to work on the One.

    Rhyan
  10. marctronixx

    marctronixx Moderator Moderator

    That's been posted in the accessories thread but it should be mentioned here as well.

    I've put a bid in weeks ago before I even received the one and it has been confirmed to work with the One.
  11. donaldvf

    donaldvf New Member

    I am using an HTC one Android v.4.2.2 and trying to tether a Nikon D90 to use with DSLR Dashboard. I can use a mouse and connect a USB thumb drive via USB/OTG adaptor but when I connect the D90 get a "USB device not supported" message. I read that I may need to install install an 'alternative Android ROM (firmware) without USB limitations'. Not sure of that. Anyone having any expperience with tethering a Nikon camera with the HTC one or any ideas would be appreciated.

    Don
  12. marctronixx

    marctronixx Moderator Moderator

    always a 3rd party rom will give you more control than stock.

    what options do you have on your camera in terms of storage? MASS storage? LUN?

    what adapter are you using?

    I have a sony a99 and ill connect it up to the phone and report back...

    I see the dev has an amazing support forum. have you contacted the dev about his app and if the htc is compatible?

    https://code.google.com/p/dslrdashboard/


    here: https://code.google.com/p/dslrdashboard/issues/detail?id=52 <<-- post your question there and get direct suport as the op on this ticket has the same issue
    donaldvf and KOLIO like this.
  13. Don164

    Don164 New Member

    I have a HTC One which is running Android 4.2 Jelly Bean. I was recently made aware of the USB OTG feature on Android phones and I was pleasantly surprised ! After purchasing a cable for a
  14. Harry2

    Harry2 Well-Known Member

  15. RobGee89

    RobGee89 Active Member

    Hey guys I just my otg cable and my 16gb cruzer works but my 4gb sd card and 32gb sd card formatted to fat32 and i tried formatting it to exfat and it still don't work, any ideas how to make them work,
    when i connect the sc card and otg lead and click mount usb storage its says usb storage safe to remove???
  16. sharksfan7

    sharksfan7 Well-Known Member

    Is there a faster way to unmount USB storage than going through Settings>Storage>Unmount? Tried to find a way to add a shortcut but doesn't seem option is available. Would prefer if there was something in the notification panel or a Quick Settings tile I could just tap to unmount. Anyone know of an Xposed mod or something that can add this?
  17. marctronixx

    marctronixx Moderator Moderator

    If you are stock and not rooted there is no hidden shortcut to do this. You need to go through those steps.

    If you are rooted there may be other options. Post up in the rooting section of t
    Your particular device for help.
  18. SteveCurrie

    SteveCurrie New Member

    I bought a OTG-usb cable to allow me to transfer files to and from my One. It worked fine to begin with but now the USB Unavailable is permenantly grayed out even when i connect the cable with thumbdrive attached (ie same as I did the first ,and successful, time)

    Any suggestions??
  19. marctronixx

    marctronixx Moderator Moderator

  20. tommo47

    tommo47 Well-Known Member

    Hi Steve, welcome to Android Forums.

    I have used my OTG/flash drive extensively both before and after the 4.4.2 update and have never experienced any problems with the mount/unmount procedure, ie the device will always read the drive and report memory used/memory available, although as marctronixx mentions some apps will no longer read from/write to the drive.

    A couple of things if you haven't already tried :-

    1. Is your thumb drive still recognised by your PC/Laptop ?

    2. Have you got or can you borrow an alternative flash drive to try ?
  21. SteveCurrie

    SteveCurrie New Member

    Firstly tks for the reply Marc...

    Second I am a techno-numpty....I assume KitKat is Android 4.4 which is whats on my phone...when was this updated cos I was able to transfer files on Friday, but not from Saturday onwards.

    When i connected my OTG cable it said something like 'OK to dismount'...then it would 'find' the SD card reader and display the space left and I could see the files (using ES File Explorer) and move the image files across.

    Now I dont get any message at all and the two options under USB Storage in the Settings menu ('Unavailable' and 'Mount USB Storage' )are grayed out.

    Tommo

    Answers are Yes and Yes

    See my previous reply to marc for more info....tks for the help


    Some more info.....

    When I connect my OTG cable I get a message 'Phone is in USB host mode'....dont know whether this helps identify what is giving me problems but more info just in case
    lavoncr likes this.
  22. tommo47

    tommo47 Well-Known Member

    If you google 'HTC One USB host mode' there does seem to be an issue with some devices. Symptoms include failure to charge with mains charger and failure to connect to PC/Laptop via usb.

    The following was apparently a fix for the charging issue but it isn't clear as to whether it fixed the Host mode issue completely.
    USB Host mode and won't charge.


    This just happened to me, and after some searching here and elsewhere I found that it seems to be an unsettlingly common issue. What was worse is the only solutions anyone had was RMA/replacement. Well, I called HTC customer service and the woman I spoke to was very helpful

    She told me that the charging mode may need to be reset and gave the following instructions.

    1. Turn phone OFF
    2. Let charge for AT LEAST 10mins even if it doesn't look like it's charging (mine DID show the new charging animation)
    3. Press and hold POWER + VOL UP + VOL DOWN for AT LEAST 2mins. Anything less will not reset the charge mode.
    4. After 2mins release the buttons and the phone should boot as normal.

    My phone is now charging normally.
    Others seem to point a finger to 'dirt in usb port/connector'.

    It may be worth giving HTC Support a call.

    :confused:
    SteveCurrie likes this.
  23. SteveCurrie

    SteveCurrie New Member

    I also found this thread and although I was having no issues with charging (either thru the usb-PC or mains) I thought I would give it a try.

    It made no difference to the OTG-USB issue I'm having.

    I have another OTG cable coming in case the one I have is duff.
  24. SnappiestGnome

    SnappiestGnome New Member

    I'm not good at these, so I'll just write this out in bullet points.

    -I bought an OTG cable

    *Whenever I plug OTG Cable into HTC One it comes up with notification saying phone is in host mode.*

    -I used my wired mouse on my HTC One for a solid 20 minutes.

    - Next day I go to use wired mouse on HTC One, doesn't work.

    - I try using wireless mouse on HTC One. Doesn't work.

    - I then use both mouses on on my laptop. They both work fine.

    -Questioning if it's the OTG cables fault I use both mouses on my nexus tablet. They both connect and work fine.

    It's not the OTG Cable, the wired mouse, or the wireless mouse that is causing the issue.

    I don't know why it's not working and I would really like if someone were to help me!:(
  25. clsA

    clsA Guides Guide


    pretty strange it worked once and then didn't .. have you rebooted the phone since last disconnecting it ?

Share This Page