1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[R910/R915] THE ODIN THREAD: Return to stock | Now with R915 files!


  1. Shabbypenguin

    Shabbypenguin Well-Known Member Developer


    How to return your Samsung Galaxy Indulge to stock


    DO NOT CHECK REPARTITION UNLESS k0nane OR I SAY TO

    Why the big red warning? Far too many people have broken their devices by not following these instructions! Search the forums, or drop by IRC - you'll see plenty of examples.

    These instructions should fix your semi-bricked or broken phone as long as you can get it into download mode. Make sure you have drivers already installed on your Windows computer before starting. Please read them all the way through and then begin.

    Things you will need to restore your phone are below.
    BY PERFORMING THESE STEPS ALL DATA ON YOUR PHONE WILL BE WIPED AND IT WILL BE RESTORED TO FACTORY STATE. I ASSUME NO RESPONSIBILITY IF THIS DAMAGES YOUR PHONE OR DOESN'T FIX IT. DO AT YOUR OWN RISK
    Download and use this version of Odin 1.61:
    ODIN

    Tar files needed to flash are in post #3

    Set up the software:
    Extract the odin-pit.zip
    Run Odin3+v1.61.exe
    Make auto-reboot box is checked:
    Click PIT and select the acs-indulge.pit that you extracted previously.
    Click PDA and select the tar you downloaded

    Put your phone in Download Mode:
    Make sure the USB cord is unplugged
    Remove the battery
    Reinsert your battery
    Hold down the "9" key
    While holding the "9" hold down the power button.
    The phone should now be displaying a Yellow Triangle with Downloading... (see next post for image of download mode)
    Plug the phone into Computer
    Under ID:COM, the box should turn yellow and contain the com port. If it doesn't see Troubleshooting at the end.
    Odin should now look like this:
    [​IMG]

    Now you should be able to click Start.
    Your phone should auto-reboot when finished and should be working 100%!
    This has worked on numerous phone that have partition issues, intermittent booting issues, and many other file system issues.

    This returns you back to factory stock, aka Metro/Cricket has no idea stock

    Troubleshooting:

    Odin isn't detecting the phone?!

    It seems frozen and hasn't made any progress for 15 minutes

    here is a how to video for the epic but its the same basic process just with different files

    Advertisement
    :
  2. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    Heimdall and what it means for you

    Heimdall is an opensource program that is designed after ODIN to flash firmware. it is cross-platform and runs just the same with a few minor changes. first things first, you need to get it.

    Heimdall – Glass Echidna

    Download it for the platform of your choice (linux make sure to grab both the cli and the frontend version)
    You need to then extract the tar you have downloaded, i recommend using 7zip to do this. you should have a bunch of files all ending in .rfs or .img these are the files you want, i suggest moving them to the desktop for easier finding

    Load up Heimdall

    it looks like this:
    [​IMG]

    What you want to do then is click on each of the browse buttons filling in the required slots except the pit, as you are not looking to re-partition the device. Once you have the parts all in there click start and watch as it flashes.

    If you are testing a new kernel or system, or even a new modem, you dont need to fill up everything, just what you wish to flash.
    someguy43210 and popovpumpkin like this.
  3. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    Stock files:

    Download R910 - Option 1 (direct) | Mirrors :: Direct #2
    Download R915 - Option 1 (direct) | Mirrors :: Direct #2


    This will flash your phone with stock kernel, stock unrooted system and recovery. Just load it in PDA on odin. For Heimdall all you will have is Factoryfs.rfs, zimage, and recovery.bin. (NOTE: The R915 version includes param.lfs.)


    Download R910 - Option 2 (direct) | Mirrors :: Direct #2
    R915 - Option 2 - coming soon


    More of the stock files, including blank data, cache, and dbdata partitions, as well as the efs and param.lfs partitions. If Odin can fix it, other than the modems, it's in here.
    Make sure to give a big thanks to k0nane for this file.



    Credits:

    Cyc - for the original guide on the epic tweaked and modified to suit the indulge
    DRockstar - R915 param.lfs
    k0nane - R910 files, R915 factoryfs.rfs
    ciper - first Odin tester on Indulge
    Stock users - original dumps
  4. ciper

    ciper Well-Known Member

    Before anyone asks or replied I want to say this method should be considered a last resort when all else has failed. Ask for help when you're stuck, try to do a normal factory reset, reinstall the removed apps and/or the unroot script.

    Edit: READ THE TEXT FILE INCLUDED WITH HEIMDALL. THERE ARE A FEW STEPS BEFORE THE PROGRAM WILL WORK

    If you are trying to return to stock and nothing is wrong with your phone you could probably do a factory reset and then apply the factory.rfs file alone, skipping all the other steps
  5. wilsonbx198st

    wilsonbx198st Well-Known Member

    Tried it and it works perfectly! !
  6. traajik

    traajik Well-Known Member

    could someone explain to me what the symptoms of a semi-bricked phone would be, like it's able to be restored but it's broken at the moment? or it works but somethings do not?
  7. k0nane

    k0nane Well-Known Member Developer

    A soft-bricked or "sponged" as some call it device is one that will only boot to the Samsung screen or recovery.
  8. wilsonbx198st

    wilsonbx198st Well-Known Member

    i think i just f'ed up my phone ,i was trying to revert back to the old firmware build after i got the update , i used the odin program and i got a fail after that i tried to restart my phone but all its showing is a phone and a computer sing , people i need help with this
    this is what i get <ID:0/005> Added!!
    <ID:0/005> Odin v.3 engine (ID:5)..
    <ID:0/005> File analysis..
    <ID:0/005> SetupConnection..
    <ID:0/005> Initialzation..
    <ID:0/005> Get PIT for mapping..
    <ID:0/005> Firmware update start..
    <ID:0/005> cache.rfs
    <ID:0/005>
    <ID:0/005> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)
  9. k0nane

    k0nane Well-Known Member Developer

    Where did you get a cache.rfs? Redownload all the files and reodin.
  10. wilsonbx198st

    wilsonbx198st Well-Known Member

    i dont know what happened but i took it to the metro pcs store and i told them that the ota update bricked my phone but they changed it for me. :)
  11. k0nane

    k0nane Well-Known Member Developer

    You got lucky! Don't do that again.
    $ilver$urfer and markolo25 like this.
  12. wilsonbx198st

    wilsonbx198st Well-Known Member

    yea i know but its weired because ive done it once ,but after i got that update ota and tried to revert to stock it just messed up.
  13. markolo25

    markolo25 Well-Known Member

    I'm having the same problem wilson is having, and currently is in the same situation, my cache.rfs is from the included tar file, if i do go to metropcs to get a replacement what do i tell them
  14. wilsonbx198st

    wilsonbx198st Well-Known Member

    i told them that i received an update ota and it reseted by itself then a red box appeard to visit a metro pcs store. after that the phone wouldnt start up. they gave me a replacement right away :)
  15. ciper

    ciper Well-Known Member

    Don't do that. That is why carriers try so hard to lock the phones down
    confed likes this.
  16. markolo25

    markolo25 Well-Known Member

    in odin, do i just put in the tar, or do i put in the tar with the pit
  17. lilonex3

    lilonex3 Well-Known Member

    having the same problem as wilson,going to redownload the tar if all else fails wont have no other choice but to take to metropcs.............
  18. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    sorry about this im reuploading a new tar now one without a cache, this will flash your phone back
    DO NOT REPARTITION YOUR DEVICE.

    also why the sudden surge of people using this?
  19. lilonex3

    lilonex3 Well-Known Member

    well for me this update happened while at work so i let it do its thing.My phone rebooted and the tw loader wouldnt load it would loop in force close.I factory reset,removed sim card,even left the battery out for a while and nothing.So this was my last resort and even now this is failing,i get the phone and pc picture.


    <ID:0/009> Odin v.3 engine (ID:9)..
    <ID:0/009> File analysis..
    <ID:0/009> SetupConnection..
    <ID:0/009> Initialzation..
    <ID:0/009> Get PIT for mapping..
    <ID:0/009> Firmware update start..
    <ID:0/009> datafs.rfs
    <ID:0/009>
    <ID:0/009> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)
  20. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    yea we tried to use the epic 4g's data and cache as yall dont have a proper tar.. this was just patch jobed by us.. its still uploading you can join the webchat and talk about it tho :p
  21. lilonex3

    lilonex3 Well-Known Member

    wont let me into the webchat
  22. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    did you click on the indulge link? type in a username then the captcha?

    edit new tar is live
  23. lilonex3

    lilonex3 Well-Known Member

    thanks bro this did it ! sorry i keep getting booted from the webchat.can i go back to root with this?
  24. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    yes you can :D
  25. ciper

    ciper Well-Known Member

    I want to point out that this will not reflash your radio firmwares. If you got the update and run this you will end up with new radio firmware but with OS build EA29.

    This could mean many things -
    1. All the changes for LTE were firmware based and everything will be great
    2. Some of the changes for LTE were on the OS and you wont get the full benefit
    3. Some changes for LTE were OS based and now with the incorrect firmware there will be bugs since you are running a mismatched set of code
    confed likes this.
Loading...

Share This Page