Random freezing and app crashing Straight Talk ZTE Merit Z990G.


  1. Hello,

    I am new here and this is my first post. I don't know anything about these smartphones so please excuse me if my terminology is incorrect in some aspects. I have recently purchased a Straight Talk ZTE Merit Z990G from Walmart. The problem I am having is it seams like it is constantly freezing up all the time. Like whenever I play games like words with friends, dice with friends, and other of the "with friends" games. However, I have had this happen with other games and apps as well. I'm wondering if this is simply just because there is multiple apps running at all times? I know these things don't have much memory at all. However, I don't understand how you close apps when your done with them. It also seams there are a lot of junk apps installed on the phone that are constantly running that I have no clue what they are. Could someone tell me if it is safe to remove these, and which ones can be safely removed? I would also like to get into rooting this phone but I have absolutely no clue about how to do so. A lot of the stuff is over my head. However, I do work on a lot of computers and I am very knowledgeable about every aspect of a computer. The problem with the phones is there is a lot of stuff I just never heard of. If someone could point me in the direction of an easy way to root this phone as well I would be very grateful. If someone could walk me through the steps to rooting it that would be even better. One last question. How can I reset the phone back to its factory settings and apps in case of a problem?

    Thanks,
    Rocky


    Advertisement
    :
  2. Rush

    Rush {<>}~{<>} Guide

  3. Hello and thanks for the welcome and your reply. I have tried to enter the code that your pointed me to so I could do a factory reset. I got the same message that the guy got that commented after trying to use it. It says something about invalid MMI code. However, I have found a setting in the phone that says "Factory Data Reset". Says that it will "Erase all data on the phone" I tried this and it also asked if I wanted to wipe my SD card and I chose yes. I wonder if this is doing a "Full" reset of the phone, or if it is just wiping any data I have added to it since owning it?

    Thanks,
    Rocky
  4. Rush

    Rush {<>}~{<>} Guide

    Wiping the sd card will erased all saved/stored pics, music, etc. Hopefully you didn't have anything stored that you need.. Anyway, I hope the resetting the device did the trick.
  5. I was able to get everything wiped. I would really like to root this phone so I can have access to anything and everything I could possibly want to do with it. I have found a guide online that shows how to do it, but I don't understand a lot of what they are saying to do. Just from looking at the instructions it looks like a lot of typing codes into the phone that perform different commands and will eventually root the phone. Am I correct to assume this? Is it really just a copy and paste job, or is it really technical?

    Here's the link to the guide I found below. Any tips and instruction on how to pull this off would be most appreciated. http://androidforums.com/avail-all-things-root/566407-root-zte-z990g-merit-avail-variant.html

    Thanks,
    Rocky
  6. Okay I am fallowing the above guide. I have got the log set pulled up on the screen and have it enabled. However, when I go to the next step which is...

    If it exists, delete it and immediately symlink it to /data/local.prop, logset may recreate it, if it does delete and try symlinking again.

    rm /data/local/logs/kernel/log_kernel.txt
    ln -s /data/local.prop /data/local/logs/kernel/log_kernel.txt

    This is what I'm getting. Can someone please explain what I am doing wrong and what I need to do from here?

    C:\Windows\system32>adb shell
    $ mkdir /data/local/logs
    mkdir /data/local/logs/kernelmkdir /data/local/logs
    $ am start -a android.intent.action.MAIN -n com.zte.emode/.logset
    mkdir /data/local/logs/kernelam start -a android.intent.action.MAIN -n com.zte.e
    mode/.logset
    mkdir failed for start, Read-only file system
    $ am start -a android.intent.action.MAIN -n com.zte.emode/.logset
    am start -a android.intent.action.MAIN -n com.zte.emode/.logset
    Starting: Intent { act=android.intent.action.MAIN cmp=com.zte.emode/.logset }
    $ ls -l /data/local/logs/kernel/log_kernel.txt
    ls -l /data/local/logs/kernel/log_kernel.txt
    -rwxrwxrwx root root 95569 2012-08-18 17:50 log_kernel.txt
    $ rm /data/local/logs/kernel/log_kernel.txt
    ln -s /data/local.prop /data/local/logs/kernel/log_kernel.txtrm /data/local/logs
    /kernel/log_kernel.txt
    rm failed for /data/local/logs/kernel/log_kernel.txt, Permission denied
    $
  7. Rush

    Rush {<>}~{<>} Guide

    Hopefully a 'bump' of this 'thread' will get the proper attention it needs.

    Good luck. I've never rooted a device before, so I wouldn't be of any help... Sorry.
    grimreaper1014 likes this.
  8. Okay thanks! Well, I haven't made it far but I have made it further than I ever thought I would lol. Not sure what the heck is going on now. Hopefully, someone can point me in the right direction. Thanks for your help with the reset. The phone was not freezing anymore =)
  9. Okay I have made it all the way to the part about rebooting and sending the su file. I put the reboot command in but nothing rebooted. What do I do from there? Also where should I put the su file on a Windows computer? Do I need to run a different command to get it to copy the su file on a Windows computer?

    Thanks,
    Rocky

    ****Update: I believe I figured it out. Couldn't be any easier really. I was getting confused and copying and pasting the whole command in each box. You got to type the commands in line by line and hit enter. Just keep going all the way down the post and copying and pasting all the commands into the command prompt. Even when you get to the part about the "su" file you just keep on copying and pasting away. I am now to the part where it says to install the superuser app. I will report back with any problems.

    ****Update 2: Superuser access has been granted and phone was successfully rooted. I am a happy camper!!! =)))))))))))))))
Loading...

Share This Page