Randomly Turning Off?Support

Last Updated:

  1. Rob89

    Rob89 Member

    Hi new here.

    Just wondering if anyone else is having this problem.
    Got the phone on 1st April and since then it has randomly turned itself off twice, then I need to manually turn it on.

    First happened over night and found it was turn off in the morning with alot of battery life.
    Then again in the afternoon same day with alot of battery life.

    Made contact with my contract provider and they says it's software related and my phone is just a 1 of few... They are sending me a new one to replace but I honestly think it will occur again.

    Only apps I have installed are, Facebook, Ebay, Twitter and Google Goggles.

    Anyone have any ideas or solutions?
    I'll be contacting Samsung in the morning too.

  2. sodaks

    sodaks Member

    it's not normal, i suggest you to do a soft reset by holding the power key for 10 seconds to refresh the memory.
  3. Rob89

    Rob89 Member

    well since the 2nd turn off, it hasnt done it since. But I'm still going along with getting the phone swapped.
  4. Rob89

    Rob89 Member

    Was on the phone to Samsung too.
    Chap said it was Firmwire or battery problem and that they have had similar complaints not just on the Ace but on other phones.

    He suggested to send it out for repairs or replace and that my phone is just 1 of few and just got unlucky.

    Still dont believe tho. Find it hard to.
  5. ankeetg

    ankeetg New Member

    I seem to be having the same problem!
    I've to remove the battery and restart my phone again.

    It really is annoying to check if my phone is still switched on.

    I'm waiting to see if there's a fix or if this is just a defective piece!
  6. rtspring

    rtspring Member

    I have exact the same problem. It became worse after upgrading to latest firmware (PDA:KB7 / PHONE:KB1 / CSC:KB6)

    Now my phone randomly shuts down at least once every day...
  7. Rob89

    Rob89 Member

    Well mine just turned off itself again today after going through 1 whole day without it happening.
    Expecting my replacement delivered tomorrow and going to see if it happens again. This time I am not going to download any apps apart from Facebook, and I will link only my email.

    Let's see if Samsung are correct about just being unlucky getting a faulty phone... Highly unbelieveable but if it strikes twice I'm going to complain again.
  8. sbnaul

    sbnaul Well-Known Member

    I think u ve a faulty piece as i dont face any such probs...
  9. Rob89

    Rob89 Member

    Ok had the replacement phone for 6hrs brand new. Just found it turned off with full battery.

    What to do...
  10. rtspring

    rtspring Member

    i installed whatchdog... this morning i found my phone switched back on again asking for pin to unlock simcard...

    don't know what to do next..:confused:
  11. Rob89

    Rob89 Member

    2nd replacement giving me problems again...
    This time I was told to not put anything outside on the phone like songs. So i didnt and only installed Facebook and linked my email account...

    Still decides to turn off and wait for me to find it to turn it on...
    I'm about to give up completely with Samsung and try a HTC out!
  12. MirandaTh

    MirandaTh New Member

    I am experiencing the same problem as of today, but I found a German forum where a lot of people were talking about this and one of them stated that it is probably a problem that has to do with the WiFi connection of the phone. In Settings-> Wireless and networks-> Wi-Fi settings you can press the menu button to go to advanced settings. Here you will see the Wi-Fi sleep policy which means that the Wi-Fi will turn off once phone's screen turns off.

    This person chose for 'Never' instead of the standard 'When screen turns off', and didn't have any problems for 3 weeks straight. After that he switched it back just to see what would happen and the phone turned off by itself the same day.

    Perhaps this really is the solution for our problem, I sure do hope so. I am going to try it, see if it works for me. Thought I'd let you know, hope we can all still enjoy this phone and that Samsung finds a way to fix it soon!
  13. TotoyKamote

    TotoyKamote Member

    Same thing happening to me. My Galaxy Ace is 2 days old and phone turns off my itself at least 1x a day. When phone automatically turns off, I can still call the galaxy ace mobile number but the device never rings or any indication of activity.

    I will try to hard reset...
  14. Rob89

    Rob89 Member

    I would try the theory above but sadly I have already rang up to replace my Galaxy Ace with a HTC Desire and try that out. Soo happy I get 14 days to decide if I want to keep them.
  15. TotoyKamote

    TotoyKamote Member

    will try this too and let you peeps know...
  16. TotoyKamote

    TotoyKamote Member

    after 24hours++ of testing, the problem re-occured. I left the phone overnight, about 6 hours w/o charger plugged. I can call the mobile phone even it looks like turned off and still the galaxy ace is not ringing. I have changed the settings:

    settings > wireless and networks > wifi settings > advanced > wifi sleep policy > never

    I will try now the hard reset but I will call my supplier and ask for a change of model or change of brand.
  17. daolak

    daolak Member

    Same problem here, randomly the phone just seems to have shut down, have to hold the power button a few times to get it boot again. Got my ace four days ago. Have put in bunch of apps, but by the comments here, it doesn't seem to matter.

    It actually seems that the phone probably doesn't shut down, instead it is on, probably frozen, and doesn't respond to button presses or give out ringtone when called to.. That would explain why a single long press on the power button fails to turn it on.

    I just put on the wifi setting to never sleep (as suggested above), and am wishing that the problem go away. I'm not very keen to get it replaced only to find the same problem again..

    [update]: Nope, i suppose the wifi setting doesn't help, as the phone again shut down 5 min after changing the wifi setting. It's the second time in an hour, if this keeps up, i probably must get it replaced.. sigh.

    [update2] I updated the firmware with kies on 10. april, and don't recall having this problem before that, although i did get the phone on 9. so maybe i just was lucky before the firmware update.
  18. TrisTan5267

    TrisTan5267 Well-Known Member

    How come I didn't experience this guys? Or probably just haven't noticed it? Or maybe it's not happening to me? :)
  19. TotoyKamote

    TotoyKamote Member

    you are lucky =)

    Question: when do you leave your WIFI switched ON overnight? do you leave your galaxy ace plugged in overnight?
  20. MirandaTh

    MirandaTh New Member

    I have tried it myself for the past two days and I haven't had any problems, BUT I have had my WiFi turned off completely unless I need it, because my dad reread the forum and said that the problem is not in the WiFi going into sleep mode, but the WiFi itself. Guess I misunderstood. Turning WiFi completely off has worked for me for the past couple of days, perhaps you could try that? I really hope Samsung notices and fixes it soon.
    lumbkoz likes this.
  21. daolak

    daolak Member

    I found another workaround, turning off sleep mode.
    Maybe there are easier ways to do it, but i did it like this:

    (copied the instructions from another forum):

    - Download and install a free app Load Monitor.
    - Under its preferences check the following on...
    - Add Notification, Only notify high load, Auto start, and most importantly Wake Lock.

    The wake lock prevents the phone from going into sleep mode, now i'm already 24 hours without shutdowns. I also set the update interval to 2 hours for the Load monitor, so it doesn't bug me often.

    The downside must be battery consumption, i assume that the sleep mode does save up some juice. But at the moment i'd rather worry for the battery than if the phone is on or not. :)

    Also, this problem is not limited to galaxy ace.. A little searching with google revealed that there is even a class action lawsuit against samsung because of the same problem in samsung S models.
  22. TotoyKamote

    TotoyKamote Member

    Yep you are correct. I experimented too with it.

    After hard reset for a number of times I observed the unit. I noticed that:

    1. performing this... "settings > wireless and networks > wifi settings > advanced > wifi sleep policy > never" has a bearing. Performing this lessens the possibility of random turning off when wifi is ON. I experimented on default settings while the wifi is on, the probelm recurs.

    2. Turning wifi OFF when not needed did not exhibit the problem. It really saves a lot of juice =) I experimented now for more than 24 hours.

    You are correct on that WIFI off when not needed thing =)
  23. TotoyKamote

    TotoyKamote Member

    I will try this too after validating the TURN OFF WIFI if not needed style for a couple of weeks

    Its cool to have workarounds, We can finally enjoy our samsung galaxy ace.
  24. TrisTan5267

    TrisTan5267 Well-Known Member

    I only switch my WIFI on when I need it. I don't do overnight charges because overcharging will make the battery bloat and lessen its battery life. I also charge with my phone off. And wait for it till it says 100% charged. And I don't charge my phone yet when my battery icon is blinking. That way it is not drained and at the same time it is at its lowest state. So maybe that's why I don't experience problem as you guys.

    I am not experiencing problems for my Samsung Galaxy Ace because:

    1. I don't overcharged it or do overnight charging.

    2. I charge with my phone off.

    3. I only charge when my battery icon is blinking or when my battery life widget says its only 5%.

    4. I switch on my wifi only when I need it.
  25. daolak

    daolak Member

    Well, this can be the reason, but not necessarily. Maybe there's a hardware defect in some phones.

Share This Page