Razr Maxx HD and Jelly Bean Amazon app storeSupport


  1. omawb

    omawb Active Member

    Does anyone else experience a problem with Amazon app store after installing Jelly Bean? I have uninstalled and reinstalled the app, but when I click on the icon I get a message: Unfortunately, Appstore has stopped. Any suggestions?

    Advertisement
    :
  2. FussBoss

    FussBoss Well-Known Member

    I am having the same issue. Seems not to have liked the update.
  3. goldz28

    goldz28 Well-Known Member

    Same thing happened to me. I un-installed and re-installed and it's still happening.
  4. lowboydrvr

    lowboydrvr Well-Known Member

    Go to Settings, Apps, and then the Amazon Appstore and clear the data. It should correct any issues you are having.
    omawb likes this.
  5. t0ked

    t0ked Member

    I removed all my amazon apps. then added an amazon account to accounts and sync settings page. reinstalled and now everything is fine.
  6. omawb

    omawb Active Member

    Thanks lowboydrvr, that seems to have done the trick!
  7. FussBoss

    FussBoss Well-Known Member

    Dang that's going to suck for me. I have a hood amount of apps from Amazon. Will give it a try tonight.
  8. lowboydrvr

    lowboydrvr Well-Known Member

    Try clearing the data first...that process is quick and painless.
  9. notbitter

    notbitter Member

    If I clear the data, that works for maybe fifteen minutes and then I get the error. The error will also come back if I close the app by sweeping it away in the app chooser. Very frustrating if I have to uninstall all my Amazon purchases. Can anyone confirm that uninstalling and reinstalling all their Amazon apps is more than a temporary fix?
  10. omawb

    omawb Active Member

    Oops, yes, the problem did return for me as well.
  11. jroc

    jroc Well-Known Member

    When this happens I just reboot the phone. It didnt start happening to me until I updated the Amazon app store recently.
  12. FussBoss

    FussBoss Well-Known Member

    OK so I found a solution that does not involve removing all of your Amazon apps.

    Uninstall the Amazon app store app.
    Sign into your Amazon account in the add accounts page.
    Reinstall the Amazon app store.

    Did this yesterday and it is still working. There was even an update for the Amazon app store app this morning.


    Edit - this worked for a few days then stopped working.
    robdec17 likes this.
  13. GS300

    GS300 Well-Known Member

    I am really confused, but nothing new there. I did the OTA and I can't seem to find the Amazon App Store in my list of apps when I press the app button.
    In setting >apps>all> it looks like there is one but when you open it the only choices I see are foce close,disable and clear data. No uninstall command.
    Under widgets there was an Amazon widget which I put on an additional homepage. I will attempt to post a copy of it.
    So is the widget the App Store? or is the Amazon App the app store which I can't seem to access to either run or uninstall? The Amazon App Store App isn't on the Playstore is it? Wouldn't make sense to be there.) Couldn't find it there to try and install.

    GS

    Attached Files:

  14. droidros

    droidros Well-Known Member

    I'm having an even weirder problem.

    I bought my phone through Amazon Wireless and they sent me instructions to install the Appstore and some free apps.

    I downloaded and installed the Appstore. After I signed into my account it opened up fine but I was on the UK site -- everything was in pounds and my free apps were not showing up per the email.

    I do have an account on the UK site as well, so I figured I must have mixed up my account settings. But since I coudn't figure out how to change them, I uninstalled and reinstalled the appstore.

    This time, when it opened, it said that I had changed my country. But when I said OK, it gave me the error that others were getting and closed down.

    So I went to settings and cleared the cache and the data, thinking that maybe it would start over and allow me to reenter everything. But when I went back, it gave me the changed country message and then opened up to the UK account.
  15. dhbuckley

    dhbuckley Well-Known Member

    I lost the Amazon Appstore with the same "unfortunately..." error. I uninstalled and reinstalled, worked for a while, then re-broke spontaneously.

    Did not clear data, or remove apps but did follow FussBoss' steps above. Seemed to be working fine but when I close and attempt to reopen, same error.

    If you have "nuked" all apps/data and it then works again for any sustained period of time, please post back.

    Don't want to spend time to nuke yet--don't do it for me....;-)...but if you already have, let us know.

    Nuke well, all.

    David
  16. droidros

    droidros Well-Known Member

    Just spent about an hour on the phone with Amazon support and tried everything, but have not been able to resolve the issue. After multiple attempts at deleting and reinstalling the appstore, I changed my password, deleted the app, deleted and readded the Amazon account, reinstalled the app. Initially it opened on the UK website but then said I had changed countries... switched to the US website, gave the error message, and closed down.
  17. FussBoss

    FussBoss Well-Known Member

    I wanted to report after about 2 days my Amazon app store stopped working yet again lol. Oh well....
  18. droidros

    droidros Well-Known Member

    This morning I received an email from Amazon that they have updated the app and fixed the problem :). So once again, I downloaded and installed. It opened to my UK account.

    Once again, I deleted my amazon account as well as the appstore through Settings and entered everything all over again. When I opened the appstore, it did open to the US account, but then immediately popped up the error message and closed down. Next time I opened the app, it was back to the UK account. BTW, I had signed onto my US account through the Chrome web browser on the phone, and it went to the correct site. Bottom line is the appstore works for UK accounts, but not for US.
    :mad::mad::mad:
  19. droidros

    droidros Well-Known Member

    Anyway, is there anything one can get through Amazon Appstore that one can't get through Google Play?
  20. belledee

    belledee Well-Known Member

    Daily free app
  21. omawb

    omawb Active Member

    Received an email from Amazon app store to update the app this morning.
  22. droidros

    droidros Well-Known Member

    Did you and did it work?
  23. hansangb

    hansangb Well-Known Member

  24. droidros

    droidros Well-Known Member

    I think I finally have it working. I created an entirely new account in Amazon using my gmail address instead of Comcast. I once again deleted the account on the phone as well as the app, and then recreated everything using the new account. At first, it did open and immediately close. But after I opened it again, it didn't revert to the UK account and it stayed open. Strange.
  25. omawb

    omawb Active Member

    Yes, it appears to be working now.
Loading...

Share This Page