1. Androidforums is going down shortly (7:00pm Central) for a few minutes of maintenance. We apologize for any inconveniences - will not take long!

RAZR MAXX won't send email unless wi-fi is ON . . . ??Support

Last Updated:

  1. ralphtt

    ralphtt Member

    Title says it all . . . cannot send email from RAZR MAXX unless via wi-fi. Am in a 4G area but have to be using wi-fi in order to send email. Receives email fine . . . via 4G but won't send unless using wi-fi.

    I must be missing a setting somewhere but have looked really hard.

    Any help much appreciated . . .


  2. Digital Controller

    Digital Controller The Real Bass Creator Guide

    Is your 4G actually working? If not you could always try re-entering the APN settings for your network...or you could always try redownloading the app from the Play Store, or even just restarting the device.
  3. ralphtt

    ralphtt Member

    4G is working. Restarting the device does not help.

    Don't understand the other two suggestions.

    APN . . . ?

    Which app from Playstore . . . ?
  4. razrclive

    razrclive Well-Known Member

    Go into your email settings and check that "sync over Wi-Fi only" is not ticked.
    seVer likes this.
  5. seVer

    seVer Well-Known Member

    What razrclive said. Post back with results.
  6. ralphtt

    ralphtt Member

    "Sync over wi-fi only" is not checked . . . but it sure acts like it is. :confused:
  7. seVer

    seVer Well-Known Member

    How about settings, data usage, menu, restrict background?
  8. razrclive

    razrclive Well-Known Member

    on home screen go to settings>accounts&sync make sure the slider at top is in on position for sync.
    It should tell you below if sync is on for your accounts.
    Go to settings data usage>but click on the more option below it. click on mobile networks and check data enabled is checked.
  9. Caesars

    Caesars Well-Known Member

    What email account is not working? Is it Yahoo?
  10. razrclive

    razrclive Well-Known Member


    Are you still reading your post?
  11. ralphtt

    ralphtt Member

    Sure am but have been unable to reply til now.

    gmail works fine. My email acct at charter.net will not send except via wifi. Problem is Charter does not care. :banghead: :mad:
  12. sherri

    sherri Well-Known Member

  13. ralphtt

    ralphtt Member

    Probably is a settings issue but not covered by the referenced charter info.
    Appreciate all the tips but no help yet. . . :screwy:
  14. sherri

    sherri Well-Known Member

    All your settings are correct in the Charter email?
  15. ralphtt

    ralphtt Member

    Yes. Charter email works fine in wifi and will receive but not send in 4G.
  16. seVer

    seVer Well-Known Member

    Some email providers only allow sending while connected to their internet. Check into that.
  17. sherri

    sherri Well-Known Member

    And according to Charter's help page, Wi-Fi must be enabled to send....
    ralphtt likes this.
  18. ralphtt

    ralphtt Member

    Didn't know that . . . but that's precisely what's happening.

    Thanks, Sherri . . . Guess I can always send using gmail but makes it kinda' difficult to repy to an email received on charter when I'm out in the boondocks.

    Really appreciate your assistance and that of all the others who tried to help!



    Ralph T
  19. sherri

    sherri Well-Known Member

    Can you set up Charter Email to be forwarded to Gmail? I have an Optimum Online account I did this with. All email from that account gets sent to my gmail account. When I go to reply, I can choose which account to choose from.

    In your case, you can choose the gmail account, and it will send via the phones data connection. You need to set up gmail forwarding from your account on a PC (or Mac), but it might be worth a try!
  20. ralphtt

    ralphtt Member

    I'll check it out. Worth a try.
    Thanks again!
  21. sherri

    sherri Well-Known Member

    Let us know!
  22. syntrix

    syntrix Well-Known Member

    Charter will only allow sending ON NETWORK.

    So they block when you try to send on cellular. There isn't a problem here, your email is functioning like Charter intends.

    Should have called them first to begin with.
  23. ralphtt

    ralphtt Member

    So, stick it in your ear, syntrix. FYI, I did call Charter and got no help.

  24. syntrix

    syntrix Well-Known Member

    Right, because they won't allow it. Period. Not a razr problem, it's your provider's email problem.

    You will need the following information to allow your Smartphone to connect to mobile.charter.net. Please use the mobile device settings for mobile devices. You will not be able to send messages if you use other settings. The mobile device settings can also be used on a laptop or netbook to send messages using a desktop Email client when not connected to a Charter internet connection.
    Username: username@charter.net Note: Make sure you enter @charter.net after your username or you will be unable to login
    Password: The password you use to login to your Email account
    SSL: This setting should be On for both SMTP and IMAP.
    Protocol: IMAP
    Incoming Email Server: mobile.charter.net
    Port: 993
    Outgoing Email Server: mobile.charter.net
    Port: 587
    If applicable: a login will be required when sending and receiving mail.
    Click here for instructions on setting up your specific mobile device.

    Looks like they might allow on imap now!

    I'd stick this in your browser, not your ear:

    Mobile Email Settings - Charter Communications
  25. sherri

    sherri Well-Known Member

    The link within this link (click here) gives you information on how to set this up on Android phones. In THAT link, directions tell you that this is Wi-Fi capable.

    Long story short: Charter email only sends over a WiFi connection. Not data.

Share This Page