Re-install system (stock) apps?


Last Updated:

  1. romulocarlos

    romulocarlos Member This Topic's Starter

    Joined:
    Jan 10, 2011
    Messages:
    7
    Likes Received:
    0
    Hi everybody.

    I have a Milestone2 and made a backup of my apk's, by simply copying the files from /system/app to another location. Then, I delete some apps, like social network, gmail and some others.

    But I can't re-install them, the installer says "application not installed" at end of process. Copy the files back to /system/app folder don't work as well. Android SDK bring a message saying FAILED_INSTALL_OPTDEX after "adb install" command.

    A detail: Super Manager shows "(no install)" at end of file name, like "email service (no install)".

    How can I can re-install these apps?

    Thanks in advice.
     

    Advertisement
  2. sitlet

    sitlet Banned

    Joined:
    Apr 11, 2010
    Messages:
    5,867
    Likes Received:
    633
    You need to be rooted to backup those apps. You cannot just copy the files from the system folder. And you need to be rooted to re-install those apps. If you aren;t rooted, you will have to run a stock ruu or factory reset to get them back.
     
  3. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    If he backed up system apps it means he is already rooted, does it not?

    As for restoring system apps. Copy the APK file into the system/app folder and change their permissions to: rw, r, r and reboot.
     
  4. romulocarlos

    romulocarlos Member This Topic's Starter

    Joined:
    Jan 10, 2011
    Messages:
    7
    Likes Received:
    0
    Yes, I already rooted my phone with z4root.

    Can you give more details about these permissions, using root explorer or super manager? Need to reset my phone after set these permissions?

    Thanks.
     
  5. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    Using Root Explorer copy the file back to its original location, long press the file and choose Permissions.

    On this scree put check marks as follows:
    User:Read and write
    Group: Read
    Others: Read

    Reboot the phone and the ap will start working again.
     
    romulocarlos likes this.
  6. romulocarlos

    romulocarlos Member This Topic's Starter

    Joined:
    Jan 10, 2011
    Messages:
    7
    Likes Received:
    0
    Yeah, it worked! Too simple!

    Now I have to find some stock apk's. You know some URL to download?

    I found for Droid X, but Android 2.1. My Milestone 2 is Froyo.

    Thanks.
     
  7. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    Let me know what you need and I will copy it from mine and post here or something like that.
     
  8. romulocarlos

    romulocarlos Member This Topic's Starter

    Joined:
    Jan 10, 2011
    Messages:
    7
    Likes Received:
    0
    I don't know what files. Don't remember, I lost some files from my backup, but don't remember wich ones.

    But your phone is English, don't? Mine is Brazilian Portuguse, is there any problems?

    Thanks for your attention.
     
  9. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    My phone is English indeed. Not sur eif that would pose a problem.

    What do you need the files for or what problems are you having that you need them?
     
  10. romulocarlos

    romulocarlos Member This Topic's Starter

    Joined:
    Jan 10, 2011
    Messages:
    7
    Likes Received:
    0
    I lost some APK and ODEX files from my backup. Some problems on my phone are because this, I believe.

    Some issues:
    Short battery life - about 12 hours;
    Freeze at least once a day;
    Low internet speed;
    Can't send scraps to orkut via contacts - orkut freeze any browser, as well;
    Some times, a "force close" appears, for any app;
    Lost signal several times a day;

    And some minor issues I don't remember now. But I remember when I open the box and start to use my phone. None of issues above occoured.

    Today I have uninstalled some apps (ADW Launcher, CPU Tuner and Super Manager) to verify these issues. If I get news, I tell you. But, orkut keeps freezing any browser (tried stock, Opera Mobile and Dolphin HD), even without that apps.

    If you can upload your default /system/app folder, I will backup mine and test with yours.

    Thanks.
     
  11. romulocarlos

    romulocarlos Member This Topic's Starter

    Joined:
    Jan 10, 2011
    Messages:
    7
    Likes Received:
    0
    Nevermind!

    I found a retail SBF for Milestone 2, and flashed with it.

    For now, after a few tests, everything is going fine, even orkut!

    Thanks for your attention!
     
  12. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    Good to hear everything is working now.
     
  13. Europa76

    Europa76 Active Member

    Joined:
    Jun 8, 2010
    Messages:
    44
    Likes Received:
    0

Share This Page

Loading...