1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

re: trying to root a Kyocera Hydro


  1. reble

    reble Well-Known Member

    My service is with Boost Mobile. I have been trying to root the Kyocera Hydro phone So I can turn on the wifi hotspot and tethering. I was told by a factory rep and Amazon that this phone can do that job. Boost Mobile says it can't. Boost Mobile says the only 2 phones that will do wifi hotspot and tethering on there service is the Samsung Galaxy s2 and the HTC Veo. I can't afford ether one new. I was also told by a person online that has been pointing me to online articles about rooting phones. Starting with the fundamentals of rooting. That this phone can do the wifi hotspot and tethering if rooted. I have gotten real deep into my phone. though I am not shure if it is rooted. I see a lot of files that look a lot like windows operation/system files. But I know enough not to do anything with them beyond looking. If i can't get this phone to do wifi hotspot and tethering. Then can someone please tell me what phone would be good for what I need, for what I can afford or trade for. I got the Kyocera Hydro new from Amazon for $150.00 Other then the wifi hotspot and tethering this phone has suited my needs well. Sometimes (but not often enough to buy a separate cell phone type usb device) I take my laptop out on Amateur Radio demo's were there isn't a open wifi to tie into. That's why I need the wifi hotspot and tethering. I always have some kind of a/c power to plug into at the site.


    Steve

    Advertisement
    :
  2. jlgarr86

    jlgarr86 Well-Known Member

    I'm using the kyocera rise which is the brother to the hydro (nearly all the same specs) my phone can use hotspot and tether as well but only if it's rooted. Luckily rooting the hydro is easily accomplished.
  3. jlgarr86

    jlgarr86 Well-Known Member

    Have you rooted your phone yet? I can't tell by your post. If so what program did you use? There are several ways to tell if your phone is rooted. Try a google search (how to tell if my phone is rooted android) or you can download Titanium Backup application from Google market and it will prompt asking for root permission when the app starts up.
  4. squidshere

    squidshere New Member

    I gotta Samsung galaxy prevail, it was an easy root and does what your looking for in tethering and wifi hotspot. You can speed up The 3g easy too. Memory its weak though...
  5. reble

    reble Well-Known Member

    I used a prog called "root checker" the hydro is not rooted. I have been trying to find a rooting prog that I can understand. I understand Android is based on Linux. I don't know much about Linux. I have always used Msdos then Windows. The Samsung galaxy prevail is only good for practicing rooting on. The prevail has (I think hardware) problems. When the prevail has sat a few days with the battery out of it then I put the battery back in. It will work fine for a few days. Then the operations start getting slower until it dies. The battery is fine. I had it tested at a local cell phone repair store. But thay wouldn't tell me any more without charging me to look at the phone. I don't know if is a hardware or a software problem. I got the prevail as is. The prevail looks beat up. the screen has surface scratches on it.

  6. reble

    reble Well-Known Member

    I just downloaded the Titanium Backup application. it is about 4am here. I will start reading the doc after some sleep.
  7. Ptree818

    Ptree818 Member

    :smokingsomb: Yes Hello Ptree here ok here's where we are at currentley... On Boosts Kyocera Hydro running 4.0.1 ics . The two links with the bat script do NOT work pressing the #3 option which would indicate another device. I have not personally tried any of the other #'s because I dont like to freeze phones I just paid 139 for ,w no sbf files or recovery. So as of Oct 19th , there is no root for this phone. I believe u can email Bi4ary and ask him to exploit root, or learn linux and push the superuser app through there is an old video on installing superuser , but it is a little bit ahead of me. My last suggestion for all the people who just dont care and wanna try.... Z4 Root . Lastly yes 2 boost phones DO have hot spot capability but if u root u can and do bypass your carriers hot spot. If u look on play store boost has banned fox fi from being downloaded so it s probably going to be good ol ,Wireless T.
    Hope this helped.
    Ptree
  8. J6Remy

    J6Remy Well-Known Member

    The Hydro is rooted.

    Some things are needed before hand..

    1. Make sure you have the Hydro Drivers

    2. You need to download busybox from the playstore.

    Follow the directions in the Rooting guide

    Boom! Root!


    I really like Foxfi. It doesn't require root, but it is an awesome app.

    -J6
  9. Ptree818

    Ptree818 Member

    Yes hello , i have the hydro drivers, u can not install any busyboxes on play store without having root prior, and have tried that same bi4ary root several times.it lists two models than says other for choice three. What do u think we r doing wrong?
  10. Wiesshund

    Wiesshund Well-Known Member

    I downloaded.both rev 2 and 15 of the.listed root. Both work pick
    Other as device. My hydro is rooted with no difficulties
  11. J6Remy

    J6Remy Well-Known Member

    how far in the process are you getting. Do you get to the "restore my data" option on the phone?
  12. Ptree818

    Ptree818 Member

    :confused:Yes Hello Weis whatever u said makes no sense , can u explain? Here is what I am having trouble with and I even took pics to show every1 what is happening on my end.1st off I don't understand downloading busybox when if u look it is already in the root bat file w/ the su? Next I redownloaded the drivers again for ky hydro boost mobile. All installed put in same folder as root.Ran root bat selected number 3 as ive done everytime w/ the phone in debugging and transfer. Runs bat then says rooted but i know im not cause su is not in there, u dont even need root checker the su willappear in app drawer.not there.I dont know ?Anyways if u know something secret lemme know cause I want root. thx
    Ptree;)

    Attached Files:

  13. Ptree818

    Ptree818 Member

    Here are the files I found in root file and the drivers I downloaded!

    Attached Files:

  14. Robertech

    Robertech Well-Known Member

    i had the same prob where nothing would happen on the phone when the bat file runs. had to use a diff usb port and let the pc install the phones drivers again. good luck
  15. Wiesshund

    Wiesshund Well-Known Member

    It looks as if you are running the bat file.from inside the zip?
    If so.you must extract it to a.permanant folder.
    You have file.path errors.going on there.
  16. Ptree818

    Ptree818 Member

    :D:smokingsomb: Yes hello, ok special thx to Wiesshund ! Sooo apparentley I could have been rooted this whole time, but had never physically had to extract a rooting file in 7zip before( droid 2, galaxy2 and htc t bolt were all one click.This time the file needed to be extracted in 7zip because it was not open that was the path error I kept getting on c prompt. So basically that was whole problem! I then ran program then plugged in phone when c prompt asked. So again thx to everyone but especially Wiesshund!

    Ptree

    Attached Files:

  17. reble

    reble Well-Known Member

    I am trying to run the Titanium backup prog. But I am stuck. I am following the instructions below.
    -----------------
    Titanium Backup HOWTOs
    This section describes the specific and basic jobs methodologies.
    1 How to make your first backup WITHOUT root
    2 How to make your first backup on rooted device
    3 How to restore your backups on a new phone, or after installing a ROM (if you wiped your phone)
    4 How to use the multi-user
  18. Wiesshund

    Wiesshund Well-Known Member

  19. reble

    reble Well-Known Member

    I am stuck again. I can't find the driver for the phone. I found "kc0zus_hydro_setup_x86.msi" I installed it but device manager still shows "kyocera usb modem" under "other devices" with the yellow triangle. I don't know were to look to update the driver.

  20. Jonathunder

    Jonathunder New Member

    Read through the other threads here on what people have done to get the Hydro rooted. Follow their instructions, most are step by step. I can't post links yet, but there are some really helpful people here who are willing to help. I rad through two threads and rooted my Hydro in a couple minutes with NO experience.

    http://androidforums.com/hydro-all-...hydro-confirmed-working-root.html#post4977643

    is HOW to do it.


    http://androidforums.com/hydro-all-...hydro-confirmed-working-root.html#post4970582

    links to the drivers.

    As far as I have read, there is NO recovery yet. Just don't go hog-wild and fiddle around too much if you don't know what you are doing (like me). Following these two steps got me rooted, though. Good luck!
  21. reble

    reble Well-Known Member

    I have the drivers installed correctly and verified with adb.exe shell that the phone is connected. And I have backed up the phone to my laptop already. But I can't find a clear set of instructions on how to use avd and sdk to root the phone. I tryed with a prog called superoneclick to root the phone. The prog gets to line 7 and just sits and waits for an action. I have no idea what it wants.

  22. Chopstikwar

    Chopstikwar Well-Known Member

    My Hydro is rooted, you heard correctly that it will get the job done. Look under one of the first posts when we finally got root access, make sure your phone is running USB Debugging, hit option 4 in the program, and it'll run. It will prompt you to restore data. Restore it. It won't erase anything, but it will give you SU. After you have SU installed on your phone go onto the Google Play Store and type in "Wifi Tethering for Root Users" It'll be the app with a wifi looking icon but it's yellow. After that it's all smooth sailing :) Hope this helped!:)
    Jonathunder likes this.
  23. Wiesshund

    Wiesshund Well-Known Member

    Files needed:
    Kyocera USB Drivers
    32 bit Custom Action Information

    64 bit Custom Action Information

    Bin4ary's multi phone root app.
    http://forum.xda-developers.com/showthread.php?p=31545627
    (I recommend release 15 http://forum.xda-developers.com/attachment.php?attachmentid=1398011&d=1350123242 )

    Instructions:
    1) go to Settings, "System", "Developer Options" and make sure "USB Debugging" is checked
    Connect phone to computer, and select "Media Transfer" on the phone

    2) After extracting the archive of Bin4ary's rooting app to a folder on your PC, open that folder and Run the "RunMe" file and select "3> Other" in the on-screen prompts.

    3) The phone will ask you to enter an encryption password... don't, just hit "restore my data" on the bottom of the screen on your phone.

    4) Follow any further on-screen prompts, your phone will reboot, and you're Rooted

    !!WARNING!! there is currently no working recovery, beware of the changes you make to your phone, modify at your own risk


    (I did not write this)
  24. reble

    reble Well-Known Member

    Thanks Wiesshund. I will let you know the outcome. I have a backup phone if I end up bricking this one. It is a real dumb phone. A LG-102. A very basic phone. Voice and txt only. But it will do in a pinch. My farther was a very wise man. He drilled into me. Always have a backup plain. And the only dumb question is the one that doesn't get asked.

Loading...

Share This Page