1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

"Read-Only File System" when trying to ADB Push an App


Last Updated:

  1. Grimshak

    Grimshak Member This Topic's Starter

    Joined:
    Jun 4, 2010
    Messages:
    20
    Likes Received:
    0
    Rooted my Droid for the first time earlier today, and installed the NexBeast using the handy-dandy Mod Manager. So far everything has been great, but I'm having problems installing non-Market Apps.

    I'm trying to install a Live Wallpaper from http://androidforums.com/all-things-root-droid/63554-coheed-cambria-live-wallpaper.html, but I keep receiving an error.

    Here is a copy from the CMD console:
    I also tried the other method, which says the file is already there?

    If it's already there, what else do I need to do? It doesn't show up under Applications>Manage Applications OR under the Market Downloads.

    I HAVE checked the "Unknown Sources" box, but still nothing. Any ideas? Thanks!
     

    Advertisement
  2. Fabolous

    Fabolous Superuser VIP Member

    Joined:
    Nov 7, 2009
    Messages:
    3,635
    Likes Received:
    2,126
    You need to mount the system as R/W first, before you push:

    Code (Text):
    1.  
    2. adb shell sysrw
    3. adb push blah blah blah
    4. adb shell sync
    5. adb shell sysro
    6.  
     
  3. Grimshak

    Grimshak Member This Topic's Starter

    Joined:
    Jun 4, 2010
    Messages:
    20
    Likes Received:
    0
    Awesome! It pushed correctly. However, I am a SUPER newbie to this, and I'm not sure what to do after I've finished the ADB part of it. On the phone, do I need to install it? Again, I checked in the Market Downloads and under Manage Applications (as well as Live Wallpapers, just in-case), and I don't see anything. I know this is gonna be something simple, I just don't quite know what I'm doing yet.

    Thanks again!
     
  4. Fabolous

    Fabolous Superuser VIP Member

    Joined:
    Nov 7, 2009
    Messages:
    3,635
    Likes Received:
    2,126
    You should just press menu, wallpapers, live wallpapers, and it should be there.
     
  5. Grimshak

    Grimshak Member This Topic's Starter

    Joined:
    Jun 4, 2010
    Messages:
    20
    Likes Received:
    0
    I just realized it replaced one I had already on there...god I feel dumb.

    Thanks again.
     
  6. Carnivex

    Carnivex Member

    Joined:
    Jan 19, 2010
    Messages:
    17
    Likes Received:
    1
    Mind spelling out the actual commands for an Android newbie?

    I'm trying to push a file to my Android device but I get the same error as the original thread starter. Then someone said I had to try doing the adb remount command and it doesn't seem to work :/

    Code (Text):
    1. D:\Test\android-sdk-windows\platform-tools>adb push D:\tun.ko \system\lib\modules
    2. failed to copy 'D:\tun.ko' to '\system\lib\modules': Read-only file system
    3.  
    4. D:\Test\android-sdk-windows\platform-tools>adb remount
    5. remount failed: Operation not permitted
     
  7. GreenAsJade

    GreenAsJade Member

    Joined:
    Jan 19, 2012
    Messages:
    12
    Likes Received:
    1
    Those are the actual commands, to use on your PC.

    However, when I do

    adb shell sysrw

    I get

    sysrw: not found

    Any ideas?

    GaJ
     
  8. GreenAsJade

    GreenAsJade Member

    Joined:
    Jan 19, 2012
    Messages:
    12
    Likes Received:
    1
    Your remount command failed.

    This is because -o,rw is not valid syntax for mount

    So if for no other reason than this, you were sure to fail with that attempt...

    GaJ
     
  9. GreenAsJade

    GreenAsJade Member

    Joined:
    Jan 19, 2012
    Messages:
    12
    Likes Received:
    1
    I did

    # su
    # mount

    (which gave me a list of the mounts, so I could choose the right mount points for /system, which was not mtdblock4 for me, but rather mtdblock1)

    # mount -rw -o remount /dev/block/mtdblock1 /system

    and after that the adb push worked.

    Yay, thanks for the hints in this thread.

    (still don't know why adb shell sysrw didn't work)

    GaJ
     
  10. teddyearp

    teddyearp Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    2,405
    Likes Received:
    829
    That's because "sysrw" is not an adb command. It is usually a .sh script which contains the longer command that some developers have included in their roms to be run from a terminal on the phone. However while in adb shell a "adb remount" usually does the same thing.
     
  11. TFroehlich4368

    TFroehlich4368 Well-Known Member

    Joined:
    Sep 15, 2011
    Messages:
    69
    Likes Received:
    8
    I get a "permission denied" when I adb shell sysrw
     
  12. teddyearp

    teddyearp Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    2,405
    Likes Received:
    829
    Read the post right above yours.
     
  13. malhovic

    malhovic New Member

    Joined:
    Sep 7, 2010
    Messages:
    1
    Likes Received:
    0
    I know this is a necro thread but I thought I would chime in for those that need help since this comes up as the top on google search for "Read-Only ADB push".

    If you're running into this:
    1. Make sure you are rooted with SuperUser of some type installed
    2. On your machine with adb installed, do the following:
    [HIGH]
    --# adb devices
    (make sure your device shows up)
    --# adb root
    (this restarts the adb daemon as root on the phone)
    --# adb push blah bleh
    (this should now run without issue)
    [/HIGH]
    You DO NOT need to remount the /system symlink with rw permissions. A lot of people will do this and forget to remount it back to ro permissions.
     
  14. chadstone30

    chadstone30 New Member

    Joined:
    Nov 8, 2009
    Messages:
    2
    Likes Received:
    0
    necro thread revived!

    apparently the method above is deprecated on my mostly stock nexus 5:

    Chads-MacBook-Pro:~ chadly$ adb root
    adbd cannot run as root in production builds​

    back to google search results
     

Share This Page

Loading...