Read this if you are having any issues with the ICS update (trust me, your answer is probably here)


Last Updated:

  1. Neph81

    Neph81 Well-Known Member

    Ok, it's clogging up multiple threads, so I'm going to put all the info here.

    The situation : You took the ICS update. It doesn't matter how, but you took the ICS update. Your phone now gives you a security error message.

    The cause (1) : You were on another non-stock rom/kernel (BO, BP, etc) and did not wipe before going to ICS.

    The solution (1) : YOU NEED TO WIPE WHEN GOING BETWEEN ROMS. There is no ifs, ands, or buts about this. You need to wipe. Turn off your phone. Power it back on by holding vol down and power together until the factory reset message pops up. Press power twice. Your phone will factory reset and then boot into ICS without issues.


    The cause (2) : You took the ICS update, and rooted. I don't care if you froze something, removed something, etc, but now you have a security error (and yes, i've heard it all so don't b.s. me and say you didn't).

    The solution (2) : Factory reset your phone by powering it off then rebooting it by pressing and holding down the vol down and power button until the factory reset menu comes up. Press power twice. Watch your phone reset and hopefully boot into ICS. If it does, then you froze something you shouldn't have. Don't do that again. If you still get a security error, then follow the instructions in this thread to reflash V7.
    Flashing LG signed Firmware - LG Spectrum - RootzWiki


    The cause (3) : You flashed CWM even thou we all told you not to.

    The solution (3) : Follow the instructions in this thread.
    Flashing LG signed Firmware - LG Spectrum - RootzWiki
    If it gives you an error after flashing this, then factory reset your phone.



    The Situation : You DO NOT want the ICS update, but you are rooted and have CWM installed.

    The cause (1):
    Your phone takes the update, and you boot into recovery. You exit recovery and boot into the OS just fine

    The solution (1) : Take this file. Put it on your sdcard card and boot into CWM Recovery. Flash this file. It will prevent you from taking any OTA updates what so ever.
    http://dl.dropbox.com/u/54501789/Spectrum/BlockOTASpectrum.zip

    The cause (2) : You are stuck in CWM and rebooting just puts you back into CWM. If you DO NOT want the update, follow this solution.

    The solution (2) : Find a way to put these files on your SDcard.
    http://dl.dropbox.com/u/54501789/Spectrum/BlockOTASpectrum.zip
    http://androidfiles.massivefilehost.com/cwm_touch/cwm_bootloop_fix.zip
    Go back to your phone and flash the BlockOTASpectrum.zip file. Then flash the cwm_bootloop_fix.zip file. Reboot into your rom. Now here is the critical part. Update your copy of CWM. You're a whole version behind where you should be. Either grab it from RomManager or from this thread.
    http://androidforums.com/spectrum-a...oot-clockworkmod-recovery-lg-spectrum-4g.html


    The situation : You have CWM and you DO want the ICS update.

    The cause (1) :
    You are stuck in CWM and rebooting just puts you back into CWM. If you DO want the update, follow this solution.

    The solution (1) : DO NOT SKIP THIS FIRST STEP. YOU WILL BRICK YOUR PHONE OTHERWISE.
    Grab this file, place it on your SDcard.
    http://androidfiles.massivefilehost.com/cwm_touch/cwm_bootloop_fix.zip
    Flash it using CWM, then reboot into your OS. Make sure your battery is at 100%, then use the instructions here to flash V7 without the issues of dealing with OTA downloads.
    Flashing LG signed Firmware - LG Spectrum - RootzWiki

    The cause (2) : You keep being pushed into CWM, but rebooting your phone pushes you back into the OS without any issue.

    The solution (2) : Follow the instructions in this thread and flash the V7 .cab .
    http://rootzwiki.com/topic/17823-flashing-lg-signed-firmware/
    If you were on pure stock, you should not need a data wipe. If you encounter any weirdness, do a factory reset once you've flashed the .cab file.

    The situation: You are on ICS, but hate the locked boot loader or hate something about ICS (wifi tethering being broke, etc).

    The cause (1) :
    You hate ICS and just want GB back.

    The solution (1) : I can not stress this enough. There is a chance you will lose data connection if something goes wrong. I've done it a dozen times with no issues, but I also have a lot of experience doing it. IF you are not comfortable with that risk, wait for the un-locker to be published.
    Factory reset your phone. Then follow the instructions in this thread.
    Flashing LG signed Firmware - LG Spectrum - RootzWiki
    Use the V6 cab instead of V7. This will downgrade you back to gingerbread and the unlocked boot loader. Feel free to re-root, cwm, custom-rom, etc.

    The cause (2) : You hate the locked boot loader, but love ICS.

    The solution (2) : Be aware, the custom kernel we're using has a few issues. One seems to be bluetooth connections. The other seems to be ADB shutting down after the phone has battery reaches 100%. We're working on the bluetooth stuff and for ADB, just restart your phone while it's connected to the PC.
    Linux bootloader unlocker:
    http://androidforums.com/spectrum-a...oot-cwm-lg-spectrum-4g-ics-linux-install.html
    Windows bootloader unlocker:
    http://androidforums.com/spectrum-a...20-bootloader-pwnage-tool-lg-spectrum-4g.html


    The situation: You want the update, but the OTA updater keeps failing.

    The cause (1) :
    You're on pure stock (no custom kernel or any other mods)(root or not rooted) Gingerbread and the OTA updater keeps failing. The OTA updater sucks. Period. The double update also feels very much unnecessary.

    The solution (1) :
    Follow the steps in this thread and use the V7 .cab .
    http://rootzwiki.com/topic/17823-flashing-lg-signed-firmware/
    If you are on true stock, you should not need to data wipe. If you run into any weirdness, you will need to factory reset your phone after flashing with the .cab file.


    The situation : Your phone is on ICS and now you can't get it to connect to your computer no matter what you try.

    The cause (1) : Something in either the unlocked kernel or in V7 itself turns adb off and doesn't turn it back on. This is either an init setting we haven't fixed or something in usbhub switching.

    The solution (1) : Reboot your phone with it attached to your computer. ADB starts on boot always and so does the USB hub. It's a PITA, but it's the current work around until we find the real issue.

    More info to come as the questions become asked. This should cover almost everything I've seen so far.

    Advertisement
  2. admn81

    admn81 Well-Known Member

    Good idea making this thread. Hopefully it will help alleviate the similar threads. Will a mod consider making this a sticky?
  3. Lykarsis

    Lykarsis Well-Known Member Contributor

    Just a quick question about wifi. There is a network at my school that is locked so i have no wifi for my evening class, but I like to type my notes on google docs so I need a connection. I use data, but when I turn off wifi (to save battery because it's a 5 hour class) every time I do anything that uses data, wifi turns back on and tells me there are networks available. I have every option I can find set to not turn it on unless I go in and enable it, but it comes on anyways. I have done a factory reset and it changed nothing. Any ideas? Or is it just a quirk of ICS?
  4. Neph81

    Neph81 Well-Known Member

    It's an LG quick in general. You're only chance is to go into airplane mode. Even V6 would constantly turn on wifi and check for networks any time a program started.
    Lykarsis likes this.
  5. Lykarsis

    Lykarsis Well-Known Member Contributor

    Ah, never noticed on GB. Oh we'll, guess I'll just have to get a longer charger cord. Thanks.
  6. alkalinetri3o

    alkalinetri3o Member

    Thanks for all the help so far. I applied the boot loop fix using CWM and rebooted my phone. However, now the phone continously loops to the homescreen, freezes and then reboots. Any suggestions?
  7. Neph81

    Neph81 Well-Known Member

    Sounds like a data issue. Are you on GB or ICS?
  8. alkalinetri3o

    alkalinetri3o Member

    As far as I know GB. I dl the first part of the ICS update and upon rebooting is when I got stuck in the boot loop. The homescreen is old and most likely GB.
  9. Neph81

    Neph81 Well-Known Member

    At this point you are probably better off doing a data wipe and flashing the v7 .cab file directly. It sounds as thou something didn't go correctly with the v6b update and no reason to go backwards when you can go forwards. If there was something you critically needed from your OS, you can flash V6 and save what you need, then flash V7.
  10. resin8kbc

    resin8kbc New Member

    *****IMPORTANT*****
    I tried the bootloader.bat, it failed. There were files not found errors. I am not sure if this has been touched upon yet, but may want to either update instructions or read first file.

    The issue was that the folder I saved it in had spaces, so it was looking for C:\Spectrum, instead of C:\Spectrum ICS Bootloader\bootloader\*.md5.

    Just thought that it might be worth mentioning to everyone to make sure that there are NO spaces in the directory that you save to. Or just update so they save to root of C:\.
  11. alkalinetri3o

    alkalinetri3o Member

    I did a few backups before beginning to unroot the phone so I don't need to go back to V6.

    As far as doing a data wipe I do this by holding down the power button and vol. down button simultaneously? After that should I follow the directions you posted here
  12. Neph81

    Neph81 Well-Known Member

    If you are on stock recovery, then yes. Otherwise that combo will just put you into CWM. Then yes, follow those instructions.
  13. alkalinetri3o

    alkalinetri3o Member

    Just wanted to let everyone know I was able to successfully flash V7 (ICS) by following the above instructions with no issues. Thanks Neph81 for the assistance.
  14. admn81

    admn81 Well-Known Member

    Just wanted to say thanks again to neph, whose instructions helped me alot tonite! Thanks for all that u do to help us out!
  15. hager03

    hager03 Well-Known Member

    THe kp500 tool says file courpeted when I download form rootzwiki and can not extact files.Any help would be apreacited.
  16. Neph81

    Neph81 Well-Known Member

    Either your browser is cutting off the file before it's finished downloading, you're trying to open the file before it's done, or your internet is being wonky.

    I'm going to go with the first as the most probable. Make sure you are on a newer browser. Firefox/chrome/ or at the very very worse ie9+. Try right clicking on the link and choosing "save as". It's in strandard zip format, so everything, including windows, should be able to open it. The final size should be 1.1MB
  17. hager03

    hager03 Well-Known Member

    Thanks Neph, downloaded firefox and it went great
  18. Newdroiduser02

    Newdroiduser02 New Member

  19. Neph81

    Neph81 Well-Known Member

    I'm hoping this is just a temporary issue, but yeah, that's not a good sign. I have a feeling they are very not happy with us for breaking their locked boot loader. You can try taking the v4 update and then going to v6 with the OTA as it should not hurt anything. I'm going to start looking into the legality of hosting the v6 .cab file personally.
  20. christbrock

    christbrock New Member

    Long, long time lurker here but just registered today. I've been rooting and on custom roms since the D1 and have done so on many phones and tablets and have always been able to resolve issues by searching...till this time and I just cant seem to find anything that speaks to this...

    A bit of background......I was on BO3.0 with the OTA update block since it was released back in the spring. Yesterday morning I updated CWM to latest, doubled wiped (as always) and installed Playful's stock, rooted, deodexed V7 yesterday. The rest of the day went fine, no issues using the image at all. This morning on the way in to the office i noticed the phone started rebooting and rebooting and so on. I wiped and restored my nandroid backup of 3.0 and found the same thing. I wiped and restored my stock nandroid backup and same thing. I found that as soon as any rom/image tries to search for service it reboots. I removed my SIM card and tried every rom/image i could and it works perfectly fine, other then no calls, text, data etc. due to the SIM not being installed. But the rom/images work perfectly other then that. CWM works flawlessly as well.

    So at the end of it when i install the SIM card it reboots when searching for signal no matter what rom/image i put on it. When i take the SIM card out every rom/image i through at it boots fine and runs like a champ. Any thoughts or ideas on what I could do? If it is futzed up I am fine with that cause i knew fully what could happen and after multiple years of playing with this stuff if this is the first screw up then ok. Thanks!

    -Chris
  21. death2all110

    death2all110 VIP Member VIP Member

    Sim card could be bad, Ive had my gnex sim go bad, just walk into any vzw store and say you need a new sim, they should activate it for your account and let you put it in. Be careful though, they may put it in themselves.
  22. 1linuxfreak

    1linuxfreak Well-Known Member

    +1 on what d2 said, let VZW install a new SIM in wife's phone, 4 hours later VZW finally had her phone working again.
  23. ortrigger

    ortrigger Well-Known Member Contributor


    My recommendation would be to go ahead and do a .cab flash to ICS. You'll get the updated ril firmware and ics is actually really nice once you root it and get rid of the bloat.
  24. littlenanner85

    littlenanner85 Well-Known Member

    I am running stock Ics with rooted and bootloader unlocked. Without doing anything I quit receiving 4G signal. I still get 3g. I have tried restoring. But it still is 4g. I know this was a issue with the leaked Ics but I have not seen much for stock ics
  25. Neph81

    Neph81 Well-Known Member

    Grab LTE OnOff from the market and use it to check your network setting. I know we also had issues when coming back to stock from CM9 where the data setting went wonky. There is always a chance that something similar happened to your ICS install, that wouldn't always be affected by a .cab restore.
    littlenanner85 likes this.

Share This Page