Recover Files moved by ROM

Last Updated:

  1. jcote258

    jcote258 Member

    OK, Been trying to search around but can't seem to find what I'm looking for. Just flashed the Mikfroyo V4.5 and the ROM took out alot of the aps, wallpapers, ring tones, ect which is nice..I found them in the ES File Explorer and there are a couple things that I want to move back onto the OS. Tried looking around in the file Explorer to see if there was an apps folder or something like that where I could move the files from "Removed" back on the phone to be recognized. This sounds like something should be fairly easy and I'm just missing something. Hit me up and let me know real quick. Thanks.


  2. ndh777

    ndh777 Well-Known Member

    To my knowledge, I don't think so. I can think of two options though:
    1. Try to find downloads online for these missing pieces to your device.

    2. Restore your phone to the way it was initially and try to save the files that are missing somewhere either on a computer or on your SD card somewhere.

    Hopefully someone else helps, I'm still learning but hopefully one of these options can help you.
  3. jcote258

    jcote258 Member

    Well the files are saved on the SD card, the ROM just moved them into multiple folders called "Removed" which tells me that the ROM saved all the stuff it removed for you to go through and put back in what you want. Can someone tell me where to put some ofthis stuff back? There are a few wallpapers, ring tones, ect. that I want to use with the ROM. If this is possible let me know.
  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    you can hook up you phone to the computer and move the ringtone you want to either the root of the card or to where your music is kept.
  5. stevcha

    stevcha Well-Known Member

    If its the apps you want installed you should be able to install them by clicking them if they're .apk format.
    They should install to the system/app folder on the phone. If for some reason they don't install by clicking them you can move them to that folder using root explorer. But make sure you have read/write permissions to the system/app folder.
  6. jcote258

    jcote258 Member

    Clicked on the .apk file through the File manager on the phone and it said that it couldn't install it. Turned the phone into a storage device and opened up explorer, and there are no folders called system or app just folders like; android secure, bookmarks, foot prints, android, data, lost.dir. I opened all the folders and checked sub folders to see if they were just hidden deeper underneath the root folders, no luck. Should I create an app folder or am I just missing it?
  7. JB in AZ

    JB in AZ VIP Member VIP Member

    The folder you are looking for, /system/app, is on the internal memory of the phone, not on the sd card. To see these you need an app like root explorer. You are looking at the sd card. You will not be able to see the internal files via a computer
  8. akazabam

    akazabam Well-Known Member

    Right, so you can't install apps that go in /system/app like you do other apks. When you tap on an apk to install it, it will attempt to install to /data/app, period. If you want to install anything from the removed directory, use root explorer. When you open it, go to /system, then select the option at the top right that says mount rw. That will allow you to make changes to /system. Copy the apks you want to install from the sdcard to /system/app. As JB said, just connecting your phone to your computer via usb will mount the sdcard, only. You can't mount internal storage because you'd have to operating systems controlling one file system at the same time. It would never work. Another option is to use the terminal emulator. We can give you instructions if you don't have root explorer. ES file explorer might work too. You have to enable root mode in settings, first, though.
  9. jcote258

    jcote258 Member

    Ahh got it, will go DL the root explorer, thanks guys.
  10. jcote258

    jcote258 Member

    Ok here is the update. Used Root Explorer and moved teeter.apk from SD card to system/apps and tried to install. Tells me that the application not installed. What seems to be the problem now?
  11. JB in AZ

    JB in AZ VIP Member VIP Member

    Once you moved it to system/apps, then reboot the phone. It should then show in your apps drawer.
  12. jcote258

    jcote258 Member

    OK found out how. Here is the process:

    1) put the .apk on your sdcard
    2) open root explorer
    3) navigate to /sdcard/whatever.apk
    4) long press, move
    5) navigate to /system/app/
    6) click mount r/w up top
    7) click move file ( or paste..whatever it says at the bottom next to cancel)
    8) find the .apk you just moved
    9) long press > permissions
    10) user : read/write, group read, the last one read as well. so it should be r/w, r, r
    11) click ok/back whatever
    12) click mount r/o up top

    13) exit (Reboot)
    14) look on your home screen for app.
  13. akazabam

    akazabam Well-Known Member

    Yep, that's about it. Glad you figured it out :).

Share This Page