[RECOVERY] ClockworkMod Recovery (CWM) 6.0.3.2 [2013/05/13]


Last Updated:

  1. jparasite

    jparasite Well-Known Member

    Disclaimer:
    I do not take any responsibility if this bricks/damages/erases your phone and any of its contents. Use at your own risk!

    Download:

    recovery-cwm-shineplus-6.0.3.2.img
    flash_image

    Previous Versions:
    recovery-cwm-shineplus-5.5.0.4.img

    Instructions:
    superuser/root is required!
    1) Download the first two files to the root directory of your sdcard.
    2) Open up a command prompt and type the following:

    Code (Text):
    1.  
    2. adb shell
    3. su
    4. cp /sdcard/flash_image /data/local/flash_image
    5. chmod 0755 /data/local/flash_image
    6. /data/local/flash_image recovery /sdcard/recovery-cwm-shineplus-6.0.3.2.img
    7. sync
    8. exit
    9. exit
    10. adb reboot recovery
    11.  
    3) Your phone should now boot into CWM-recovery.
    4) Vol+/Vol- to navigate menu, Call button for OK, End-call for back/cancel

    Known Issues:
    - None so far (requires testing).

    Changelog:
    2013/05/13
    - Resynced to latest CM10.1 sources; updated CWM to 6.0.3.2.

    2012/06/30
    -
    Initial release.
    - 'Mount USB Storage' now working.
    - Backlight brightness now set to maximum value on start (63).

    Thanks to:
    - jiilik for providing his CM7 source files that I used in the process of porting
    - karendar for testing and support, and providing a solution to backlight brightness problem
    - CyanogenMod and ClockworkMod team for their open-source projects

    Advertisement
  2. BabblingCamel

    BabblingCamel Member

    Looks awesome. Will flash once I get this thing rooted...

    EDIT: flashed the recovery without any issues. Will update once I've flashed Karendar's custom ROM.
    EDIT: Everything seems to have worked perfectly - Flashed V20B_R2_Custom_Stock.zip without any errors/problems. Kept all my previous apps and settings to boot.
  3. jparasite

    jparasite Well-Known Member


    Thanks for the feedback!

    I'm going to keep trying to get TWRP working as well, and.will probably start work on my Extended Power menu with screenshot support.
  4. karendar

    karendar Well-Known Member

    You know why this recovery rocks? Because it mounts sd-ext properly. Which means if you use app2sd you can backup your app partition! Just for that, it's worth its weight in GOLD! Thanks jparasite, great port! And glad you got the brightness figured out. ;) Reason I gave you 255 is because I was using it on my Galaxy S2... Which seems to have a larger range of brightness levels. :| hehe.

    Tested USB mounting, SD-ext, backup... Haven't restored. And on top of that, it actually detects adb which Amon-RA does not. Only thing missing from this recovery is the touchscreen support which was built into a few recoveries. ;) haha

    **EDIT** BTW, just E-Mailed LG to see when they'll release v20B source... Waiting for an answer. Last time I mailed them, it was uploaded 48 hours later. ;)
  5. karendar

    karendar Well-Known Member

    Just got a reply from LG, they should have source uploaded within a week or two. ;)
  6. jparasite

    jparasite Well-Known Member

    Awesome. As soon as it's up I'll attempt to compile LOL, hopefully it won't blow up this time.
  7. jparasite

    jparasite Well-Known Member

  8. cjmaniac

    cjmaniac Well-Known Member

    I am able to d/l a copy if you want me to upload a copy elsewheres?
  9. karendar

    karendar Well-Known Member

    Yeah, LG fudged up the download. I harrassed them again to fix it. ;) Had to send them a screenshot showing the 404 error before they actually knew what I was talking about! haha.

    It downloads now.
  10. Norwal

    Norwal Member

    I must be missing something. :confused:

    I'm in root, have the # sign and the two files are in the root director of my SD Card. I open ConnectBot, the terminal I have on my phone and type "adb shell" and all I get is permission denied. I've tried with debugging on and off as well as with usb plug in and not. I always get the same error. If I enter SU first, then I get "adb: not found".

    I've googled adb and know that it's related to debugging but have not come across any light bulb moments.

    Any suggestions?

    I'm running 2.3.3 with V20b
  11. Norwal

    Norwal Member

    Ok I now figured out that it a Terminal on my Computer and not the phone and that the usb drivers were corrupted. So now I have the ADB Shell working but "cp: not found" is the next hurdle. I love this stuff.:D
  12. Norwal

    Norwal Member

    I found the solution. For some reason Busybox wasn't working. I found the solution here:
    cp not found on Root Droid

    My phone is backing up as I type.
  13. jparasite

    jparasite Well-Known Member

    Bump, as I've updated CWM to the latest version available. Hopefully there are no bugs with this release.
    androidwkim likes this.
  14. temporary2010

    temporary2010 Active Member

    Thanks. I finally got around to installing it. Never really dealth with ADB stuff before, so I learned a little something :).
    It didn't backup the SD-EXT partition for me, though, but that's minor.

    FYI, "Reboot Menu" by Rice Knight (at Android Market/Play) works for rebooting into recovery.

Share This Page