[RECOVERY] LTE2 Recovery App now with Touch.


  1. PlayfulGod

    PlayfulGod Well-Known Member Developer

    Hello folks, as you all may heard I got a LG Spirit to dev with... and yes I still hate locked bootloaders.

    But I have reworked one of 985hPatKicK's LTE2 recoveries with CWM Touch

    Just download and install the apk.

    lte2_l1m_recovery.apk

    NOTE!!: MAKE A BACKUP!!! If you get stuck in CWM, just restore a backup and it will then boot back to the os.

    Note to Motion user, this recovery is HUGE and almost unreadable on the Motion!!! You been warned. ;)

    Advertisement
    :
  2. GameTheory

    GameTheory Well-Known Member Developer

    PG am I doing something wrong?

    I clicked the top button then after it said ok I clicked on the bottom button to boot into recovery.

    I click on reboot system now in recovery but it boots back into recovery. Tried a few times. I then pulled the battery, but still boots into recovery. lol

    Any ideas?
  3. PlayfulGod

    PlayfulGod Well-Known Member Developer

    let me restore back to stock n see if I can dupe that behavior.
  4. GameTheory

    GameTheory Well-Known Member Developer

    Dang PG don't put yourself through all that for me. lol I'll just unbrick, no biggie. ;)

    Thanks much appreciated.
  5. PlayfulGod

    PlayfulGod Well-Known Member Developer

    too late lol, this is f..... weird too, I been using it all day. :\
    GameTheory likes this.
  6. GameTheory

    GameTheory Well-Known Member Developer

    lol Don't worry about it, I'm prolly the only one since noone else has reported this. Maybe my phone just didn't like the change. lol

    Thanks for checking
  7. PlayfulGod

    PlayfulGod Well-Known Member Developer

    oh it did it to me too, I restored again and it booted normally.
  8. GameTheory

    GameTheory Well-Known Member Developer

    Cool. I wasn't sure if I could restore a backup. Thought I might have to unbrick. Will restore now and report back.
  9. PlayfulGod

    PlayfulGod Well-Known Member Developer

    can sideload a rom too. ;)
  10. GameTheory

    GameTheory Well-Known Member Developer

    Ok I'm back in biz. lol Restored my backup.

    I gotta say this recovery is sweet. It has more options and restores a backup much faster than the non-touch version. Plus I noticed the cube actually spins on this one. lol
  11. OptimusSlime

    OptimusSlime Well-Known Member

    I have the same problem. I uninstalled the old Recovery, then installed the Touch CWM. It seems to have erased everything on my phone except for the Clockwork directory. Wont boot into anything but CWM.

    I tried to restore but it says "Couldn't open directory. No files found" Might be related to my whole phone being erased lmao. Luckily we have that nifty unbrick guide. Geez Playful happy April Fools Day to you too. ;) Just kidding man thanks for all the hard work. We all know this can happen especially with Zero Day apps.

    I am (was) running the Katana aosp fyi...
  12. mario16

    mario16 Well-Known Member

    Well I just installed the touch CWM but haven't tried it out yet but it didn't erase my backup or anything like that, but will see what happens
  13. GameTheory

    GameTheory Well-Known Member Developer

    In the recovery go down more to the other option that says restore from external sd. The restore option at the top gives that error because it's to restore from internal.
  14. OptimusSlime

    OptimusSlime Well-Known Member

    Yeah... I think I reformatted my Ext at some point recently... So thats a no go too. No worries...I screw up my phone every week or so lol. Shoulda seen what I did to my motion. Turns out you shouldn't put random software from a different phone on one. Anyway, not sure what caused he issue for me and GT, but people need to DO A COMPLETE NANDROID BACKUP TO EXT before flashing ;)


    So... the fact that the Touch kept coming on at boot makes me wonder if we can use it as a true CWM and access it if we are bricked normally...

    So after I reinstalled KatanaV2 and the Touch Recovery things now seem ok. Not sure what caused the hiccup but I will leave that to the Pros. :)
  15. I had this baby installed yesterday with no hiccups. It worked perfect out of box. Thanks PG.
  16. PlayfulGod

    PlayfulGod Well-Known Member Developer

    You had it installed with root tho, right?
    Might be the diff there since the root script installs it to system/app.
  17. i ran Dan's root and installed your apk over the original.
  18. mightyantskate

    mightyantskate Well-Known Member

    Man this recovery is super sick, the lg spirit is getting better every day. thanks PG! works perfect
  19. AGLtech

    AGLtech Well-Known Member

    I installed this but the touch points are not correct. I press one and it boots into recovery, i press another and it just reboots. Whoa. Same problems that GT was having
  20. AGLtech

    AGLtech Well-Known Member

    Just unbricked both Spirits which were stuck on the touch recovery. Does not work. It is not worth using touch over the button method. My wife was a little mad that I had to test on her Spirit too but I had to know if this was a wide spread issue.
  21. quechon

    quechon Well-Known Member

    Sorry to here that but i installed it and haven't had any issue with it
  22. PlayfulGod

    PlayfulGod Well-Known Member Developer

    just do a backup & restore it when stuck and it boots back fine.
    I find it very worth it, as I am in recovery ALOT, but I've not experienced any touch points being off and I have been playing with it for the past week. ;)

    Sorry it didnt work for you tho. ;)

    I also have it packed with a modded spirited_away that installs it to system/app (which I havent experienced getting stuck with). It also includes files for linux & osx. ;)
    AGLtech likes this.
  23. GameTheory

    GameTheory Well-Known Member Developer

    PG quick question. I was thinking of doing this....

    What do you think of a flashable pack that deletes the old recovery and flashes your new one to system directory. Do you think I'll have better luck with this?

    I agree... I'm in recovery many times throughout the day so having a bada$$ recovery like this is necessary.

    Also I was reading through the thread and I think some of you guys are getting a bit hasty. Lets keep it cool. ;)
    jasonzech likes this.
  24. PlayfulGod

    PlayfulGod Well-Known Member Developer

    I have no objections to that. ;)
  25. AGLtech

    AGLtech Well-Known Member

    Yeah. Maybe I should have tried to restore, dumb on my part, but I was pretty frustrated. Thanks for the advice and sorry if I got frustrated.
Loading...

Share This Page