[Recovery][Root]Pantech Breakout Root & CWM Recovery All in One


Last Updated:

  1. LunaticSage

    LunaticSage Member

    I have tried to use your script a few times. I select the option to install CWM so I can try to flash your pre-update ROM so I can go through the update. When I do my phone screen goes black and says FastBoot has been enabled. Then it hangs and I get no indication whether or not CWM is installing. I have tried to remove the batter and hold the volume and power key after this but the phone just boots up normally. Am I missing something, or being to impatient or what? Thanks for any help bro.

    Advertisement
  2. mtmichaelson

    mtmichaelson Well-Known Member

    You have to make sure the fastboot drivers are installed. There is one included in the zip.
    maninjapan likes this.
  3. mtmichaelson

    mtmichaelson Well-Known Member

    Make sure you hold search and power until the Pantech splash turns off.
    maninjapan likes this.
  4. grizzled

    grizzled Member

    I am a certified non-techy, so bare with me. what do you mean exactly when you say pull the battery? Are you talking about the phone battery itself?
  5. grizzled

    grizzled Member

    got it
  6. grizzled

    grizzled Member

    I am getting two splash screens. the first lasts only seconds and the second lasts closer to one half minute and i get a phone boot at the end of the second. should i release the power/vol. down after the first or second.
  7. mtmichaelson

    mtmichaelson Well-Known Member

    After the first.
    maninjapan likes this.
  8. grizzled

    grizzled Member

    when do i unplug the usb cable and how do i flash breakoutroot.zip
  9. mtmichaelson

    mtmichaelson Well-Known Member

    When done installing cwm, then unplug and reboot into recovery. When in recovery choose install zip from sdcard, then choose zip from sdcard, then select breakoutroot.zip.
    maninjapan likes this.
  10. grizzled

    grizzled Member

    I am not doing something right. these are the steps i have been following:
    run recovery
    enter 1 then enter 2 then exit
    unplug usb
    take out battery
    immedietely press volume down and power button and replace battery
    pantech splash comes up for about 10 seconds.
    when it flashes to a second pantech splash i release the buttons
    it boots the phone every time. There is no hesitation between the first and second splashes.
    sorry to trouble you so much but i seem to get half way there and get shortsheeted.
  11. Bitthebeast

    Bitthebeast Member

    So i did all the steps, except for the part where you need to hold down Volume Down and Power. That never did anything but boot the phone for me, so i held down Search and Power instead, and that brought me to CWM. I'm guessing this is temporary from what i've read here. If it is, how do i get the Volume Down + Power button combo step to work?
  12. grizzled

    grizzled Member

    this is the only way i was able to get to CWM. Will this work and if so what steps do we follow for rooting?
  13. Bitthebeast

    Bitthebeast Member

    If you download the "BreakoutRoot.zip" and put it on your SD Card, then do the steps that we did, you can flash it from CWM and i imagine that should Root the phone. My phone was already rooted so i am not entirely sure though.
  14. mtmichaelson

    mtmichaelson Well-Known Member

    Guys, I am sorry! I mainly dev for the LG Revolution and we use volume down and power. I must have not been thinking right when I posted lol. I have now corrected it in the op. Thanks!
    maninjapan likes this.
  15. grizzled

    grizzled Member

    got into CWM and it said it couldn't open sdcard/update. no such file or directory. It looks like i have things in place but something must be missing.
  16. mtmichaelson

    mtmichaelson Well-Known Member

    Don't do the install update.zip. Do the choose zip from sdcard.
    maninjapan likes this.
  17. srefsn1

    srefsn1 New Member

    Take it from my double unrooting and triple rooting experience. There are TWO updates to complete for your breakout. Keep checking for new updates until your phone says you have the most recent. <sigh>
  18. belovedson

    belovedson Active Member

    can someone help me

    i downloaded all the zip files. i installed adb and fastboot and connected the phone. by the way i am familiar with rooting this is like my 8th android phone. i get to the recoveryaio.bat and for the life of me i cant get it to find the phone.

    ive installed adb and fast after mounting the usb. weird how you have to mount it twice for the computer to recognize. i have mounted once and tried yet no availability. i tried different usb ports but each time my phone is recognized. i tried different cable. hmm what to do

    TROUBLESHOOTING

    I have win 7 64bt and for whatever reason after trying the various motorola drivers i could not get the verizon app that installs the correct drivers to pop up. I tried an xp machine and it worked.

    Is there way to fix this problem? I think because my computer has various drivers from multiple phones may be the problem. I unloaded all the drivers, apps, etc tied to other phones but it did not help
  19. mtmichaelson

    mtmichaelson Well-Known Member

    Only mount once for adb. The second actually mounts the USB.
    maninjapan likes this.
  20. maninjapan

    maninjapan Member

    Hey michaelson thanks for the root- it worked great! :)
    Am I correct in assuming that there are no custom ROM's yet available for the breakout? I used the ROM installer and tried to put Clockworkmod on and the breakout but it wasn't listed. Am I missing something or is the breakout still too new for a custom ROM? Thanks again for all your help!
  21. mtmichaelson

    mtmichaelson Well-Known Member

    I am slowly working on one right now. I have had a lot on my plate the past couple weeks though. Will be back at work on it soon!
  22. maninjapan

    maninjapan Member

    Thanks michaelson, looking forward to it!
  23. blackdawn

    blackdawn New Member

    mtmichaelson

    What needs to be done/removed to install Verizon updates?
    I tried to use the unroot, and then change back to stock recovery but the update still failed....

    I did try to use zergroot and superoneclick 2.2 prior to finding your method of rooting, because neither of those stuck after reboot for some reason.
  24. alanski

    alanski New Member

    MTMichaelson - Thank you so much for this, when I get out of my financial rut I will donate whatever I am able to.

    First of all it is amazing that you came up with this, many, many, many thanks. Double thanks for such a wonderful guide.
    Not wanting to take anything away from it, since it is simple to the point.

    However as a newbie, I was unaware of several things, that caused a lot of pain headache and endless googling to figure out.
    And also getting the sequence of events just right.
    There are also some nuances that will help the technically challenged.

    Preliminary, pre-requisite steps to insure a smooth operation

    1) Make sure the correct drivers are installed.
    What does that actually mean?
    At first I thought it meant, that when you plugin the USB cord the computer automatically detects the drivers and installs them.
    Yes that is partially true, but that's not ALL drivers.
    On my Pantech, I had to do something else.
    First of all you may need to try different USB ports on your computer until this next step pops up.
    As soon as the USB is plugged in, an Auto-Play popup should display, the first item says something like
    "E: BootLoader"
    where E is whatever drive letter your computer assigned to your phone.

    I clicked this, and it prompted some Verizon installation.
    THESE are the drivers that are needed.

    If that doesn't happen, then your computer has not loaded the correct drivers for your phone, and you will not be able to proceed.

    I would recommend you call your phone provider or manufacturer to help sync your phone with the computer.


    2) The zip files mentioned in the post (Root and Unroot), that you download, need to be physically transferred over to your phone's
    SD Card. Without this, you can't flash the phone.
    Select the USB Debugging mode via the Phone Settings -> Application -> Development.
    Go into mass storage mode, and check Windows Explorer to make sure your phone shows up as a drive in My Computer.
    Then drag and drop the Root and Unroot zip files from your computer to your phone's SD card folder.

    When #1 and #2 have been done and resolved then you can proceed with the instructions as normal.
    You just keep pressing "Next key" until the prompt tells you it has been installed.
    Then your Pantech will be on a black screen that says something like "Android Development Mode......Fastboot yadda yadda..."

    3) I did not know a couple of things WTF does flash mean. Flash the phone, flash the root, flash the zip file. flash <this> ;-)
    j/k. I also did not know what Battery Pull or pull the Battery meant.

    4) So once you get to the black screen "Android Development mode, etc" and the CVW has finished the install, unplug the USB cable
    from the phone and the computer.
    At this point no communication is required between the computer and phone. That chapter is over.

    5) So with the black Android development mode screen on your Pantech, this is what a Battery Pull means.
    With the Phone still on, you take the battery out. Then you wait 30 seconds, and put the Battery back in.

    5 a) Next is important --- now to power the phone back on, Press the Power Button and Search key simultaneously.
    Be careful not to press any other key by mistake, like I did the first 4 times, otherwise the phone will boot up and you will have
    to start from Square 1 again. This has been described and explained perfectly in all the other posts. You hold it through the Pantech
    splash screen. If you see a Verizon or 4GLTE screen, then go directly to jail. ;-) Means you have to start over.

    6) So ok I'll attempt to explain what "flash the file" means.
    When you are in the root recovery mode of your phone (dos or unix looking text with options), there is an option to load and install a zip file that is on your SD card.

    If you got here that means you inherit the factory and will go on a glass elevator trip with Willy Wonka to the land of the Oompa Loompas.

    You will see a command line looking options, and you are in root.
    One of the options in the root menu says something about install from sd
    and also install zip from sd, or something to that effect.
    You select that option, and then it shows you the file structure of the sd file and you find the appropriate zip file that you
    copied over from teh computer.
    You will get confirmation that it completed successfully.
    press the back button to go back to the main menu and reboot.

    7) One thing I did separately from this was to install the SuperUser app from the marketplace.
    Once I rebooted as root, I opened this application, and in preferences selected the option to Su from binary.

    8) I downloaded and used Titanium Backup to remove my Verizon crapware. The only way this worked was when I was rooted, and then opened
    the SuperUser app and did the su binary thing. Then I opened the Titanium Backup up, it prompts you that you are using
    super user privileges. Then it lets you uninstall protected and system apps.

    Hope this helps and offers some more clarification to users who were stuck or confused like me.
  25. rabidhunter

    rabidhunter Well-Known Member Contributor

    Okay, so I ran the RecoveryAIO.bat successfully and then added the .zip files. I unplugged phone, removed battery, then held power and search button together. Then a box and the Android dude appear for a little bit, then the Android dude is there but there's a big yellow triangle with an "!" in it. Am I not waiting long enough?

Share This Page