Removing Facebook from Precedent!Tips


Last Updated:

  1. wolfy02

    wolfy02 Member

    So many of you have probably noticed that you can't remove facebook from this phone. I tried multiple apps that were supposed to work after rooting to no avail. I was finally able to remove it from the memory so it won't come back after a reboot. Surprisingly it's not very hard, and can be done in about 15-30 minutes. I would like to state before going on about this, that if you mess up your phone, I'm not responsible. This tut is only what worked for me, and it may not even apply to you. As the old phrase goes -- measure twice, cut once.

    ==========================Apps needed==============================

    You will need to have your phone rooted first with the rtto
    Then you will need to install SSHDroid

    You will also need to clear any of the data from facebook using the application info you get from settings>applications>manage applications.

    Now run SSHDroid so it can gain superuser access. After you start the App, it will begin running an ssh server on your phone. To access it from windows get PuTTY. Should be the first in the exe table.

    ==========================Getting Under the hood==============================

    Open PuTTY, in Hostname put your IP address SSHDroid gave you. It will be something like sftp://root@xxx.xxx.x.xxx -- just put the xxx.xxx.x.xxx -- Example: 192.168.1.105
    Port will be 22, and hit open. Wait a few seconds, and it will ask for login. Default for SSHDroid is root password admin.

    Now that you're officially inside your android's system, BE CAREFUL! Anything you screw up here could brick your phone at the least. there will be some commands that we use, in face all the commands that your phone can use is located in /system/xbin/. Some of the commands you will be using are as follows:

    cd - change directory
    ls - lists files in current directory or directory specified Ex: ls system/app/
    rm - remove a file
    rmdir - removes a directory
    mount - mounts a filesystem
    reboot - reboots the system
    find - finds a file

    At any time you can type any of the commands with --help, and it will give you options and examples on how to use it. try ls --help

    ==========================The Nitty-Gritty==============================

    first you want to cd to the root of the filesystem do this by entering cd / .
    the bit where your cursor is should now look like this ~ # . Now that you're at the root, we want to remount the directory system with read/write privileges. we do this by entering, mount -o remount ro/rw system . This so so we are able to remove the facebook apk backup that was installed on the system from factory.

    now we just cd into the app directory inside the system directory. cd system/app . list the files within this directory with ls. You should see a file named FBAndroid-X.X.X_preload.apk (the x.x.x is the version number mine was 1.5.4). Once you have verified the presence of this file remove it! rm FBAndroid-X.X.X_preload.apk

    we aren't done yet. There is one more file that needs to be removed. cd into the directory /data/data/ cd /data/data/ . now enter ls . look for a directory named com.facebook.katana/. Find it? good! cd into it. now there should only be one lib directory in it, remove it with rmdir lib . now cd .. , and rmdir com.facebook.katana/

    finally reboot your phone, cause you're done! reboot -f -d 2 after your phone reboots facebook no longer shows up in any of the lists or updates. Congratulations!

    ==========================Quick and Clean==============================

    as an alternative tut I will give the commands needed to do this in the order in which they need to be executed.

    Code (Text):
    1.  
    2. [B]cd /
    3. mount -o remount ro/rw system
    4. ls system/app
    5. rm system/app/FBAndroid-X.X.X_preload.apk
    6. rmdir /data/data/com.facebook.katana/lib
    7. rmdir /data/data/com.facebook.katana
    8. reboot -f -d 2[/B]
    9.  

    Advertisement
  2. wolfy02

    wolfy02 Member

    By the way, I just tried this with the other useless apps, like ThinkFree and Books and it totally worked.
  3. sillyname

    sillyname Well-Known Member

    With my rooted phone I used Total Commader for Android...

    Total Commander - Android

    I explored to the appropriate system directory, enabled read/write and deleted the offending files... I suppose this method would be too easy. ;)
    wolfy02 likes this.
  4. wolfy02

    wolfy02 Member

    that's awesome, total commander is definitely worth it.
  5. akashik

    akashik Well-Known Member

    Have you tried Titanium Backup Pro? Under 'Backup/Restore' select the app you want to remove, then select 'Uninstall'.

    I pulled a lot of bloatware out of my phone that way that wouldn't uninstall any other way. A lot easier than digging through code.
  6. wolfy02

    wolfy02 Member

    i did try multiple apps that were supposed to remove bloatware, but alas this is the only one that worked for me. thanks for the heads up though :D
  7. akashik

    akashik Well-Known Member

    No problem. I came across that myself by accident while looking through the options one day.

    Funny story, since my last post I nuked my phone changing the partitions on my SD card so have spent half my morning in Titanium re-removing bloatware, and restoring most of my apps.
  8. maxtease

    maxtease Member

    My phones rooted, I use link2sd to remove all my apps and to save major space.
  9. wolfy02

    wolfy02 Member

    thats no fun. hope all went well. just be glad you didn't brick it :D
  10. akashik

    akashik Well-Known Member

    Oh it was bricked. Thankfully reflashing it through Odin brought it back. All went well, and it running great again, thanks. :)
  11. frrrosty

    frrrosty New Member

    OK, I'm trying this, but putty doesn't do anything after I type "root" and hit open. It just skipd down a line and I can't type anything else!!!

    WTF???

    BTW, you could have mentioned this was going to WIPE my phone. Thx loads

    Screw this, it JUST DOESNT WORK

    This server is INCREDIBLY SLOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOW!

    So, I try Total Commander, all I get is "ERROR PROCESSING PURCHASE - DF-BPA-13". Funny, it's a FREE app

    So, I install Total commander by downloading on PC and moving it onto the phone and running it.
    BUT, all it does is show directory after directory. WHERE IS FACEBOOK SO I CAN GET RID OF IT???????
  12. frrrosty

    frrrosty New Member

    Care to give just a LITTLE more detail? What directory? What file?

    You guys kill me, you take the time to post some info, but you leave out what REALLY MEANS SOMETHING!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    WOLFY, RIGHT NOW I WANT TO FIND YOU AND KILL YOU.
    THE APP WIPED EVERYTHING.
    F*CK YOU.
    AFTER THIS, NO APPS WILL DOWNLOAD, ERROR 921, ERROR THIS, ERROR THAT.

    TAKE MY ADVISE AND DON'T FOLLOW WOLFY'S "HELPFUL" SUGGESTIONS.
    hE MUST WORK FOR APPLE
  13. akashik

    akashik Well-Known Member

    If you can get to a factory reset under settings, try that to get your phone back to normal. If that works and the market is working again, and you still want to pull out the bloatware, go for the simple approach.

    Titanium Backup

    I mentioned it earlier in this thread.

    I don't mind digging into my phone. I run Pandabomb's CM7 and run V6 Supercharger via Script Manager whenever it's updated, but when it came to pulling out crap on the stock ROM, Titanium was the pain free way. Just avoid system apps your phone actually needs to run.

    As you've discovered though, your mileage may vary on the success of anything you do to your phone - cause, you know, those apple employees right? ;)
  14. londonamour

    londonamour Member

    This is the part I'm having trouble with. I give it the password of admin and it keeps saying access is denied. I've tried typing with one finger, holding my breath, crossing my toes...access is still denied. What am I doing wrong?

    In the meantime, I'll look for another SSH client to use, and if that doesn't work, I'll try to find another method of uninstalling those useless pre-installed apps that are taking up all my internal memory.

    Thanks!

Share This Page