Root Removing stock apps with Root Explorer

Discussion in 'Android Devices' started by Jack321, Apr 14, 2010.

  1. Jack321

    Jack321 Active Member
    28

    I know this is obvious but ...
    ***Please proceed at your own risk***

    I am new to this (less than a week) and I removed everything with root explorer (and it was so simple).
    You can get it from the market.
    I would recommend it if you are not used to linux commands.
    It was well worth the two dollars for me.

    The main thing to know is r/w (read/write) vs. r/o (read only).
    It is just as it says - r/o will only let you read files, while r/w will let you read AND write files (which includes move and delete).

    Your phone needs to be rooted for this to work!
    After all, we are in the "All things root section".

    Here's what I did:
    1. remove sd card from phone and use pc to create new folder on sd card - "deleted" or you can use Astro to do this
    2. put sd card back in phone
    3. open root explorer
    4. It works like windows - the apps are in system>app
    5. find the app you want to remove (start with bejeweled)
    6. make sure the top text says "Mounted as r/w" (press the grey rectangle if it doesn't)
    7. long press the app and select "move"
    8. select menu>home
    9. now go to sd card>deleted instead of system>app
    10. you will see "paste" on the bottom - press it
    11. repeat as necessary

    I did it this way because I wanted to maintain copies.
    You could just delete rather than move.
    You can also remove any .odex files of the same name.
    Please do a search if you want to know which apps to remove or what their names are.

    I hope this helps! :D
     

    Advertisement

  2. latinmaxima

    latinmaxima Well-Known Member
    103

    Oct 15, 2009
    835
    111
    103
    Customer Service/ Quality Assurance Supervisor
    Richmond ,KY
    Nice simple write up. Worked very well for me. This should help many on here get the job done!
     
  3. duratime

    duratime Well-Known Member
    43

    Mar 2, 2010
    454
    44
    43
    Cali
    I tried it and moved Bejeweled to the SD card, but everytime I went back to the system/apps folder it was still there. I'm I missing something? I may have just figured it out. I think I need a bigger SD card.

    Edit: I wasn't reading the Mount R/O thing right. I thought the grey box told you the status, but th status is to the left, that is simply the toggle to switch the status. Thanks for the help.
     
  4. Jack321

    Jack321 Active Member
    28

    Just trying to do my part. Thanks for feedback, I changed OP.
     
  5. ovrrdrive

    ovrrdrive Well-Known Member
    163

    Dec 18, 2009
    1,215
    389
    163
    Any idea why I can't change it to r/w in the system folder?

    It would imply that I wasn't rooted but as far as I can tell I am. I installed the dd10 this morning from the sd card.

    I can change from r/w to r/o in any of the folders but the system folders.
     
  6. Jack321

    Jack321 Active Member
    28

    First - Installing DD10 alone does not root your phone (even if it was rooted).
    You must then install the joeykrim-SDX-a2.1-root-v5.zip found here

    Second - There are several ways to verify you are rooted. I know of one:
    • download "connectbot" from the market and open it
    • change "ssh" to "local" and give it any name
    • type "su" at the $
    • if it changes to #, your phone is rooted

    Good Luck!
     
  7. NOMster

    NOMster Well-Known Member
    78

    Nov 10, 2009
    429
    109
    78
    GA
    or, if you cant change to rw in root explorer, you're not rooted.
     
  8. ovrrdrive

    ovrrdrive Well-Known Member
    163

    Dec 18, 2009
    1,215
    389
    163
    I can change the $ to # in connectbot, and I can change to rw in root explorer but not in the system folder...
     
  9. Jack321

    Jack321 Active Member
    28

    I don't know, sorry. :rolleyes:

    If it were me, I would start over with a DD03+joey recovery flash.
    But, that is a lot of work ...
     
  10. ovrrdrive

    ovrrdrive Well-Known Member
    163

    Dec 18, 2009
    1,215
    389
    163
    Sorry, I wasn't necessarily asking you I was just piggybacking. I didn't see a need to start a new thread about the same thing right below yours.

    I have a feeling its something simple. I don't think its worth it to go flashng again because I have a perfect install on the phone and don't want to risk it. I actually don't even have a need to delete the sprint apps. I just wanted to. ;)
     
  11. duratime

    duratime Well-Known Member
    43

    Mar 2, 2010
    454
    44
    43
    Cali
    Make sure you didn't do something stupid like I did. I thought the grey box told me the status, but it's asking if you want to switch status. The other thing I did (which I was too embarrassed to admit) was that I left the computer mounted to the SD card, which messed things up a bit, but had a different result than what your reporting. Just throwing ideas out.
     
  12. f1fanatic

    f1fanatic Well-Known Member
    16

    Apr 18, 2010
    49
    1
    16
    I've got 2.1 and root. But when I go to make a folder on the SD card called "deleted" it says my disk is "write" protected. How do I fix that?
     
  13. ub3r-l33ch

    ub3r-l33ch Well-Known Member
    16

    Dec 7, 2009
    74
    3
    16
    Or you can use Titanium Backup to remove apps with root, and it's free.
     
    nyrblue35 and gmjlopez like this.
  14. Eazail70x7

    Eazail70x7 Well-Known Member
    153

    Mar 13, 2010
    1,612
    108
    153
    Baltimore, Maryland

    Actually, its not necessarily the case. I had root explorer and was rooted but still it would not let me change it to rw. The reason was because I was using an older version of root explorer. Once I got a newer one, boom!! It works :D
     
  15. Jack321

    Jack321 Active Member
    28

    I'm not sure but it sounds like the tab on your card may be set to lock?
    I removed the card from my phone and used my laptop to create the folder.
     
  16. Eazail70x7

    Eazail70x7 Well-Known Member
    153

    Mar 13, 2010
    1,612
    108
    153
    Baltimore, Maryland
    Is it safe to remove the sprint football app? If so, how do I remove it? I can't find it in the system/app directory. Little help?
     
  17. GitUsUM

    GitUsUM New Member
    5

    May 10, 2010
    1
    0
    5


    nfl-prod-release.apk and yes you can remove it
     
  18. Eazail70x7

    Eazail70x7 Well-Known Member
    153

    Mar 13, 2010
    1,612
    108
    153
    Baltimore, Maryland
    I removed the nfl one you mentioned but the sprint football is still installed
     
  19. latinmaxima

    latinmaxima Well-Known Member
    103

    Oct 15, 2009
    835
    111
    103
    Customer Service/ Quality Assurance Supervisor
    Richmond ,KY
    Are you looking in the applications list in the 2.1 applications manager. If so just click uninstall from there and it will be completely gone.
     
  20. gmjlopez

    gmjlopez Well-Known Member
    36

    Jan 22, 2010
    100
    4
    36
    Male
    G-town, CT
    It worked great. Thanks!
     
  21. craigpicc

    craigpicc Active Member
    16

    Nov 14, 2009
    41
    1
    16
    is there somewhere i can find a list of deletedable apps...thx in advance.
     
  22. latinmaxima

    latinmaxima Well-Known Member
    103

    Oct 15, 2009
    835
    111
    103
    Customer Service/ Quality Assurance Supervisor
    Richmond ,KY
  23. rmac1813

    rmac1813 Member
    5

    Nov 8, 2009
    7
    0
    5
    Las Vegas
    (after using this app to remove a bunch of stuff) i'm already seeing better battery life out of DD10. great thread.
     
  24. pookahbot

    pookahbot New Member
    5

    Jun 24, 2010
    2
    0
    5
    I've followed the tutorials and rooted my Moment--I can change the $ to # in ConnectBot. But when I try to go into /system/app, I get a permission denied message. Not at all familiar with this process, just want to get rid of the dumb stock apps I'll never use!
     
  25. Jack321

    Jack321 Active Member
    28

    Are you using root explorer? I don't remember seeing "permission denied" in root explorer. If you are getting that from connectbot, someone else will need to help you or maybe you need to check another thread. The reason I paid for root explorer is so that I would not have to use linux commands.
    Sorry :(
     

Share This Page

Loading...