ReRooting After ODIN NAE LoadingSupport


  1. marx2k

    marx2k Well-Known Member

    Earlier today I downloaded the OTA update for my Sprint S4. This killed my wifi. I then used Odin to load NAE and this fixed my wifi issues but of course I was no longer rooter. I then loaded Odin back up and loaded CF-Auto-Root-jfltespr-jfltespr-sphl720.tar.md5 and automatically rebooted. Immediately upon rebooting, I was taken to the red-android load screen that shows the root exploit being loaded with no issues. Afterwards, the phone reboots but there is no SuperSU binary installed. I then go to the Play Store and manually download it but when opening it, the application informs me that it can't find the SU binary on the phone.

    Does anyone have any thoughts on this? I've tried this multiple times as well as trying to have Odin not reboot the phone and instead doing it manually but still no dice.

    Advertisement
    :
  2. dynomot

    dynomot VIP Member VIP Member

    Not sure why an OTA update would kill your Wi-Fi, odd, but still.

    The only thing I can think of why you can't root is that your using CF rooting .tar for the last Jellybean firmware (4.3) and the update is KitKat (4.4.2). Other than that I'm stumped, but that is nothing new. Someone will know why your having problems, and be able to sort you out I'm sure. :)
  3. Rukbat

    Rukbat Well-Known Member

    1) Minor point - su (case counts) is a binary, SuperSU is an app/

    2) Try using Kingo to root. (If the update was to 4.3 or 4.3.2 it will work. If it was to 4.4 it probably won't, and you'll have to wait until they figure out an exploit for that.)

    Any thoughts as to why su didn't get copied? Probably because the exploit used by CF-Auto_Root doesn't work in the new version you updated to. Since the exploit didn't work, nothing got temporary root, so it couldn't copy a file to /system/bin, which is where the binary gets copied to.
  4. marx2k

    marx2k Well-Known Member

    This same lack of wifi thing happened in the update to MK2

    I'm thinking that the update to 4.4.2 also renders this version of the CF rooting file unusable :/
  5. marx2k

    marx2k Well-Known Member

    The update was, indeed, to 4.4.2. What's interesting is that I can install SuperSU from the play store as I mentioned, but then when I try to install root through CF, it deletes that app so when I reboot, it's gone again. :D
  6. supreme83

    supreme83 Member

    Dont know if you ever resolved this but 2 things:

    1 I rooted a Sprint s4 yesterday with latest cf build. Make sure after running cf, you go to the play store and update SuperSU the app. after it has updated, open it and allow it to disable Knox, if need be. It will give you the message tht binary needs to be updated. If you are on data or wifi to allow it to install the binary let it do so by pressing normal.

    2 You can use Odin (try the same build that came with cf)to install a custom recovery and install latest SuperSU update zip via custom recovery.

    in case anyone runs across this thread, I can confirm both methods worked on the Sprint S4 without any problems.
Loading...

Share This Page