[RESOLVED + FIX] GTA Vice City (Car freezing)Support


  1. jokerpks

    jokerpks Well-Known Member

    Hello has anyone tried playing GTA Vice City on this phone. It appears that the cutscenes are blurry and whenever you get into a car the screen freezes. This issue is know on many devices and normally can be fixed by increasing the resolution to 100% however that doesn't work on this device. GTA San Andreas works fine even with max setting, I am guessing this might be an issue with the GPU Andreno 305. Does anyone have a fix?

    EDIT: ISSUE HAS BEEN RESOLVED THROUGH THE FOLLOWING METHOD
    http://androidforums.com/metropcs-o...ta-vc-freezing-fix-game-graphic-enhancer.html

    Advertisement
  2. JVene

    JVene Well-Known Member

    As a developer, thoroughly familiar with these technologies, my reaction (yes, I've tried all of these) is that Rockstar, the company behind the GTA series, does not yet know how to write 3D rendering engines for OpenGL ES 2 while accounting for the various devices.

    There may never be a solution unless Rockstar corrects their code.

    I've seen this problem in a number of engines, including supposedly high end engines.

    The problem may stick around in various titles for another year before the engine providers get around to figuring out how to accommodate OpenGL ES on the Android ecosystem.

    For targets in other 'closed' operating systems, the challenge is much simpler. If the developer need only consider a couple dozen devices they can exhaustively prove their work on all of them rather cheaply, relatively speaking. On Android, however, with so many combinations of device and OS support details the problem is nearly insurmountable without a certain level of disciplined engineering.
  3. BryanBreezy

    BryanBreezy Member

    Have they put out any updates lately? I don't own the game myself, but this sounds like an update would fix it.
  4. jokerpks

    jokerpks Well-Known Member


    I just checked they last updated last year in September. I doubt they will update this anymore unless a lot of people report this issue to them.
  5. DesolationJones

    DesolationJones Active Member

    I tried installing Vice City a while ago and I got the same problem so you're not alone. GTA3 worked though.
  6. jokerpks

    jokerpks Well-Known Member

    update: Issue has been resolved solution found in the thread

Share This Page