restorng galaxy s2 to stock rom after root and brick?


Last Updated: 2011-12-26 18:31:59
  1. peterdan1506

    peterdan1506 Well-Known Member

    how can i install a custom rom Cyanogen mod 7 over another old custom rom(cognition).. i intalled the wrong one!! i tried already using clockwork recovery tool, just selecting the zip of cyanogen but now my phone is stuck on the galaxy ss II GTI9100T screen with a yellow triangle at the bottom.... plz help!!!

    the only thing i can do is put the phone in download mode!!

    Advertisement
  2. peterdan1506

    peterdan1506 Well-Known Member

    i need 2 restore my galaxy s2 back 2 a stock rom after i tried rooting it and was bricked. I can only get into download mode
    my counter is at 4(whats this mean?)

    how do i get it back 2 a stock rom? all it does is keep reloading the samsung logo!

    be GREAT if someone could help me!!!
  3. jaliy

    jaliy Well-Known Member

    [removed by mod]
  4. Slug

    Slug Check six! Moderator

    Don't panic - it's not bricked because

    That's good. You can fix stuff that way. When it's completely dead and unresponsive that's when you panic. ;)

    You have used Odin four times to flash firmware, kernel or modem to the handset.

    Will it boot into recovery (HOME+VOL_UP+POWER)? If so use the "reset" option to do a full wipe - that often fixes the issue.

    If not you'll need to flash a stock firmware to your handset with Odin. There a link to the XDA thread containing stock firmwares in the Guide sticky. You can find a link to another topic containing carrier-specific firmware at the top of that XDA one.
  5. peterdan1506

    peterdan1506 Well-Known Member

    ok, thanks. it does go into recovery mode
    i just got a stock rom, my phone goes into the home screen now... but what do i do from here?
    do i have 2 use my carrier specific rom?
  6. Slug

    Slug Check six! Moderator

    Last time I looked at CM7 it required TWO flashes; the first one only flashed the kernel and gave exactly the same symptom as you have. If you can boot into recovery try flashing the CM7 file again.
  7. Slug

    Slug Check six! Moderator

    From your other thread I'm assuming you were installing CM7, correct? If so read my reply there - you may only need to boot into recovery and flash CM7 a second time.
  8. peterdan1506

    peterdan1506 Well-Known Member

    how do i do that? im currently running a stock rom kf4
    there is no clockwork recovery mod on this rom so wouldnt i need 2 re-root it using cf root?
    and if so, where do i find a kf4 cf root thingy? the 1 i have doesnt work
  9. Slug

    Slug Check six! Moderator

    Okay, way too much confusion between the two threads.... I've merged them so let's start fresh.

    Your firmware is KF4, so to root that you should use a KF4 CF-Root package found here. Assuming that your handset is now booting normally to the Android home screen and functioning correctly:

    Extract the TAR file from the ZIP you download
    Open Odin on the PC and enter the TAR in the PDA section.
    DO NOT change any of the default settings.
    Restart the handset in Download Mode
    Connect it to the PC via the USB cable
    When Odin's ID:COM light shows yellow hit the Start button.
    Wait!
    The handset will reboot when complete; disconnect the USB cable
    Once back at the home screen, you should find the CWM and Superuser apps in the drawer.
    Congratulations - you have root access. :)
  10. peterdan1506

    peterdan1506 Well-Known Member

    the kf4 root package didnt work in odin, said failed... i used a different one and now have cwm...what now 2 install cyanogen7?
  11. Slug

    Slug Check six! Moderator

    In theory anything prior to KF4 should work, I think. Did you try both KF4 packages?
  12. peterdan1506

    peterdan1506 Well-Known Member

    i used kh1 cf root and i got cyanogen working... thank you soooo much 4 ur help man :) i really really appreciate it so much :)
  13. Slug

    Slug Check six! Moderator

    Glad to hear you're up and running, Peter. Enjoy CM7! :D
  14. peterdan1506

    peterdan1506 Well-Known Member

    thank u once again :) it looks totally different now?? menus have changed and all, is that right? and where is the android market??

    also one last thing... what if i ever wanted 2 go back 2 the stock firmware 2 get android 4.0 when it comes out if i choose???.. and how do i unroot in order 2 do this?
  15. Slug

    Slug Check six! Moderator

    You won't have any core Google apps as the code is proprietary and third-party developers aren't permitted to redistribute them as part of their ROM. The latest Gapps package is available here.
  16. Bottlez

    Bottlez New Member

    Thank you lord (that would be SLUG). I did a reset, and the damn phone worked again. Otherwise it would have been my second brick in a row:-D.

    Anyway, thanks

Share This Page