Retrieving your MSL (ENABLE WIN 7 HIDDEN ADMIN)


  1. WhisperPntr

    WhisperPntr Well-Known Member

    If it has been 2-3 weeks since I've posted, it is likely I am no longer maintaining this thread. Unless there is still no other method to obtain the MSL, please consider this method obsolete.

    UPDATE:
    Potential breakthrough! I have discovered that this method works more or less consistently on Windows 7 Ultimate. I therefore believe this is a permissions / UAC issue and will go ahead and try the install on a windows 7 home build.
    In the meantime, everyone who has windows 7 pro, home, vista go ahead and enable the hidden Administrator login
    Enable the (Hidden) Administrator Account on Windows 7 or Vista - How-To Geek
    Then do everything from that account
    For those who are on windows xp 32/x64 or windows 95 I do NOT know if this method will work for you. Chances are because this already flakes out for newer systems, you'll have driver issues and since I do not have a development xp system in my possession I cannot try the hundreds of different troubleshooting techniques I have used over these past few days to see if I can force it to work.

    Disclaimer

    Note that though I am continuing to work on a universal fix this is STILL a VERY frustrating method of pulling your MSL. It may be easier to grab your MSL from VM and several team viewer sessions attest to the difficulty in grabbing it.
    If you still want to go forward be sure to update your system drivers and also be prepared to use another computer.

    Special thanks to

    Salvy512, creators of QPST and HxD hex editor - without them this guide would be impossible
    mmarz's memory guide at xda - Which this guide is partly based on
    jcase - for his continuing development, rooting expertise, and continuing assistance with this phone
    androidforums - for hosting our development on their forum

    Troubleshooting (updated)
    Issue #1 Corrupt/zeroed out bins (still not fixed)
    Potential fixes in order of suggestion are:
    granting full administrative rights to drive C:
    A factory reset
    updating your system's usb drivers
    reinstalling your drivers and connecting to another port in the following manner

    1. With your phone DISCONNECTED Go to your start menu and uninstall LG Mobile Update
    2. Go to your control panel and uninstall
      LG USB WML Modem Driver
      LG SP USB Driver
      LG United Mobile Driver
    3. reboot (may be optional but best to do so)
    4. download LGVM696.zip
    5. Open the Zip and drag the LGVM696 directly to the root of your C drive. (do not let it create two LGVM696 directories -ie C:\LGVM696\LGVM696)
    6. Run the 3 exe files
      C:\LGVM696\LGUnitedMobileDriver_S4981MAN37AP22_ML_ WHQL_Ver_3.7.2.exe
      C:\LGVM696\LG_SmartPhone\LGSmartPhone_ModemlinkDUN Drive_WHQL_ML_Ver_1.0.exe
      C:\LGVM696\LG_SmartPhone\LGWindowsMobile_USBDriver _WHQL_ML_Ver_1.0.exe
    7. Connect your phone to a DIFFERENT USB port and Start your phone normally.
    8. Ensure that all on the Development page is ticked (Settings -> applications -> Development). Be sure to let the drivers install
    9. After the drivers successfully install unplug the phone and power it off
    10. Start it in download mode
    11. You should get the com port successfully (if the modem driver installation fails ignore it)
    12. Go into QPST config, remove all the existing ports, then add the new detected and listed port.
    13. Open up QPST Memory debug and the top left icon should say "COM# Phone in Download Mode" (look at the attached img), not anything else.
    14. You now should have a proper and working driver set.

    Retrieving your MSL

    Those in the know
    If you know the relevant commands and programs, with a properly installed driver set and activated phone, propagate the memory with SPC attempts by doing ##DATA#, ##DIAG#, ##RTN#, etc. (note we are still verifying which command propagates the bin with an MSL). Then pull ebi0_cs0.bin from your phone in emergency mode and find the hex offset near 07496A80 to locate the 6 digit msl.

    What is needed

    Phone on STOCK firmware (build zv4.gwk74, android 2.3.7, kernel 2.6.35.11)
    Windows OS (You can try the procedure by substituting the programs below compiled for your OS)
    LGVM696.zip (Windows Drivers, see instructions below)
    QPST - RAR compressed 2.7 build 366 OR you can try to google a non compressed version
    HxD Hexedit - or any hex editor you prefer
    7zip - or an unrarer, I just prefer 7zip

    FINDING YOUR MSL FROM A CLEAN SYSTEM

    1. Install the LGVM696 Drivers
      1. download LGVM696.zip
      2. Open the Zip and drag the LGVM696 directly to the root of your C drive. (do not let it create two LGVM696 directories -ie C:\LGVM696\LGVM696)
      3. Run the 3 exe files
        C:\LGVM696\LGUnitedMobileDriver_S4981MAN37AP22_ML_ WHQL_Ver_3.7.2.exe
        C:\LGVM696\LG_SmartPhone\LGSmartPhone_ModemlinkDUN Drive_WHQL_ML_Ver_1.0.exe
        C:\LGVM696\LG_SmartPhone\LGWindowsMobile_USBDriver _WHQL_ML_Ver_1.0.exe
      4. Start your phone normally, Enable Development, let the drivers install and enter in program commands.
        • Go to Settings -> Applications -> Development and tick all on that page.
        • Let the drivers install on your computer before the next step
        • Dial ##DATA# click on Data Profile then edit. Enter in your SPC twice so that it reboots. It should reboot into charging rather than resetting.
      5. Unplug the USB Cable
      6. While pressing and holding on the entire Volume Up/Down rocker button plug in the USB Cable. It should state download is in progress. This is download mode and one of two drivers should install (if the modem fails that is fine)
        • Download Mode should display an LG logo, have a circular double arrow then text that says "Download is in progress. Do not disconnect cable".
      7. Go to Control panel -> Hardware and Sound -> Devices and Printers -> Device Manager and then see if there is a port item called "LGE Android Platform USB Serial Port".
    2. Install and setup QPST
      1. From the start menu find the QPST -> "QPST Configuration"
      2. Remove ALL existing ports, then click "Add New Port".
      3. You should now see a new window which has a list or a single com port. Choose the com port that is in the following format:
        COM # USB/QC Diagnostic
        Your phone should appear in the the "Active Phones" tab.
      4. Exit out of QPST Configuration and Run QPST -> "Memory Debug App"
      5. Click "Browse", choose the COM port, click ok and the Icon on the top left should state "COM # Phone in Download mode"
      6. Tick "Use Unframed Memory Reads" (see img below) then press "Get Regions".
      7. To save space, deselect all, select a "SaveTo" Directory. When done you should now have a ebi0_cs0.bin file in the folder. In process you should see the following screen.
        [​IMG]
    3. Install HxD Hexedit and open your bin with a hex editor
      1. Open Hxd Hex Editor from the start menu (location is "<Your Program Files install Directory>\HxD\HxD.exe" )then drag the file "ebi0_cs0.bin" your self-selected SaveTo directory to the program.
        Note!!f If ebi0_cs0.bin is nothing more than 0s and/or fs then your file is corrupt / unfinished. If your file doesn't look empty and contains data, zip ONLY ebi_cs0.bin. The file size of the zip file should NOT be less than 20mb.
      2. If the file looks as though it has valid data, ALT TAB back to the QPST Memory debugger, then click "Reset Phone" and exit out of the program.
      3. Back in HxD editor Press CTRL G or from the menu SEARCH>GO TO. A popup will appear. Leave the options as is and input "07496A80" in the search field. This is the general Hex Offset where the MSL should be.
      4. Looking first at the general area then slightly up and down, find code that looks similar to the following pattern.

        ................
        ..........d&#8212;...8
        47iA.....d&#8212;...84
        9n

    Advertisement
    :
  2. irkillcactuar

    irkillcactuar Member

    Worked well up until "Use Unframed Memory Reads"

    I'm not seeing this anywhere...
  3. Hashtag

    Hashtag Well-Known Member

    Same here, there was no unframed memory read option. But, I went ahead and did it anyways, then when I pulled it up in the Hex reader the only things that were in the bin file were 0,F,., and weird y's.
  4. WhisperPntr

    WhisperPntr Well-Known Member

    First, did you flash to a different rom?

    Second, try downloading this version. http://conflipper.com/Software/QPST_2.7_366.rar

    it's a check box on the screen before get regions. Does your window look like the attached jpg??
    [​IMG]

    Third, this option must be available and ticked or else will give an error.

    Lastly if it borks out try leaving all bins selected in step 10. It takes longer but perhaps it works better. For my phone it was the same either way. I deselected it as it was faster and took less space.

    IIRC you reflashed your rom right? If so then you are not using the default firmware and therefore would be using a different bin from us.
    However if you are using the default firmware, then feel free to zip up the file then upload to mediafire or 4share.

    Attached Files:

  5. dobbs69

    dobbs69 Well-Known Member

    Well I tried with qpst 2.7 366 and I did get the unframed memory option however same results. All y's. Searched for an hour to no avail.
  6. kwknott

    kwknott Well-Known Member Developer

    I tried the procedure and couldn't locate my msl. Since I have it already I did a search and didn't get any results. Was it maybe in one of the other bin files? All I get when scrolling is the weird y's
  7. glbell62

    glbell62 Member

    this worked perfectly, however windows 7 64 bit didn't load drivers for CDC etc.. so I repartitioned hard drive and installed windows 7 32 bit and it loaded perfectly. I was able to change msl through CDMA WS and dump NV Ram etc..

    Thanks Again

    Gary
    kwknott likes this.
  8. kwknott

    kwknott Well-Known Member Developer

    I'll try another version of windows and see if I have any luck
  9. Hashtag

    Hashtag Well-Known Member

    Just letting you know that your link got pulled for violating the terms of service. If I may suggest one, SendSpace is very good about letting almost anything be on their servers :p thats who I use anyways.
  10. Hashtag

    Hashtag Well-Known Member

    That was on my old OE. I am now using my replacement OE that they sent. And I tried with all of the boxes checked as well and I didn't see anything. Could you reupload that link that got taken down please?
  11. BliND123

    BliND123 Well-Known Member

    I guess you mean this file since other one still seems to work. QPST_2.7_366.rar

    If you click the "Show more sites" I just went to a random one that was using a different host for what seems to be the same file. Check it out and see if it's the same. Not sure what goes on in that other forum I got it from so not sure I can post the link I found it on, should be the second one I got from the "Show more sites".
  12. WhisperPntr

    WhisperPntr Well-Known Member

    kwknott, dobbs, Hashtag:
    Go to your phone and check your build and kernel version.
    If it's newer than mine then I will try to update to that one.

    Also if you have the bins, zip it and send it to me. I use 7zip but a normal zip program should be fine. Also I replaced the link with the new version QPST_2.7_366.

    http://conflipper.com/Software/QPST_2.7_366.rar

    But again try Blind's link as well if it fails for you somehow
  13. hakdunn

    hakdunn New Member

    Hi I try this with windows 7 64 and windows xp 32. I got the file but I can't find the msl.I hope I am not the only one with this issues.
  14. ktb83

    ktb83 Well-Known Member

    Hello,

    I was able to save the bin files. However, as some other members have posted, I was also unable to locate the MSL using HxD. I did spend a decent amount of time looking through the ebi0_cs0.bin file up and down beginning from the recommended hex offset.

    Here is my phone info:
    LG Optimus Elite
    Android version: 2.3.7
    Baseband version: VM696ZV4-M8655L-AABBQMLYM-414005
    Kernel version: 2.6.35.11
    Build number: ZV4.GWK74
    Software version: VM696ZV4
    Hardware version: Rev.1.1

    I'll try to send WhisperPntr the bin files in a PM or follow up post since this is my first post and I'm unable to post links. I appreciate any help I can get.

    Thanks in advance.
  15. dobbs69

    dobbs69 Well-Known Member

    Here's my info:
    Build- ZV4 GWK74
    Kernel- 2.6.35.11

    I'll have to get 7-zip, later today I'll send you the bin. THANKS for your help !
  16. WhisperPntr

    WhisperPntr Well-Known Member

    A note, the ebi0_cs0 file will still be large (>20mb) even after zipping. Also if it contains all 0's or Fs then your file was corrupted.

    Without my being next to you I cannot troubleshoot what is wrong but do any of you receive error messages?

    Did you enable all under development for the phone itself?
    Switch on the phone normally then go to Settings -> Applications -> Development
    Tick all on that page, then reset in Download mode and try again.

    Also did you download the latest LG drivers?
    LG LGVM696 Support: Find Manuals & Warranty Info | LG USA

    I also do not know definitively if jcase's driver needs to be register along with LGNPT but doesn't hurt to try. I have that reggied as well as Android SDK installed.
  17. WhisperPntr

    WhisperPntr Well-Known Member

    I am using windows 64 bit and take care to run as administrator and also ensure that all the drivers and com ports are registered as well as the phone has development mode turned on. I do have all the other development softwares though such as DFX, LGNPST, Android SDK, and CDMA. Of those 4 I would say Android SDK and LGNPST with the drivers from jcase would make more of a difference.

    You likely have a zeroed out or incomplete ebi0_cs0.bin. Easiest way to figure out if it is corrupt is zip it. If the resulting zip is anything below 20ish megs, something is definitely wrong with it.

    I updated my first post and included a link for LG drivers. did you install it? Do you see the com port? Does it detect your phone?
  18. ktb83

    ktb83 Well-Known Member

    Good news!

    - I re-installed the USB driver for Windows from LG.

    - I checked all boxes on the phone in Settings -> Applications -> Development (the first time I only had USB debugging checked)

    - I ran QPST Configuration, QPST Memory Debug App as Administrator

    - This time I unchecked all the regions (which I was able to uncheck) in QPST Memory Debug App, so it only saved the MANDATORY ones (the first time I left them all checked)

    - The ebi0_cs0.bin, ebi0_cs1.bin, and load.cmm files came out the same exact size as my first attempt. However, for whatever reason, the content of ebi0_cs0.bin was much different.

    - This time the MSL was located exactly at hex offset 07496A80.

    I'm not sure what made the difference.

    Thank you for the help, WhisperPntr.
    WhisperPntr likes this.
  19. WhisperPntr

    WhisperPntr Well-Known Member

    good job ktb. Yea it could be any of the above or the fiddly file versions of the software. Also you don't have lgnpst or android sdk installed correct? If you do I may have to include that as a possible fix though I highly doubt it matters.
  20. ktb83

    ktb83 Well-Known Member


    I've had the Android SDK installed for a long time, so it was present on my first attempt.

    I have not yet installed LGNPST. I just uploaded it to www.virustotal.com:
    https://www.virustotal.com/file/06a3b7c297f749a121d339ccd2d70423fb3b0acc88ea16cbc67f6562631de59a/analysis/1339374083/

    It's interesting that virustotal.com's copy of NOD32 did not detect it as a threat. Their copies of Panda, Symantec and VIPRE do detect it as a threat.
  21. dobbs69

    dobbs69 Well-Known Member

    I have a question. Why won't qpst or the memory debug app work for me if I run it as administrator? Everytime I run it , it will not show any com/ports but if I just run it normal it shows my phone and appears to work except all I see is yyyyyyyyy.....
  22. WhisperPntr

    WhisperPntr Well-Known Member

    I've never had that issue dobs. likely a bug with the program though run qpst configuration as administrator too. It needs to detect the com port and if it doesn't then it's a LG driver or software related issue
  23. JayySkittles

    JayySkittles Member

    Heyy guys. I need help. Mine is giving me an error and saying that the port may be busy or not working properly, any helpp?
  24. WhisperPntr

    WhisperPntr Well-Known Member

    First what step are you on? Did you start in emergency/download mode? I made a correction to the guide as the phone must be in download mode to register a com port.

    Did you look up in the control panel -> Device manager to make sure that you see a Ports > LGE Android Platform USB Serial Port > Properties > Port Settings > Advanced > COM port number ?

    Also go to QPST Configuration and select the port on the left hand side list then click add new port.
  25. JayySkittles

    JayySkittles Member

    Yeah, Im to the point where Im adding the new port. But for some reason it shows it as a LGE AndroidNet USB Serial Port. It will show up in QPST as the correct COM# which happens to be 10. It just says its busy and/or not working properly.

    I also have the same build, kernal, and version as you do.
Loading...

Share This Page