Rezound will not start, HELP!


Last Updated:

  1. EddieE

    EddieE Member

    My Rezound will not turn on at all. I rooted it using Scotty's root guide soon after I purchased it in late February. But I never installed any other ROMS or that s-off thingy, it was never wet or dropped. It was working fine up until this morning when I tried to turn it on there was nothing. Several times I tried removing the battery, pushing the start and volume buttons at the same time and still nothing. When I first plugged in the charger the red indicator light came on for a couple of seconds and went back off. Now when I plug in the charger I get nothing, no lights at all. I did get the red light to come on once and only once when I connected the Rezound to my computer using the USB cable. But there was no connection with my system. Can someone tell me what is going on? Could it possibly be a bad battery? Thanks.

    Advertisement
  2. scotty85

    scotty85 Guides Guide

    it could be a bad battery,or a dead battery and a bad charger :eek:

    if you leave the phone plugged in for 15 minutes doesnt the chzarge light come on?

    when the battery is really,really dead,you wont get a light at first. after a few minuts,youll get a blinking light,then after a few more minutes,a solid orange charge light. give it another few minutes and it should power on.

    if things dont happen in that sequence,id prolly take your battery and phone to a vzw store and have them put it into a phone and power it on. then take a charged battery and put it into your rezound. they should have no prollem doing this for you,as youll likely buy a battery if yours is dead.

    then thunderbolt does take a dimensionally same battery,wich will turn on and run the phone. however,it will not charge in the rezound,nor will it read the available charge,or a battery temp. so you could toss in a TB battery just for some peace of mind your phone still works. the TB will happily run and charge the rezound battery,so you could toss the rezond battery into a TB and see if it powers on and charges.

    failing all that,it sounds like some sort of hardware failure :(
  3. EddieE

    EddieE Member

    Thanks Scotty, you are always helpful. I decided to take the Resound to Best Buy where I purchased it last night. I have their mobile phone insurance. I was a little concerned that they would find out the phone was rooted and deny coverage. Anyway they said they are sure the problem is the charging port. There is nothing wrong with the battery it just was not getting a charge. They said they had a couple others with the same issue and decided to give me a rapid exchange instead of sending it off for repairs which could take weeks. I still have to wait a couple of days for the new phone though.
  4. scotty85

    scotty85 Guides Guide

    that sucks to be without a phone for a couple days,but good to hear they are taking care of you :)
  5. pwned

    pwned Well-Known Member

    Did you happen to have cwm recovery

Share This Page