Ring delay


Last Updated:

  1. agemme27

    agemme27 Well-Known Member This Topic's Starter

    Joined:
    Nov 13, 2009
    Messages:
    59
    Likes Received:
    0
    Is there a way to eliminate the ringer delay? It seems like forever before my phone starts to make any noise to notify me of a phone call.
     

    Advertisement
  2. YankeeDudeL

    YankeeDudeL Well-Known Member

    Joined:
    Oct 25, 2009
    Messages:
    2,170
    Likes Received:
    516
    Ok, that sounds like a good way of describing it. I also have a thread going about this, but thus far only one guy has responded and he's having the same problem.
     
  3. Fabolous

    Fabolous Superuser VIP Member

    Joined:
    Nov 7, 2009
    Messages:
    3,635
    Likes Received:
    2,126
    I think this requires root, but you can pull build.prop and modify a line along the lines of:

    ring.delay = 3000

    or something to that extent. I usually just change it to 1

    Then you push it back to /system
     
    f12 likes this.
  4. skunkpbguy

    skunkpbguy Well-Known Member

    Joined:
    Dec 12, 2009
    Messages:
    296
    Likes Received:
    8
    I know this sounds simplistic, but have you tried various ring tones?
     
  5. f12

    f12 Active Member

    Joined:
    Feb 21, 2010
    Messages:
    25
    Likes Received:
    1
    wait nvm i think i got it, thanks so much though
     
  6. spazma7ik

    spazma7ik Well-Known Member

    Joined:
    Dec 29, 2009
    Messages:
    66
    Likes Received:
    1
    Would you happen to have your phone rooted and overclocked? Cause if you set profiles for your sleep/standby for anything around 125/250, there can be a problem with the phone waking up and ringing.
     
  7. YankeeDudeL

    YankeeDudeL Well-Known Member

    Joined:
    Oct 25, 2009
    Messages:
    2,170
    Likes Received:
    516
    Man, how come everyone's responding to this and not my thread? Is my 24 hour deoderant wearing off? lol

    I am rooted, but this has been an issue since before I ever obtained it. But mine is specific to when my Droid is set to both ring and vibrate. When I uncheck vibrate, there's no longer any delay.

    I could give Fabolous' answer a go, but I think that would solve the OPs problem, not mine.
     
  8. agemme27

    agemme27 Well-Known Member This Topic's Starter

    Joined:
    Nov 13, 2009
    Messages:
    59
    Likes Received:
    0
    Ok Fabolous, thanks. Do you want to give me a step by step? I'm running bugless beast and a the sholes overclock kernal.
     
  9. Fabolous

    Fabolous Superuser VIP Member

    Joined:
    Nov 7, 2009
    Messages:
    3,635
    Likes Received:
    2,126
    From a terminal window:

    adb pull /system/build.prop build.prop

    Open the build.prop file with notepad or wordpad w/e

    Find the following line:

    ro.telephony.call_ring.delay=3000

    Change 3000 to 1, or delete the line entirely, save the file

    Then, back in the terminal:

    adb shell mount -o remount,rw /dev/mtd/mtdblock4 /system

    adb push build.prop /system/
     
  10. agemme27

    agemme27 Well-Known Member This Topic's Starter

    Joined:
    Nov 13, 2009
    Messages:
    59
    Likes Received:
    0
    Thanks again:D
     
  11. crankerchick

    crankerchick Well-Known Member

    Joined:
    Dec 30, 2009
    Messages:
    593
    Likes Received:
    113
    on my 2 previous phones running windows mobile, there was a service code to dial to change the slot cycle index to help with the problem. Those phones both shipped with SCI of 2 and I always changed it to 1. I have searched both here and on Droidforums but I can't seem to find an answer for the Droid. There was a code posted in the Eris forum but it doesn't seem to work on my droid.

    Fabolous, is your method changing how long the phone takes to ring once it is notified of a call? Versus the sci which is how often the phone checks pings the tower for an incoming call?
     
  12. YankeeDudeL

    YankeeDudeL Well-Known Member

    Joined:
    Oct 25, 2009
    Messages:
    2,170
    Likes Received:
    516
    I don't have an issue when vibrate is off, it's when it's enabled. When it is, my ring doesn't kick in till way after vibrating. It's not an issue when it's on me, but if it's charging, or I'm just not near it, I can't get to it in time.

    Sure, it's simply a matter of being cognizant of the situations and whether or not to enable it. But I was wondering if everyone had this issue, or if it's just me.
     

Share This Page

Loading...