1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Ringtone problem when plugged into computer


Last Updated:

  1. ffolliet

    ffolliet Member This Topic's Starter

    Joined:
    Dec 25, 2008
    Messages:
    10
    Likes Received:
    1
    Discovered a problem today which is reasonably obvious when I think about it.

    I have various customised ringtones. They (necessarily) live on the sd card.

    when the phone is plugged into a computer it essentially takes the card OUT of the phone loop to allow access.

    When the phone rings it can't "find" the customised tone (as the sd card "isn't there) and so defaults to something on the phone itself. which was inaudible.

    Any thoughts?
     

    Advertisement
  2. Cryptic79

    Cryptic79 VIP Member VIP Member

    Joined:
    Sep 10, 2008
    Messages:
    576
    Likes Received:
    24
    I don't understand it, but that was the same as my Dash.
     
  3. dkaufman1

    dkaufman1 Well-Known Member

    Joined:
    Oct 24, 2008
    Messages:
    1,202
    Likes Received:
    29
    Good catch... I will run some tests. I use ringroid, not sure the location of created ringtones...but easy to check.
     
  4. dkaufman1

    dkaufman1 Well-Known Member

    Joined:
    Oct 24, 2008
    Messages:
    1,202
    Likes Received:
    29
    Ok I have some very interesting results....when I connect my device the card is unmounted, so I see the notification of the USB icon in the status bar. This is important for this test, please note:

    When I call the phone while connected via USB but unmounted and the phone is on the home screen, the call comes in and my ringtone of choice is used.

    When I call the phone while connected via USB but unmounted and the phone is on the notification tab screen, the device NEVER rings and my voicemail picks up rather quickly.

    When I choose to mount the USB drive, and call the device while on either the home or the notification screen the device rings with a new tone. Sounds like an office ringer, a bunch of short beeps in a row.

    Interestingly while in this last configuration, I got a txt and my normal alert tone is a ringroid created alert and all that happened was a double vibrate in quick succession. Again no noise was generated.
     
  5. ffolliet

    ffolliet Member This Topic's Starter

    Joined:
    Dec 25, 2008
    Messages:
    10
    Likes Received:
    1
    glad it's not just me. bit of an issue really, particularly as i use any random computer i'm near as a "mobile" charger.

    the "problem" isn't really ringdroid but the phone/operating system itself.

    anyone seeing the same with other ringtone apps?
     
  6. dkaufman1

    dkaufman1 Well-Known Member

    Joined:
    Oct 24, 2008
    Messages:
    1,202
    Likes Received:
    29
    Hopefully someone from Android's team knows of this or sees it. I wonder if you can log it somewhere for them as a bug?
     

Share This Page

Loading...