RK2918 Android TV Box with 4x USB - ROOTED firmware + manual!


  1. sphp

    sphp Member

    Hello guys,

    this is a manual how to upgrade your Android TV Box RK2918 with 4x USB looking like this with a rooted Firmware:

    [​IMG]

    There are some versions of this Box in blue and black color as well as with and without android tv logo. Important is that you have the Box with 4x USB (NOT 2x or 3x USB).

    I rooted my 4x USB RK2918 Android TV Box. Upgrading the Box is just a few steps away:

    1) Download Firmware from Uploaded.to
    EDIT 2012-03-04, added new mirror: https://rapidshare.com/files/3368714344/update.img

    2) Copy update.img on SD Card root folder, insert SD Card into Box
    3) Start Box and wait for upgrade dialog, confirm update
    4) Wait while Box restarts and update performs
    5) You're finished and have a fully rooted box


    Content of Firmware
    -Made from original firmware, Android 2.3.1
    -Removed default homescreen, replaced by ADW Launcher (regular phone homescreen)
    -Added Superuser + full root
    -Removed Youtube App (old non working version, can be replaced by new one)
    -Full support of upgrading via SD Card, like in the origin firmware


    I got some root apps like droid VNC server running well.

    Enjoy the freedom and homescreen of this rooted firmware.


    Disclaimer: I am not responsible for any damages resulting in this upgrade. I tested with my box and everthing works fine, as it is made from origin firmware. You may loose your warranty if you do the steps above.

    Attached Files:


    Advertisement
    :
  2. ltaronger

    ltaronger New Member

    This firmware is valid for 3 USB? or only for 4 USB devices?
    Thanks
    erik1978 and PIERINO like this.
  3. sphp

    sphp Member

    I can't test 3 USB devices, so only valid for 4 USB at this moment.
  4. sphp

    sphp Member

    No more replies on this? Nobody tested this firmware? It works really good. :)

    I am running it now without TV, controlling the TV Box via my PC over Wifi (+Webkey for Android) - that really rocks!
    delloite likes this.
  5. delloite

    delloite New Member

    I have tested it and it is working beautifull :).
    Thank you.

    Can you please confirm that cifs manager is working.
    I have problem with it.
  6. delloite

    delloite New Member

    ok , here is the right procedure



    3) Install a Termminal emulator
    4) Download this cifs.ko here : cifs.ko download
    4.1) download slow-work.ko from here : slow-work.ko download
    5) goto terminal EMU
    5) issues the su command to gain admin access..
    6) copy the files u downloaded and place it where-ever u like...
    6.1) insmod slow-work.ko -from the directory where u put it on your tab
    7) insmod cifs.ko - from the directory where u put it on your tab
    8 ) lsmod - to verify its loaded..
    9) now you can manually mount a samba/windows share using the following command..

    mount -t cifs -o username=SHAREUSERNAME,password=PASSWORDFORSHARE //ip-location-for-the-share/share-name /where-u-want-to-mount-the-share..
  7. PIERINO

    PIERINO New Member

    THANKS, BUT IF IS POSIBLE TO GET THE FILE IN ANOTHET LINK, I HAVE PROBLEMS TRYING TO DOWNLOAD IN UPLOADED SITE.

    I AM TALKING ABAUT YOUR ROM

    pdangelavitti@gmail.com

    PIERINO
  8. sphp

    sphp Member

    mmelani likes this.
  9. mmelani

    mmelani New Member

    Thanks a lot for your time to share this information!!!!!!
    I have recently purchased an RK2918 android tv box OEM (ebay) with 4 usb ports, and will be made a test with your firmware asap! (the original first screen is very poor and ugly)
    In order to made a good work in case of errors, can you provide me the source of the original firmware (or any information about how I can find it?
    Thank you very much for your help!
    best regards!

    Martin
  10. harshana8181

    harshana8181 New Member

    HI SPHP,

    Thanks for the great update, it has given my "HDMP0071" unbranded 4usb port (ebay orded) android tv a new smart look.

    I faced two minor issues after the update-
    1- after super user update it's giving an error saying some binary's could not update but you can continue with the save version ( this is not the exact error, I just typed by memory)

    2- After the Market updated to Play Store it didn't identify the wifi connection ( rest was ok - youtube and web browser worked) then I uninstalled the update and reinstalled and the problem goes of till the next reboot. this is very annoying. please let me know how to fix it.


    Will there be any chance of getting ICS for the TV in the near future? Hope u will help us with it.

    Thank you once again for the marvelous update.
    Take Care.
  11. harshana8181

    harshana8181 New Member


    Hi Martin,

    I updated my ebay ordered 4port "HDMP0071" android tv .. the update is great. for more info read my previous comment which I wrote to thank "SPHP" for releasing the update.

    if you need more info contact harshana.ada@gmail.com.

    have a nice day...!:)
  12. teofilbellmare

    teofilbellmare New Member

    It is nice.
  13. Hi,

    i finally installed the firmware to my box. works very well, didnt get into any troubles until today. :) thank you very much.

    still, the problems with USB port and wireless keyboard touchpad remain unsolved. the "cursor" gets stuck on the lower end of the screen, when using the touchpad of my wireless keyboard. i ordered a new one from the seller to check if the old one is borken, but still same problem. any idea on how to fix such an USB problem? any ideas what it can be?

    link to problem topic:
    http://androidforums.com/google-tv/413090-r-box-rockchip-2918-google-tv-4.html#post4080075


    furthermore, any idea if it is possible to run ICS android 4.0 on this box? i found firmware in another topic in this forum... you guys think this could work in this box as well?

    link:
    http://androidforums.com/google-tv/513616-android-4-0-tv-box-advice.html#post4102029
  14. sphp

    sphp Member

  15. Tonipetit

    Tonipetit Member

    Any have the original firmware ?

    Toni
  16. adzmr2

    adzmr2 Member

    Hey

    I have one of these boxes with the 4 usb's, i was planning to use it as a car pc due to its size, but i would really like to be able to use a 7" touchscreen 7 Inch HD Touchscreen Car Monitor (HDMI, AV, VGA) | eBay which uses egalax drivers on windows and linux, and also gps which again the drivers are available for linux, the gps is a bu-353 eBay - The UK's Online Marketplace and the manufacture says the drivers should work, buy how can these drivers be incorporated into the kernel? Can anyone help me at all?

    Adz
  17. adzmr2

    adzmr2 Member

    this update works great thanks for uploading this SPHP
  18. ai25

    ai25 New Member

    Hi everyone.
    If someone try with an 3usb port device. Please let me know, ok!
    Thanks
  19. rahulsri1111

    rahulsri1111 New Member

    I have been looking for the ICS 4.0 firmware for the same box (RK2918 - with 4 USB ports) but i could not find anywhere. I couldn't even find 2.3.4 firmware.
    Currently my wifi doesnt works with the default stock rom (2.3.1) which came with the box. So i was thinking if i could get hold of 2.3.4 or 4.0 (ics) and that might fix the wifi problem also if i m lucky. Any help would be appreciated.
  20. sphp

    sphp Member

    Wifi works fine with stock and this rooted version. You might open your TV Box and look if antenna is build in and connected correctly to the Wifi module. This is no software issue and it won't be solved by a firmware update!

    There'll be an ICS-update, according to a Chinese seller. But it will take one month or longer to release and I don't know if it's true or they just want to sell more boxes by refering to some update. So, we'll see...
    rahulsri1111 likes this.
  21. sphp

    sphp Member

    OK, soldered a VGA port on the platine, but VGA output doesn't work.

    Does anybody know, how I can activate the VGA output (bus)? There is a version of this box with VGA output, so it must be possible to activate.
  22. ai25

    ai25 New Member

    Hello!
    I download Netflix on my 4usb device and I have a LED FULL HD TV, but I cant wach Netflix on HD.
    Someone can help? What can I do?
    Thanks!
  23. barghy

    barghy New Member

    @sphp : i try to update with firm posted but after reboot, not start . Not any light that indicate runing or stand-by, not blinking. Is like android TV is dead. HDMI not find any devices...
    Pls help me...
  24. pequenomestrex

    pequenomestrex New Member

    I found it:

    championasia.en.alibaba.com/product/536171297-210342992/HD_1080P_Android_4_0_TV_box_RK2918_video_talk.html

    So I believe it's possible to install ICS in RK2918, this model have some different specifications but the CPU is the same... maybe it's possible to have an update soon to our model.
Loading...

Share This Page