RK2918 Android TV Box with 4x USB - ROOTED firmware + manual!


  1. barghy

    barghy New Member

    I need it good firmware for RK2918 Android TV Box with 4x USB
    I try firm posted in link and answer is:
    <layer 7.2> Download firmware fail.
    Thx in adv.
  2. rio14

    rio14 New Member

  3. Penguin73

    Penguin73 Member

    Great JOb,

    installed and its working very good only is going to break in play when wifi is on. Can u tell me how i can change launcher and uninstall adw and what can i do to play dts films and put out Dolby Digital sound through the optical ? Can i change the Video Player to MX PLAYER ?

    THX ALEXANDER
  4. rahulsri1111

    rahulsri1111 New Member

    @sphp - I changed the wifi encryption from WEP to WPA2 and the wifi started working. So for some strange reason it wasn't able to work with WEP secured Wifi. Thanks
  5. zetobias

    zetobias New Member

    PLease, did you resolve this problem? I have the same!
  6. zetobias

    zetobias New Member

  7. sphp

    sphp Member

    This has to be some hardware dependent problem. I use a Logitech VX nano mouse and it works fine.
  8. Homerepairman

    Homerepairman Member

    Question for original post.
    What model number is that TV box ?
    Iam looking at what I believe is the same model.
    The one Iam looking at is TVTB0032--at Alibaba.
    Thanks
  9. Penguin73

    Penguin73 Member

    Hi go and delete flash player and then go to market and load down the new one. Pls can u send me some pictures of the firmware from the blue box and do u now the date of it. Can your box play dts sound through the optical cable ?

    Alexander
  10. bluetthompson

    bluetthompson New Member

    Thank you for all the work with rooting the box. It is a most excellent job.

    Is it possible to change the /system directory from cramfs to ext3? Also it would be nice to have uinput module enabled so we can use the droidmote server application from google play.

    For some reason I cannot get my box connected to windows 7 via USB for flashing with RkTools. I have tried all the combinations using USB male-male(A-A) , windows simply does not see my device.

    Once again, thanks for all the great work.

    Cheers,
    Trev
  11. Kasbert

    Kasbert New Member

    I tried using ext3 for /system, but the filesystem got corrupted immediately after mounting it read/write. My theory is that because the internal flash has 16kb erase size block and the file system has 1kb block size, the flash driver implements the writing by read-modify-write cycle. I guess this is error prone even without bugs in the driver. The kernel ext3 fs won't allow 16kb block size.

    The tv box has a modified /init which automatically runs e2fsck for /data and /cache. It also runs mke2fs and creates a fresh filesystem if mount fails. I guess this is to overcome the unstability of the system.

    Someone said that ext2 would be better for flash devices, because ext3 journaling will cause more writes to the device. Unfortunately this tv box supports only ext3. So I tried using fuse-ext2 and I even had some luck using 16kB block ext2 for /cache. /cache is not used for anything so it is good for trying things out. I tried using it for /data too but it a bit too unstable. The system boots but the Android animation starts over and over.

    When using rktools, did you follow these instructions http://androidforums.com/google-tv/505559-flashing-android-tv-box-one-four-usb.html ?

  12. ez2kal

    ez2kal Member

    Hi folks,

    I have the same RK2918 tv box 4 port USB.

    I have these issues:

    1- I connected the wireless mouse to the box and it worked for 10 minutes and then stopped and now doesn't show it at all , i tried 2 different wireless mice (both on original and the rooted one) but doesn't seem working at all!
    Answer: problem was the type of mouse used)

    2- In rooted version, Google Play can NOT connect to internet!
    Answer: I got the solution for this. After updating the dat and time, you MUST put it back on Automatic. (otherwise at the next boot the date goes back and that confuses the Google Play and wont work)


    Thanks
  13. leikinm

    leikinm New Member

    hallo everybody. i flashed my box with this firmware,and after this my remote don't respond . i don't now what to do.
    maybe you have some ideas for this
    some more question : can i flash the box with firmware for model with 2 or 3 usb
    thanks
  14. jpzaes

    jpzaes New Member

    HI, do you have the original firmware... or any good media center?..

    I trieed to donwload but not success.

    Thanks.
  15. androiddev561

    androiddev561 New Member

    I have the android tv box Rk29_RBox V1 with 2 usb ports and 1 usb for device.how to root my device?I tried your procedure it did not work.Can somebody help me?
  16. alois

    alois New Member

    Hello, I need the original firmware.
    on that box with 4x USB

    best thanks in advance
  17. plopesrepaa

    plopesrepaa New Member

    Hi, I'm new in the forum, and I've already read everything on this post, but I have this problem. Different from all replies here, I have an built in board, probably the same board that have in side your TV box, the problem is that my board came without the SD card extra board. So I want to ask if anybody here tried this upgrade with the USB port.

    Thanks
  18. androiddev561

    androiddev561 New Member

    I tried your solution but it didnt work cause my device Rk2918 TV Box has 3 USB.If you find any solution to root my device for upgrading it to ICS please let me know.
    my email id is androiddev561@gmail.com
    Thanks in advance
  19. browset

    browset New Member

    How can I do a hard reset for this device. I managed to brick mine
    after flashing.
  20. ez2kal

    ez2kal Member

    this is so strange! i have tried 2 different mice and also my new IpaZ wireless keyboard+mouse and in each case, the mouse is connected but stock in the bottom of the screen. When i restart, the mouse is active for about a minute and i can use it but out of a sudden, jumps back in the bottom of the screen and only has horizontal movements so practically cant use it to do anything!

    Any idea?
  21. ukko

    ukko Member

    Hi,
    I have the same issue, works fine with wired mouse but my 2.4ghz Ipaz goes to the bottom of the screen after 1 minute of use.

    I also tried with a BT iPaz but it was not detected.

    Anyone have the solution to make 2.4ghz mouse working or for activate BT?

    regards
    Christophe.
  22. pequenomestrex

    pequenomestrex New Member

    I have this:

    ebay.com/itm/2-4GHz-Mini-Wireless-QWERTY-Keyboard-Touchpad-USB-Adapter-HTPC-IPTV-PAD-PC-TV-/260953114143?pt=PCA_Mice_Trackballs&hash=item3cc204861f

    And works fine. Ipaz doesn't work, I ask to 3 eBay sellers and all answer th iPaz not work on this box.
  23. ez2kal

    ez2kal Member

    hgjhgjhk.jpg item doesn't exist! what is the name? could be easier to search if i knew the name. Are you talking about this:
  24. ukko

    ukko Member

    Thanks pequenomestrex, I'll order this one, is it the one at $34?

    @ez2kal: search with the item number : 260953114143
  25. pequenomestrex

    pequenomestrex New Member

    Just put 'www.' before link.

    The name is 'Rii Mini i8'
Loading...

Share This Page